Follow us on Twitter X-Cart on Facebook Wiki
Shopping cart software Solutions for online shops and malls

X-payments problem after server change
 
Reply
   X-Cart forums > X-Payments > X-Payments issues & questions
 
Thread Tools
  #1  
Old 05-03-2019, 01:12 PM
 
joestern joestern is offline
 

Senior Member
  
Join Date: Apr 2004
Posts: 176
 

Default X-payments problem after server change

We migrated to a new server with PHP 7.3 and other updates.

Whenever we try to process an order, we get 'Error: The card information entered is not valid. Please check and try again.'

This is happening on version 3.1.4 and 3.1.5.

It looks like the Luhn calculation is failing every time even with valid card numbers?

Do you have any suggestions as to what server settings we might look to to determine why this problem occurs?
__________________
X-Cart version 4.7.11
Reply With Quote
  #2  
Old 05-03-2019, 02:20 PM
 
joestern joestern is offline
 

Senior Member
  
Join Date: Apr 2004
Posts: 176
 

Default Re: X-payments problem after server change

OK - I think I can get past the problem by basically disabling the Luhn calculation/verification.

By following the error logs, I got to "lib/XPay/VSNode/StringRegExp.php file (67:preg_match)" and basically can get past the problem by just removing the exclamation point (!) in that line.

As best I can tell, PHP 7.3 changes the behavior of preg_match a bit, and while I don't know how to trace the test backwards, I think that the formatting of the test is the issue here.
__________________
X-Cart version 4.7.11
Reply With Quote
  #3  
Old 05-05-2019, 08:26 PM
  ambal's Avatar 
ambal ambal is offline
 

X-Cart team
  
Join Date: Sep 2002
Posts: 4,102
 

Default Re: X-payments problem after server change

Hi Jeff,

X-Payments 3.x has not been adapted for PHP7.3 yet.
__________________
Sincerely yours,
Alex Mulin
VP of business development for X-Cart
X-Payments project manager
Reply With Quote
  #4  
Old 05-06-2019, 09:23 AM
 
joestern joestern is offline
 

Senior Member
  
Join Date: Apr 2004
Posts: 176
 

Default Re: X-payments problem after server change

Quote:
Originally Posted by ambal
Hi Jeff,

X-Payments 3.x has not been adapted for PHP7.3 yet.

What is the latest version of PHP that is compatible with X-Payments 3.x?
__________________
X-Cart version 4.7.11
Reply With Quote
  #5  
Old 05-06-2019, 11:58 PM
  ambal's Avatar 
ambal ambal is offline
 

X-Cart team
  
Join Date: Sep 2002
Posts: 4,102
 

Default Re: X-payments problem after server change

v7.2.x

https://www.x-payments.com/help/X-Payments:System_requirements_for_X-Payments_3

Quote:
Originally Posted by joestern
What is the latest version of PHP that is compatible with X-Payments 3.x?
__________________
Sincerely yours,
Alex Mulin
VP of business development for X-Cart
X-Payments project manager
Reply With Quote
  #6  
Old 09-17-2019, 12:35 PM
 
joestern joestern is offline
 

Senior Member
  
Join Date: Apr 2004
Posts: 176
 

Default Re: X-payments problem after server change

We just received a message from x-cart that says:

"Multiple severe vulnerabilities (https://www.cisecurity.org/advisory/multiple-vulnerabilities-in-php-could-allow-for-arbitrary-code-execution_2019-087) have been discovered in all supported PHP branches.

Most of the hosting companies have already upgraded their servers to PHP7.3.9 and some of them are still in the process.

We can patch it up for you, but first we have to examine your store to figure out which way. Please contact us for the details."

How do we upgrade to PHP7.3.9 if x-payments is not compatible with php7.3?!
__________________
X-Cart version 4.7.11
Reply With Quote
  #7  
Old 09-17-2019, 04:03 PM
  cflsystems's Avatar 
cflsystems cflsystems is offline
 

Veteran
  
Join Date: Apr 2007
Posts: 13,532
 

Default Re: X-payments problem after server change

Quote:
Originally Posted by joestern
How do we upgrade to PHP7.3.9 if x-payments is not compatible with php7.3?!
That's funny
__________________
Steve Stoyanov
CFLSystems.com
Web Development
Reply With Quote
  #8  
Old 09-18-2019, 01:14 AM
  ambal's Avatar 
ambal ambal is offline
 

X-Cart team
  
Join Date: Sep 2002
Posts: 4,102
 

Default Re: X-payments problem after server change

Quote:
Originally Posted by joestern
We just received a message from x-cart that says:

"Multiple severe vulnerabilities (https://www.cisecurity.org/advisory/multiple-vulnerabilities-in-php-could-allow-for-arbitrary-code-execution_2019-087) have been discovered in all supported PHP branches.

Most of the hosting companies have already upgraded their servers to PHP7.3.9 and some of them are still in the process.

We can patch it up for you, but first we have to examine your store to figure out which way. Please contact us for the details."

How do we upgrade to PHP7.3.9 if x-payments is not compatible with php7.3?!

Actually, you do not have to upgrade to the latest PHP 7.3.x. Upgrading to latest PHP 7.2.x is acceptable solution, too.
i.e.
---
SYSTEMS AFFECTED:

PHP 7.2 versions prior to 7.2.22
---

means you can upgrade to PHP 7.2.22 to have fixes applied.
__________________
Sincerely yours,
Alex Mulin
VP of business development for X-Cart
X-Payments project manager
Reply With Quote
Reply
   X-Cart forums > X-Payments > X-Payments issues & questions


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -8. The time now is 09:58 PM.

   

 
X-Cart forums © 2001-2018