Follow us on Twitter X-Cart on Facebook Wiki
Shopping cart software Solutions for online shops and malls

Invoice logo not replaced in customer email
 
Reply
   X-Cart forums > X-Cart 4 > Changing design
 
Thread Tools Search this Thread
  #1  
Old 01-04-2007, 08:54 PM
 
JonCam JonCam is offline
 

Newbie
  
Join Date: Oct 2006
Location: Denver
Posts: 6
 

Default Invoice logo not replaced in customer email

I replaced the default small company logo gif with my company logo.

The invoice that shows on screen when the customer completes an order shows it correctly. However, the invoice that is sent to the customer via email has the "Company Name" logo from xcart in it. v4.1.3

Is this a bug or something I didn't realize I had to change manually?

Any thoughts? I'm ready to launch but for this issue.

Cheers,
JC
__________________
X Cart 4.4
Reply With Quote
  #2  
Old 01-04-2007, 10:01 PM
  Jon's Avatar 
Jon Jon is offline
 

X-Guru
  
Join Date: Oct 2002
Location: Vancouver, Canada
Posts: 4,163
 

Default Re: Invoice logo not replaced in customer email

It's a different image, which unfortunately I don't recall the name of off-hand. I highly recommend downloading your entire image directory and reviewing for possible changes anyway.
__________________
|
Our clients strive to be the best in their industry.
We position you for success with our strategically integrated approach to software, search engine optimization and social media.

TWITTER
https://twitter.com/SmackDigital

LINKEDIN
https://www.linkedin.com/in/smackdigital
Reply With Quote
  #3  
Old 01-05-2007, 02:26 AM
 
balinor balinor is offline
 

Veteran
  
Join Date: Oct 2003
Location: Connecticut, USA
Posts: 30,253
 

Default Re: Invoice logo not replaced in customer email

The image on the invoices is companyname_small.gif. Please be sure to read the guidelines on posting in the bugs forum, it is for software bugs only, not configuration issues. Moving to Template Editing. Thanks!
__________________
Padraic Ryan
Ryan Design Studio
Professional E-Commerce Development
Reply With Quote
  #4  
Old 01-05-2007, 08:50 PM
 
JonCam JonCam is offline
 

Newbie
  
Join Date: Oct 2006
Location: Denver
Posts: 6
 

Default Re: Invoice logo not replaced in customer email

Yes, I read it... thank you.

I still haven't seen anything that tells me it isn't a bug. I've been through all the images in x-cart and can't find any other like it. If anyone can tell me the name and location of the image, I'd be interested. Until then, x-cart can tell me it isn't a bug... although they are good at saying something isn't when it later turns out it is... sorry for the rant.

Padraic, if you re-read my post, you will see that I've already changed the one you mention, and have cleared the cache as well...

How do I move this back to Bugs and Fixes?
__________________
X Cart 4.4
Reply With Quote
  #5  
Old 01-06-2007, 02:59 AM
 
balinor balinor is offline
 

Veteran
  
Join Date: Oct 2003
Location: Connecticut, USA
Posts: 30,253
 

Default Re: Invoice logo not replaced in customer email

If you open the template, you will see exactly what it is called. The invoice is skin1/mail/html/order_invoice.tpl. It is companyname_small.gif. It is not the same image as your main logo.
__________________
Padraic Ryan
Ryan Design Studio
Professional E-Commerce Development
Reply With Quote
  #6  
Old 01-06-2007, 03:10 AM
  denlem's Avatar 
denlem denlem is offline
 

Senior Member
  
Join Date: Apr 2004
Location: MA / CT / RI Border
Posts: 117
 

Default Re: Invoice logo not replaced in customer email

Quote:
Originally Posted by JonCam


I still haven't seen anything that tells me it isn't a bug.


Have you found anything that has told you that it * IS * a bug??

As balinor said, the file name is companyname_small.gif

Typically it will be in your /skin1/images/ directory. You will need to either overwrite this image with the same name, or go into your /mail/html/order_invoice.tpl template, and look around line 12, you will see:

<td valign="top"><br /><br /><img src="{$ImagesDir}/companyname_small.gif" alt="" /></td>

and change the file name to exactly match the name of the file you uploaded.
__________________
X-Cart Gold Plus 4.7.10
Reply With Quote
  #7  
Old 01-06-2007, 03:50 AM
 
balinor balinor is offline
 

Veteran
  
Join Date: Oct 2003
Location: Connecticut, USA
Posts: 30,253
 

Default Re: Invoice logo not replaced in customer email

I just looked at this on a fresh install of 4.1.3, and that is indeed the correct image. Changing it changes the image on the invoice, so it isn't a bug. If it isn't changing, make sure you:

1. Uploaded the new graphic to the correct folder.

2. Cleared out your templates_c director

3. Cleared out your browser's cache
__________________
Padraic Ryan
Ryan Design Studio
Professional E-Commerce Development
Reply With Quote
  #8  
Old 01-06-2007, 06:49 AM
 
JonCam JonCam is offline
 

Newbie
  
Join Date: Oct 2006
Location: Denver
Posts: 6
 

Default Re: Invoice logo not replaced in customer email

Okay guys, I'm going to rewrite the problem, because obviously you are reading that I'm a newbie and making some assumptions.

- Before I wrote in, prior to testing an order I changed the companyname_small.gif to one with my logo.
- It changed fine on the onscreen invoice that the customer sees [therefore the gif is in the correct directory, and it correctly overwrote the default file].
-I thought I was done. I looked at the email receipt that was sent to me as the test user.
- The default logo showed up.
- I went back into tools and cleared the template cache and redid the order.
- Same result. 6 orders in a row, same results.

I've deleted the logo from the mail/html/order_invoice.tpl and it deleted it on both the onscreen version and the email, so I'm going to get on with my life. If it isn't a bug, great, but it sure acts like a bug.

Sorry for my frustration, but this is an awfully frustrating shopping solution if you don't love coding.
__________________
X Cart 4.4
Reply With Quote
  #9  
Old 01-27-2007, 04:18 PM
 
Chaosnhavoc Chaosnhavoc is offline
 

Newbie
  
Join Date: Jan 2007
Posts: 6
 

Default Re: Invoice logo not replaced in customer email

I had a similar problem, my logo wouldnt show up in the emails. I changed mail/html/order_invoice.tpl image src to the http:// address versus the current src.
__________________
X Cart 4.1.6
Reply With Quote
  #10  
Old 01-27-2007, 05:14 PM
 
carpeperdiem carpeperdiem is offline
 

X-Guru
  
Join Date: Jul 2006
Location: New York City, USA
Posts: 5,399
 

Default Re: Invoice logo not replaced in customer email

I had a similar problem way back when... and I think my email client cached the original image. Since I didn't know how to clear the cache of my email client, I simply renamed the image (adjusted the templates) and everything was great.
__________________
xcart 4.5.4 gold+ w/x-payments 1.0.6; xcart gold 4.4.4
Reply With Quote
Reply
   X-Cart forums > X-Cart 4 > Changing design


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -8. The time now is 11:25 PM.

   

 
X-Cart forums © 2001-2018