Follow us on Twitter X-Cart on Facebook Wiki
Shopping cart software Solutions for online shops and malls

ShippingEasy Module Error Enabling Module

 
Reply
   X-Cart forums > X-Cart 4 > Third Party Add-Ons for X-Cart 4
 
Thread Tools
  #1  
Old 11-09-2018, 06:36 PM
 
abbieroad abbieroad is offline
 

Advanced Member
  
Join Date: Oct 2004
Posts: 31
 

Default ShippingEasy Module Error Enabling Module

I just installed the ShippingEasy Module and it seemed to install correctly.

Upon clicking the box to enable it in the admin, I get an error:

"Error Enabling Module!"

That's it. No other information. Although one other thing I noticed is that I cannot access the General Settings page in admin now (I get a "This page isn't working. HTTP ERROR 500" error.

I assume the issue is related.

I am on Xcart version 4.6.0

Any idea on what might be going on or where to find more information on what the error actually is?

Thanks!

Steve Wood
__________________
Steve Wood

www.TheApronPlace.com
X-Cart version 4.6.0
Reply With Quote
  #2  
Old 11-10-2018, 06:29 AM
  cflsystems's Avatar 
cflsystems cflsystems is offline
 

Veteran
  
Join Date: Apr 2007
Posts: 13,743
 

Default Re: ShippingEasy Module Error Enabling Module

You need to take a look at the logs and see if anything shows there. The 500 error is most likely related to some syntax errors in php script(s) modified by the installation you did.
__________________
Steve Stoyanov
CFLSystems.com
Web Development
Reply With Quote
  #3  
Old 11-10-2018, 01:23 PM
 
abbieroad abbieroad is offline
 

Advanced Member
  
Join Date: Oct 2004
Posts: 31
 

Default Re: ShippingEasy Module Error Enabling Module

Thank you, Steve, that helped track down the problem with enabling the module. Per the error logs, it seems that "ShippingEasy needs the Multibyte String PHP extension" After enabling that PHP extension, I was able to enable the module.

However, the problem with the 500 error still exists with the General Settings page and now, after enabling the module, with the Congifuation page of the Module. Both of which call the /admin/configuration.php file.

The error log does show an issue with that file:

PHP Fatal error: Class 'XCEmailFormat' not found in /home/theapron/public_html/admin/configuration.php on line 1474

Line 1474 shows:
$smarty->assign('email_extended_validation_regexp', func_email_validation_regexp(XCEmailFormat::EXTEND ED));

This is indeed a part that was added from the ShippingEasy module.

Of course, it all doesn't mean much to me, because I don't know all of the coding. Does it mean anything to you?

Thanks for the help!
__________________
Steve Wood

www.TheApronPlace.com
X-Cart version 4.6.0
Reply With Quote
  #4  
Old 11-10-2018, 04:48 PM
  cflsystems's Avatar 
cflsystems cflsystems is offline
 

Veteran
  
Join Date: Apr 2007
Posts: 13,743
 

Default Re: ShippingEasy Module Error Enabling Module

Try uninstalling the module and them installing it again. It looks to me something was not added properly or at all and XCEmailFormat class is not loaded. If still doesn;t work you can report it as a bug to the developer.
__________________
Steve Stoyanov
CFLSystems.com
Web Development
Reply With Quote
  #5  
Old 11-10-2018, 10:47 PM
 
abbieroad abbieroad is offline
 

Advanced Member
  
Join Date: Oct 2004
Posts: 31
 

Default Re: ShippingEasy Module Error Enabling Module

Thank you...I have uninstalled it and contacted Xcart and the developer of the module is taking a look at it. Thanks for your help!
__________________
Steve Wood

www.TheApronPlace.com
X-Cart version 4.6.0
Reply With Quote

The following user thanks abbieroad for this useful post:
cherie (11-11-2018)
Reply
   X-Cart forums > X-Cart 4 > Third Party Add-Ons for X-Cart 4


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -8. The time now is 10:27 PM.

   

 
X-Cart forums © 2001-2020