Follow us on Twitter X-Cart on Facebook Wiki
Shopping cart software Solutions for online shops and malls

Invoice logo not replaced in customer email
 
Reply
   X-Cart forums > X-Cart 4 > Changing design
 
Thread Tools Search this Thread
  #11  
Old 01-28-2007, 03:08 AM
 
balinor balinor is offline
 

Veteran
  
Join Date: Oct 2003
Location: Connecticut, USA
Posts: 30,253
 

Default Re: Invoice logo not replaced in customer email

Quote:
I had a similar problem, my logo wouldnt show up in the emails. I changed mail/html/order_invoice.tpl image src to the http:// address versus the current src.

If you do that, it will generated a security error on the receipt page, so it is not recommended.
__________________
Padraic Ryan
Ryan Design Studio
Professional E-Commerce Development
Reply With Quote
  #12  
Old 01-28-2007, 04:36 PM
 
Chaosnhavoc Chaosnhavoc is offline
 

Newbie
  
Join Date: Jan 2007
Posts: 6
 

Default Re: Invoice logo not replaced in customer email

Security error? Where can I look for it at? I have not noticed any other issues could it be something that I am overlooking? Prior to changing the src Email Invoices would not download the image, it would show up with the red X like it couldnt find it. Any insight is greatly appreciated.
__________________
X Cart 4.1.6
Reply With Quote
  #13  
Old 01-28-2007, 05:20 PM
 
balinor balinor is offline
 

Veteran
  
Join Date: Oct 2003
Location: Connecticut, USA
Posts: 30,253
 

Default Re: Invoice logo not replaced in customer email

If you have secure checkout enabled (which I hope you do), viewing the Invoice page in secure mode will give you a 'This page displays both secure and insecure items, do you wish to proceed?'.

Also, if you could take a moment to add your X-Cart version to your signature that would be great...thanks!
__________________
Padraic Ryan
Ryan Design Studio
Professional E-Commerce Development
Reply With Quote
  #14  
Old 07-19-2007, 07:37 PM
 
David De Candia David De Candia is offline
 

Newbie
  
Join Date: Jul 2007
Posts: 3
 

Default Re: Invoice logo not replaced in customer email

Since I had this problem, I'm just going to add that I'm pretty sure carpeperdiem was right.

If you have correctly uploaded your new companyname_small.gif and it is still showing the old default logo in your email, it's because your email app's image cache needs flushing.

Checking my email via my webmail browser verified this.
__________________
X-Cart Gold v4.1.8
Reply With Quote
  #15  
Old 05-11-2008, 11:13 AM
 
TA TA is offline
 

eXpert
  
Join Date: Apr 2006
Posts: 299
 

Default Re: Invoice logo not replaced in customer email

Yes, carpeperdiem is right on. I had the same problem and spent some time scratching my head. I was able to confirm this issue on a machine that had no email client set up. I went into mail/html/order_invoice.tpl and renamed the image there and then went into the images directory and renamed it to match. All is well.
__________________
v4.7.3 [unix]
Reply With Quote
  #16  
Old 09-13-2011, 07:17 AM
 
Kristine Kristine is offline
 

Newbie
  
Join Date: Sep 2011
Posts: 1
 

Default Re: Invoice logo not replaced in customer email

I agree that trying to go through X-Cart can be very difficult. Many of the templates and other files have the same names but are saved in different locations. In version 4.4.3, the logo for the invoices is in the folder skin/common_files/images/companyname_small.gif

I'm sure the original poster has had their problem solved but I hope this helps future users.
__________________
X-Cart v. 4.4.3
Reply With Quote
  #17  
Old 06-01-2018, 10:45 AM
 
goldensheep goldensheep is offline
 

Member
  
Join Date: Apr 2018
Posts: 19
 

Default Re: Invoice logo not replaced in customer email

Hi,

I have the logo showing on customer invoices OK, but if I (as a customer log in) look at an invoice in my order history - it still has the X-Cart logo.
If (as Admin in the backend) open up/print an order/invoice - the logo is also still X-Cart.

For the life of me, I can't find where this is image is stored.

If anyone can help, I would be truly grateful
__________________
X-Cart 4.7.9
Reply With Quote
  #18  
Old 06-01-2018, 11:54 AM
 
mcupka mcupka is offline
 

eXpert
  
Join Date: Jan 2013
Posts: 204
 

Default Re: Invoice logo not replaced in customer email

Don't have your exact version but have you looked here?

https://forum.x-cart.com/showthread.php?t=73776


Quote:
Originally Posted by goldensheep
Hi,

I have the logo showing on customer invoices OK, but if I (as a customer log in) look at an invoice in my order history - it still has the X-Cart logo.
If (as Admin in the backend) open up/print an order/invoice - the logo is also still X-Cart.

For the life of me, I can't find where this is image is stored.

If anyone can help, I would be truly grateful
Reply With Quote
  #19  
Old 06-01-2018, 01:42 PM
 
goldensheep goldensheep is offline
 

Member
  
Join Date: Apr 2018
Posts: 19
 

Default Re: Invoice logo not replaced in customer email

Thanks for the link to the thread.
I have tried all of those suggestions and replaced two image files called companyname_small.gif with my logo, but the x-cart one still remains on the invoices.

Incidentally, before replacing/overwriting those original images, I noticed that they were not the X-Cart logo, but blue text/logos saying Company logo (or something similar). This is what makes me think that they are not the right files.
__________________
X-Cart 4.7.9
Reply With Quote
  #20  
Old 06-04-2018, 05:16 AM
 
mcupka mcupka is offline
 

eXpert
  
Join Date: Jan 2013
Posts: 204
 

Default Re: Invoice logo not replaced in customer email

Quote:
Originally Posted by goldensheep
Thanks for the link to the thread.
I have tried all of those suggestions and replaced two image files called companyname_small.gif with my logo, but the x-cart one still remains on the invoices.

Incidentally, before replacing/overwriting those original images, I noticed that they were not the X-Cart logo, but blue text/logos saying Company logo (or something similar). This is what makes me think that they are not the right files.
Did you try viewing the email through a different program/browser as was suggested?

"If you have correctly uploaded your new companyname_small.gif and it is still showing the old default logo in your email, it's because your email app's image cache needs flushing.

Checking my email via my webmail browser verified this."

I'll be around till 5pm EST today and can go back and forth with you based on my current install (on here obviously). Hope that helps, thanks.
Reply With Quote
Reply
   X-Cart forums > X-Cart 4 > Changing design


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -8. The time now is 12:43 PM.

   

 
X-Cart forums © 2001-2018