Follow us on Twitter X-Cart on Facebook Wiki
Shopping cart software Solutions for online shops and malls

Orders not properly communicating between Client Site, X-Payments and Auth.Net AIM
 
Reply
   X-Cart forums > X-Payments > X-Payments issues & questions
 
Thread Tools
  #1  
Old 12-15-2015, 01:34 PM
  CenturyPerf's Avatar 
CenturyPerf CenturyPerf is offline
 

eXpert
  
Join Date: Jun 2003
Location: Reno, Nevada
Posts: 396
 

Default Re: Orders not passing to Authorize.net

I'm seeing orders that are not properly communicating between:
Client Site <<>> X-Payments <<>> Authorize.net AIM.

However, these are domestic (not international) orders.

The orders are being authorized for capture, but are NOT creating an invoice in the store. Meaning, my client cannot see that an order was placed. I can only see these orders in Authorize,net and X-Payments. And it seems these invisible orders are occurring more often (seven since November 21st).

Regarding these invisible orders:
1) They do NOT show an invoice inside XCart 5.2.10
2) The do show in my client's Authorize.net account as UNSETTLED
3) I can CAPTURE the order and collect the invoice from Authorize.net's merchant portal
4) I see the payment as "authorized" inside X-Payments
5) I can CAPTURE the order inside X-Payments

What else do you need to try and solve this interesting and annoying problem? My client has started screaming at me over it, and now I have to manually check for orders in X-Payments every day to make sure no orders have been missed.
__________________
Best Regards,

Sam Solace - Pres/CEO
Century Performance Center, Inc.
http://www.centuryperformance.com

(3) sites using X-Cart 5.3.5.5
X-Payments Enterprise 3.1.4

Last edited by qualiteam : 12-15-2015 at 09:53 PM.
Reply With Quote
  #2  
Old 12-15-2015, 09:54 PM
  qualiteam's Avatar 
qualiteam qualiteam is offline
 

X-Guru
  
Join Date: Dec 2010
Posts: 6,373
 

Default Re: Orders not properly communicating between Client Site, X-Payments and Auth.Net AIM

Hello Sam,

I've moved this post from the original forum thread as it seems to be related to X-Payments, not the Authorize.Net SIM integration that is built into X-Cart.
__________________
Alex Solovev,
Qualiteam

---

User manual Video tutorials X-Cart FAQ

You are welcome to press "Thanks" button
if you find this post useful

Click here to learn how to apply patches

X-Cart Extensions
Reply With Quote
  #3  
Old 12-16-2015, 08:53 PM
  ambal's Avatar 
ambal ambal is offline
 

X-Cart team
  
Join Date: Sep 2002
Posts: 4,099
 

Default Re: Orders not properly communicating between Client Site, X-Payments and Auth.Net AIM

Hi Sam,

What do you see at X-Payments logs at both X-Cart and X-Payments side?

https://www.x-payments.com/help/X-Payments:FAQ#Where_can_I_find_X-Payments_logs.3F
__________________
Sincerely yours,
Alex Mulin
VP of business development for X-Cart
X-Payments project manager
Reply With Quote

The following user thanks ambal for this useful post:
CenturyPerf (12-17-2015)
  #4  
Old 12-17-2015, 03:01 AM
  CenturyPerf's Avatar 
CenturyPerf CenturyPerf is offline
 

eXpert
  
Join Date: Jun 2003
Location: Reno, Nevada
Posts: 396
 

Default Re: Orders not properly communicating between Client Site, X-Payments and Auth.Net AIM

Hello Alex:

I posted a few more details on the problem (specifically that when these invisible orders occur they authorize the product total, but ignore shipping costs) in a different thread before I was notified of this moved post. The details are here: https://forum.x-cart.com/showthread.php?t=73283

In the xp-connector log I see the callback requests, and they look normal.

In the php_errors.log I see this:

Quote:
16-Dec-2015 07:43:56] Error (code: 0): An exception occurred while executing 'UPDATE xc5_orders SET total = ? WHERE order_id = ?' with params [552.62, 1092]:

SQLSTATE[40001]: Serialization failure: 1213 Deadlock found when trying to get lock; try restarting transaction
Server API: cgi-fcgi;
Request method: GET;
URI: /?target=checkout&action=checkout&xpc_iframe=1;
Backtrace:
#0 /home/directory/public_html/lib/Doctrine/DBAL/DBALException.php(116): Doctrine\DBAL\Driver\AbstractMySQLDriver->convertException('An exception oc...', Object(Doctrine\DBAL\Driver\PDOException))
#1 /home/directory/public_html/lib/Doctrine/DBAL/Connection.php(995): Doctrine\DBAL\DBALException::driverExceptionDuring Query(Object(XLite\Core\PDOMySqlDriver), Object(Doctrine\DBAL\Driver\PDOException), 'UPDATE xc5_orde...', Array)
#2 /home/directory/public_html/var/run/classes/XLite/Core/Connection.php(97): Doctrine\DBAL\Connection->executeUpdate('UPDATE xc5_orde...', Array, Array)
#3 /home/directory/public_html/lib/Doctrine/ORM/Persisters/BasicEntityPersister.php(481): XLite\Core\Connection->executeUpdate('UPDATE xc5_orde...', Array, Array)
#4 /home/directory/public_html/lib/Doctrine/ORM/Persisters/BasicEntityPersister.php(369): Doctrine\ORM\Persisters\BasicEntityPersister->updateTable(Object(XLite\Model\Cart), 'xc5_orders', Array, NULL)
#5 /home/directory/public_html/lib/Doctrine/ORM/UnitOfWork.php(1024): Doctrine\ORM\Persisters\BasicEntityPersister->update(Object(XLite\Model\Cart))
#6 /home/directory/public_html/lib/Doctrine/ORM/UnitOfWork.php(341): Doctrine\ORM\UnitOfWork->executeUpdates(Object(Doctrine\ORM\Mapping\ClassM etadata))
#7 /home/directory/public_html/lib/Doctrine/ORM/EntityManager.php(389): Doctrine\ORM\UnitOfWork->commit(NULL)
#8 /home/directory/public_html/var/run/classes/XLite/Model/Session.php(309): Doctrine\ORM\EntityManager->flush()
#9 /home/directory/public_html/var/run/classes/XLite/Model/Session.php(198): XLite\Model\Session->setCellValue('lastCartInitial...', 1450280636)
#10 /home/directory/public_html/var/run/classes/XLite/Core/Session.php(118): XLite\Model\Session->__set('lastCartInitial...', 1450280636)
#11 /home/directory/public_html/var/run/classes/XLite/Model/CartAbstract.php(223): XLite\Core\Session->__set('lastCartInitial...', 1450280636)
#12 /home/directory/public_html/var/run/classes/XLite/Model/OrderAbstract.php(2170): XLite\Model\CartAbstract->calculate()
#13 /home/directory/public_html/var/run/classes/XLite/Model/CartAbstract.php(132): XLite\Model\OrderAbstract->renew()
#14 /home/directory/public_html/var/run/classes/XLite/Controller/Customer/ACustomerAbstract.php(170): XLite\Model\CartAbstract::getInstance(true)
#15 /home/directory/public_html/var/run/classes/XLite/Module/CDev/XPaymentsConnector/Controller/Customer/Checkout.php(46): XLite\Controller\Customer\ACustomerAbstract->getCart()
#16 /home/directory/public_html/var/run/classes/XLite/Module/CDev/XPaymentsConnector/Controller/Customer/Checkout.php(83): XLite\Module\CDev\XPaymentsConnector\Controller\Cu stomer\Checkout->isCheckoutReady()
#17 /home/directory/public_html/var/run/classes/XLiteAbstract.php(575): XLite\Module\CDev\XPaymentsConnector\Controller\Cu stomer\Checkout->handleRequest()
#18 /home/directory/public_html/var/run/classes/XLiteAbstract.php(600): XLiteAbstract->runController()
#19 /home/directory/public_html/cart.php(37): XLiteAbstract->processRequest()

The only error file I see in X-Payments Payment Log is one file posted yesterday:

Quote:
ERROR [2015-16-12 15:11:46]
User: unknown; IP: 24.151.88.36
Zone: View
Code: PAYMENT_INVALID (0)
Unknown exception

Affected systems: View/Payment.php file (98:assert); View/Payment.php file (57:getPayment); Core/Dispatcher.php file (156:process); Application.php file (137:dispatch); /home/directory/public_html/xp/payment.php file (24:run)


ERROR [2015-16-12 15:12:10]
User: unknown; IP: 24.151.88.36
Zone: View
Code: PAYMENT_INVALID (0)
Unknown exception

Affected systems: View/Payment.php file (98:assert); View/Payment.php file (57:getPayment); Core/Dispatcher.php file (156:process); Application.php file (137:dispatch); /home/directory/public_html/xp/payment.php file (24:run)

However, in the X-Payments console it does not show any transaction errors, but does say there was "Recent Error Dates" of 12/16 and 12/15 but provides no details Those are probably my own login errors to the X-Payment console.

At this point I'm about to restart the server and see if that clears anything up. I already tried clearing the cache and re-deploying the store and that didn't make any difference.
__________________
Best Regards,

Sam Solace - Pres/CEO
Century Performance Center, Inc.
http://www.centuryperformance.com

(3) sites using X-Cart 5.3.5.5
X-Payments Enterprise 3.1.4
Reply With Quote
  #5  
Old 12-17-2015, 03:19 AM
  ambal's Avatar 
ambal ambal is offline
 

X-Cart team
  
Join Date: Sep 2002
Posts: 4,099
 

Default Re: Orders not properly communicating between Client Site, X-Payments and Auth.Net AIM

Sam,

> Serialization failure: 1213 Deadlock found when trying to get lock; try restarting transaction

This is definitely a server-side issue that creates the trouble for your client. I see you use self-hosted X-Payments so I advise you to work with our techs regarding fixing your server environment for X-payments.
__________________
Sincerely yours,
Alex Mulin
VP of business development for X-Cart
X-Payments project manager
Reply With Quote

The following user thanks ambal for this useful post:
CenturyPerf (12-17-2015)
  #6  
Old 12-17-2015, 09:04 AM
  CenturyPerf's Avatar 
CenturyPerf CenturyPerf is offline
 

eXpert
  
Join Date: Jun 2003
Location: Reno, Nevada
Posts: 396
 

Default Re: Orders not properly communicating between Client Site, X-Payments and Auth.Net AIM

Thanks Alex:

My server is hosted by EWD (Total Server Solutions) and I communicated with them early this morning regarding this issue. They had mentioned something about a recent routing issue regarding upstream IPs, but I'm not sure that is causing my issues.

I just sent them a follow-up with the error, and explained your concern over server environment. Is there anything specific that needs to be addressed when self-hosting X-Payments? It seemed to be working perfectly until recently, and there have been no changes to the server. For reference, I'm using the latest X-Payments, version 2.2.0.

I appreciate your help with this.
__________________
Best Regards,

Sam Solace - Pres/CEO
Century Performance Center, Inc.
http://www.centuryperformance.com

(3) sites using X-Cart 5.3.5.5
X-Payments Enterprise 3.1.4
Reply With Quote
  #7  
Old 12-17-2015, 09:25 AM
  ambal's Avatar 
ambal ambal is offline
 

X-Cart team
  
Join Date: Sep 2002
Posts: 4,099
 

Default Re: Orders not properly communicating between Client Site, X-Payments and Auth.Net AIM

Do you host X-Cart with EWD, too?
Do you host X-Payments and X-Cart in the same environment/account or separately?
__________________
Sincerely yours,
Alex Mulin
VP of business development for X-Cart
X-Payments project manager
Reply With Quote
  #8  
Old 12-17-2015, 09:30 AM
  CenturyPerf's Avatar 
CenturyPerf CenturyPerf is offline
 

eXpert
  
Join Date: Jun 2003
Location: Reno, Nevada
Posts: 396
 

Default Re: Orders not properly communicating between Client Site, X-Payments and Auth.Net AIM

Yes to both, and currently X-Payments is within a subfolder of one of my domains running X-Cart 4.x.

I'm also communicating with EWD about this now. They just asked the same question. Should X-Payments be installed under its own (separate) domain, or?
__________________
Best Regards,

Sam Solace - Pres/CEO
Century Performance Center, Inc.
http://www.centuryperformance.com

(3) sites using X-Cart 5.3.5.5
X-Payments Enterprise 3.1.4
Reply With Quote
  #9  
Old 12-17-2015, 07:31 PM
  ambal's Avatar 
ambal ambal is offline
 

X-Cart team
  
Join Date: Sep 2002
Posts: 4,099
 

Default Re: Orders not properly communicating between Client Site, X-Payments and Auth.Net AIM

> Yes to both, and currently X-Payments is within a subfolder of one of my domains running
> X-Cart 4.x.

This is not PCI compliant way to install and use X-Payments. It must be installed 100% separately.
__________________
Sincerely yours,
Alex Mulin
VP of business development for X-Cart
X-Payments project manager
Reply With Quote
  #10  
Old 12-17-2015, 10:38 PM
  CenturyPerf's Avatar 
CenturyPerf CenturyPerf is offline
 

eXpert
  
Join Date: Jun 2003
Location: Reno, Nevada
Posts: 396
 

Default Re: Orders not properly communicating between Client Site, X-Payments and Auth.Net AIM

I'm in the process of correcting that.
__________________
Best Regards,

Sam Solace - Pres/CEO
Century Performance Center, Inc.
http://www.centuryperformance.com

(3) sites using X-Cart 5.3.5.5
X-Payments Enterprise 3.1.4
Reply With Quote
Reply
   X-Cart forums > X-Payments > X-Payments issues & questions


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -8. The time now is 11:31 AM.

   

 
X-Cart forums © 2001-2018