Follow us on Twitter X-Cart on Facebook Wiki
Shopping cart software Solutions for online shops and malls

X-payments 1.0.6 payment methods not showing up in connector 4.6.6

 
Reply
   X-Cart forums > X-Payments > X-Payments issues & questions
 
Thread Tools
  #1  
Old 02-13-2015, 07:20 AM
 
janna.ross janna.ross is offline
 

Newbie
  
Join Date: Dec 2011
Posts: 9
 

Default X-payments 1.0.6 payment methods not showing up in connector 4.6.6

I am doing a fresh install of our store on to a new server and have installed the latest classic xcart (4.6.6) and the latest xpayments 1.0.6. I was able to deploy the configuration bundle in the connector and connect to xpayments, but the only payment method that we use is Authorize.net AIM, which is configured exactly as our current live install (running cart 4.4.3 and xpay 1.0.4), is not being imported to the connector. The payment method is enabled and assigned to the online store, it just refuses to show up in the cart connector when I synchronize the payment methods.

I did check the xcart log for the xpay connector and see this showing up:
-------------------------------------------------
[13-Feb-2015 14:01:19] xpay_connector message:
Internal error.
Request URI: /admin/xpc_admin.php?mode=import_payment_methods
Backtrace:
/data/webpages/cart.pflaum.com/html/modules/XPayments_Connector/xpc_func.php:2277
/data/webpages/cart.pflaum.com/html/modules/XPayments_Connector/xpc_func.php:2017
/data/webpages/cart.pflaum.com/html/modules/XPayments_Connector/xpc_func.php:1970
/data/webpages/cart.pflaum.com/html/modules/XPayments_Connector/xpc_func.php:1404
/data/webpages/cart.pflaum.com/html/modules/XPayments_Connector/xpc_func.php:3292
/data/webpages/cart.pflaum.com/html/modules/XPayments_Connector/xpc_admin.php:219
/data/webpages/cart.pflaum.com/html/admin/xpc_admin.php:84

-------------------------------------------------


And then when i check the xpayments log file i'm seeing this error showing up, i have no idea if they're related

ERROR [2015-13-02 15:23:22]
User: shopping cart (Pflaum Publishing Online Catalog); IP: 10.5.0.69
Zone: Controller/Api
Code: API_EXPIRED (506)
Your X-Payments connector module supports API version "1.3". This X-Payments supports the following API versions only: "1.1, 1.2".

Affected systems: Controller/Api.php file (112:assert); Core/Handler.php file (320:checkCredentials); Core/Handler.php file (559:checkAccess); Core/Dispatcher.php file (146:__construct); Application.php file (156:dispatch); /data/webpages/cart.pflaum.com/html/xpayments/api.php file (26:run)

Any help would be greatly appreciated. Thank you.
__________________
x-cart v4.4.4
x-payments 1.0.4
Reply With Quote
  #2  
Old 02-13-2015, 08:18 AM
  cflsystems's Avatar 
cflsystems cflsystems is offline
 

Veteran
  
Join Date: Apr 2007
Posts: 14,042
 

Default Re: X-payments 1.0.6 payment methods not showing up in connector 4.6.6

Latest X-Payments is 2.x. You may need to upgrade it.
Or if you can setup the API the connector uses and change it to 1.2
__________________
Steve Stoyanov
CFLSystems.com
Web Development
Reply With Quote

The following user thanks cflsystems for this useful post:
ambal (02-15-2015)
  #3  
Old 02-16-2015, 08:27 AM
 
janna.ross janna.ross is offline
 

Newbie
  
Join Date: Dec 2011
Posts: 9
 

Default Re: X-payments 1.0.6 payment methods not showing up in connector 4.6.6

I changed the API on the connector, which cleared up that error. However I'm still not able to import the payment methods from XPayments.
__________________
x-cart v4.4.4
x-payments 1.0.4
Reply With Quote
Reply
   X-Cart forums > X-Payments > X-Payments issues & questions


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -8. The time now is 05:06 PM.

   

 
X-Cart forums © 2001-2020