Follow us on Twitter X-Cart on Facebook Wiki
Shopping cart software Solutions for online shops and malls

X-Cart 4.5.5 released

 
Closed Thread
   X-Cart forums > News and Announcements
 
Thread Tools
  #11  
Old 02-12-2013, 10:57 AM
 
carpeperdiem carpeperdiem is offline
 

X-Guru
  
Join Date: Jul 2006
Location: New York City, USA
Posts: 5,399
 

Default Re: X-Cart 4.5.5 released

Quote:
Originally Posted by RichieRich
It noted CloudSearch was updated to version 1.1.0, but cannot see what was actually updated. Looking at the post, it looks like just the version number?

http://forum.x-cart.com/showpost.php?p=352997&postcount=45

Cloudsearch 1.1.0 should be in your file area. It is in mine.
__________________
xcart 4.5.4 gold+ w/x-payments 1.0.6; xcart gold 4.4.4

The following user thanks carpeperdiem for this useful post:
NikitaP (02-13-2013)
  #12  
Old 02-12-2013, 02:29 PM
  cflsystems's Avatar 
cflsystems cflsystems is offline
 

Veteran
  
Join Date: Apr 2007
Posts: 14,018
 

Default Re: X-Cart 4.5.5 released

Quote:
Originally Posted by ambal
Yes, you need to upgrade X-Payments to v1.0.6 if you want to use it with X-Cart v4.5.5.
So 4.5.5 will not work with previous XPayments versions? Him...
__________________
Steve Stoyanov
CFLSystems.com
Web Development
  #13  
Old 02-12-2013, 04:50 PM
  cherie's Avatar 
cherie cherie is offline
 

X-Wizard
  
Join Date: May 2003
Location: USA
Posts: 1,532
 

Default Re: X-Cart 4.5.5 released

Thanks for making the upgrade pack available right away!

Ran into some issues upgrading a mildly customized 4.5.4 store:
  1. Patch would not finish until /admin memory_limit was bumped up from 32M (I set to 64M)
  2. The new admin ip restriction is implemented during the patch so you get locked out when it tries to display the results
  3. This causes func.mail.php to throw a non-critical error on line 868
  4. Though config.php was patched it still said "could not patch" and had to be removed from file.lst
  5. Kept getting "AFTER-PATCH WAS NOT APPLIED" but Go Back showed it's now on 4.5.5 and would not let the patch complete until:
    • set version back to 4.5.4 in the xcart_config table
    • rename patch.sql to something else like patch.sql.orig (cannot end in .sql)
    • disable the first condition in patch_post.php

All patched now but thought this info might be helpful to someone.

Is PayPal Pro (US) now using an iframe? I couldn't tell by the announcement and I haven't been able to confirm myself.

Mod: you might want to wrap the changelog post in noparse.
__________________
redlimeweb.com
custom mods and design integration
4.7 linux

The following user thanks cherie for this useful post:
carpeperdiem (02-24-2013)
  #14  
Old 02-12-2013, 11:16 PM
 
cheap eyeglasses cheap eyeglasses is offline
 

Senior Member
  
Join Date: Oct 2010
Posts: 140
 

Default Re: X-Cart 4.5.5 released

can not change admin passwords of www.cheapprescriptionglasses.net, shows:

Some errors occurred when trying to save profile data:
The password must be at least 7 characters long and must contain both alphabetic and numeric characters. It should not be the same as your username.
  #15  
Old 02-13-2013, 12:38 AM
  seyfin's Avatar 
seyfin seyfin is offline
 

X-Cart team
  
Join Date: May 2004
Posts: 1,223
 

Default Re: X-Cart 4.5.5 released

Quote:
Originally Posted by cheap eyeglasses
can not change admin passwords of www.cheapprescriptionglasses.net, shows:

Some errors occurred when trying to save profile data:
The password must be at least 7 characters long and must contain both alphabetic and numeric characters. It should not be the same as your username.

Do you enter your new password which meets the above requirements? It is for security reasons - no simple passwords are allowed.
__________________
Sincerely yours,
Sergey Fomin
X-Cart team
Chief support group engineer

===

Check this out. Totally revamped X-Cart hosting
http://www.x-cart.com/hosting.html

Follow us:
https://twitter.com/x_cart / https://www.facebook.com/xcart / https://www.instagram.com/xcart
  #16  
Old 02-13-2013, 02:42 AM
  ambal's Avatar 
ambal ambal is offline
 

X-Cart team
  
Join Date: Sep 2002
Posts: 4,115
 

Default Re: X-Cart 4.5.5 released

Quote:
Originally Posted by cflsystems
So 4.5.5 will not work with previous XPayments versions? Him...

It will work but not for iFrame integration
We listened very closely and mindfully to suggestions and feedback from our users and re-done algorithm for X-Payments iFrame integration in order to avoid duplicate and not-finished payments as well as improve checkout experience for customers. This change involved changes both from X-Cart (mostly) and X-Payments sides. As result, improved iFrame integration will work for X-Cart v4.5.5 and X-Payments 1.0.6 used together.

At the same time, you can use previous X-Payments versions with X-Cart 4.5.5, but it will be separate checkout page setup - you need to set Api version: 1.1 and disable "lite" interface in X-Cart Connector module settings in 4.5.5.
__________________
Sincerely yours,
Alex Mulin
VP of Business Development for X-Cart
X-Payments product manager

Last edited by ambal : 02-13-2013 at 02:46 AM.

The following user thanks ambal for this useful post:
cflsystems (02-13-2013)
  #17  
Old 02-13-2013, 02:58 AM
  ambal's Avatar 
ambal ambal is offline
 

X-Cart team
  
Join Date: Sep 2002
Posts: 4,115
 

Default Re: X-Cart 4.5.5 released

> Is PayPal Pro (US) now using an iframe?

US PayPal PRO is an X-Payments method and it can be used via X-Payments iFrame integration that we improved with this release.
__________________
Sincerely yours,
Alex Mulin
VP of Business Development for X-Cart
X-Payments product manager
  #18  
Old 02-13-2013, 04:37 AM
 
carpeperdiem carpeperdiem is offline
 

X-Guru
  
Join Date: Jul 2006
Location: New York City, USA
Posts: 5,399
 

Default Re: X-Cart 4.5.5 released

Quote:
Originally Posted by seyfin
Quote:
Some errors occurred when trying to save profile data:
The password must be at least 7 characters long and must contain both alphabetic and numeric characters. It should not be the same as your username.

Do you enter your new password which meets the above requirements? It is for security reasons - no simple passwords are allowed.

Am I reading this correctly: 4.5.5 requires 7 character passwords for customers?
What happens if an upgraded customer uses their old "simple" password?
We MUST disable this "feature".

Here's my gripe on this:
A user account on an x-cart store is not the same as a bank. There is simply NO NEED for "secure passwords" for customers since the data it's protecting is only name, email, address and things they like to purchase. IF you require that my customer must change their password -- you're going to PISS THEM OFF. And therefore piss me, the merchant, off as well.

WHY THE F did you change this without an option to turn it off at the admin?

Yes, I am upset about this. This needs an option to turn it off. Immediately.

You guys are not thinking like merchants.
__________________
xcart 4.5.4 gold+ w/x-payments 1.0.6; xcart gold 4.4.4
  #19  
Old 02-13-2013, 06:04 AM
  RichieRich's Avatar 
RichieRich RichieRich is offline
 

X-Adept
  
Join Date: Sep 2004
Location: London, England
Posts: 750
 

Default Re: X-Cart 4.5.5 released

Is it both customer and admin? I thought it was just the admin side.
__________________
Richard


Ultimate 5.4 testing
  #20  
Old 02-13-2013, 06:05 AM
 
Danimal Danimal is offline
 

Senior Member
  
Join Date: Sep 2006
Posts: 134
 

Default Re: X-Cart 4.5.5 released

My dumb luck. Not even done with a mild customization and settings updates for a new 4.5.4 site and 4.5.5 is out. How hard is the upgrade? The only customizations thus far are the header and the rest is CSS. Nothing special, just minor HTML changes.
__________________
~Dani

For version & mods installed, see post.
Closed Thread
   X-Cart forums > News and Announcements


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -8. The time now is 05:22 AM.

   

 
X-Cart forums © 2001-2020