Follow us on Twitter X-Cart on Facebook Wiki
Shopping cart software Solutions for online shops and malls

XC5 - Support for PHP 8.0 & subsequent PHP 8.* releases

 
Reply
   X-Cart forums > X-Cart 5 > General questions (X-Cart 5)
 
Thread Tools Search this Thread
  #11  
Old 02-06-2022, 06:50 AM
  cflsystems's Avatar 
cflsystems cflsystems is offline
 

Veteran
  
Join Date: Apr 2007
Posts: 14,116
 

Default Re: XC5 - Support for PHP 8.0 & subsequent PHP 8.* releases

5.4.1.x has no problems with php 7.4 and mysql 8. If you have 5.4.1.x not being able to run on it then it is some 3rd party modules or something else on that server/cart that's the problem.
__________________
Steve Stoyanov
CFLSystems.com
Web Development
Reply With Quote

The following user thanks cflsystems for this useful post:
Ed B. (02-23-2022)
  #12  
Old 02-23-2022, 02:12 AM
 
Ed B. Ed B. is online now
 

X-Adept
  
Join Date: Apr 2016
Posts: 440
 

Default Re: XC5 - Support for PHP 8.0 & subsequent PHP 8.* releases

Thanks, as a matter of fact I have managed to run without a problem another dev store with php 7.4, so it is not php configuration either. So all I need to do is to figure out which add-on is the culprit...
__________________
X-cart 5.2.12, php 5.6
Ed from Grenoble, France
Reply With Quote
  #13  
Old 02-23-2022, 04:39 AM
  cflsystems's Avatar 
cflsystems cflsystems is offline
 

Veteran
  
Join Date: Apr 2007
Posts: 14,116
 

Default Re: XC5 - Support for PHP 8.0 & subsequent PHP 8.* releases

You turn them all off, switch php and start turning on one by one
__________________
Steve Stoyanov
CFLSystems.com
Web Development
Reply With Quote
  #14  
Old 03-03-2022, 09:04 AM
 
Ed B. Ed B. is online now
 

X-Adept
  
Join Date: Apr 2016
Posts: 440
 

Default Re: XC5 - Support for PHP 8.0 & subsequent PHP 8.* releases

Quote:
Originally Posted by cflsystems
You turn them all off, switch php and start turning on one by one


Thank you, that is what I was about to do when ... our "free license" got transformed to "trial license" that expired again. I thought this issue was solved long time ago...
__________________
X-cart 5.2.12, php 5.6
Ed from Grenoble, France
Reply With Quote
  #15  
Old 03-04-2022, 04:38 AM
  cflsystems's Avatar 
cflsystems cflsystems is offline
 

Veteran
  
Join Date: Apr 2007
Posts: 14,116
 

Default Re: XC5 - Support for PHP 8.0 & subsequent PHP 8.* releases

Quote:
Originally Posted by Ed B.
Thank you, that is what I was about to do when ... our "free license" got transformed to "trial license" that expired again. I thought this issue was solved long time ago...




This issue was never fixed and will not be in this or earlier versions. Eventually next major version will have different way of calling the mothership to check the license but who knows.
__________________
Steve Stoyanov
CFLSystems.com
Web Development
Reply With Quote
  #16  
Old 03-06-2022, 11:47 AM
 
Ed B. Ed B. is online now
 

X-Adept
  
Join Date: Apr 2016
Posts: 440
 

Default Re: XC5 - Support for PHP 8.0 & subsequent PHP 8.* releases

Quote:
Originally Posted by cflsystems
This issue was never fixed and will not be in this or earlier versions. Eventually next major version will have different way of calling the mothership to check the license but who knows.


For some reasons, I was seeing "trial" on service.php page but on admin.php I still saw "free", and it didn't keep my dev stores from operating correctly. And I stopped seeing "your trial license expires in N days". So I presumed the problem was gone. But now I see that my "trial license expired".


Too bad that we will have to migrate to another e-commerce platform now that our production store was almost ready...
__________________
X-cart 5.2.12, php 5.6
Ed from Grenoble, France
Reply With Quote
  #17  
Old 03-15-2022, 01:24 AM
 
Ed B. Ed B. is online now
 

X-Adept
  
Join Date: Apr 2016
Posts: 440
 

Default Re: XC5 - Support for PHP 8.0 & subsequent PHP 8.* releases

Quote:
Originally Posted by Ed B.
For some reasons, I was seeing "trial" on service.php page but on admin.php I still saw "free", and it didn't keep my dev stores from operating correctly. And I stopped seeing "your trial license expires in N days". So I presumed the problem was gone. But now I see that my "trial license expired".


Too bad that we will have to migrate to another e-commerce platform now that our production store was almost ready...


Somehow all problems are gone... Well, thank you very much for help anyway.
__________________
X-cart 5.2.12, php 5.6
Ed from Grenoble, France
Reply With Quote
  #18  
Old 03-15-2022, 02:37 AM
 
Ed B. Ed B. is online now
 

X-Adept
  
Join Date: Apr 2016
Posts: 440
 

Default Re: XC5 - Support for PHP 8.0 & subsequent PHP 8.* releases

Quote:
Originally Posted by Ed B.
Somehow all problems are gone... Well, thank you very much for help anyway.


Actually not... It turned out that
  • The error with php 7.4 comes from my own custom module
  • The problem with license comes from loopback error, which somehow is related to the use of php 7.3 or 7.2
  • The loopback error keeps me from recompiling the store, meaning that I will have to develop my module using php 7.4, but because of the error I can't even visualize what it does...
So somehow I will have to keep switching back and forth between php versions for debugging
__________________
X-cart 5.2.12, php 5.6
Ed from Grenoble, France
Reply With Quote
Reply
   X-Cart forums > X-Cart 5 > General questions (X-Cart 5)


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -8. The time now is 01:24 AM.

   

 
X-Cart forums © 2001-2020