Follow us on Twitter X-Cart on Facebook Wiki
Shopping cart software Solutions for online shops and malls

Advanced Product Reviews - Review won't launch

 
Reply
   X-Cart forums > X-Cart 4 > Changing and adding new features
 
Thread Tools Search this Thread
  #1  
Old 07-18-2020, 08:24 AM
 
peggyr peggyr is offline
 

X-Adept
  
Join Date: Dec 2005
Posts: 444
 

Default Advanced Product Reviews - Review won't launch

Hi,

I'm testing the Advanced Product Review module. I have custom reviews disabled (which have never been enabled on my site).

I have added a review, authorized it, it appears on the product page, but when I click on it, nothing launches, and the link shows "javascript:;"

I do not have popups blocked - I've checked the logs for errors, I have logged onto the DB/table and the review looks fine in the SQL table. I've cleared cache, temp files, etc.

Am I missing some other setup? Thanks for any ideas on what to check.

Peggy
Attached Thumbnails
Click image for larger version

Name:	review-rating-setting.JPG
Views:	9
Size:	10.1 KB
ID:	5527  
__________________
X-Cart 4.7.12 GP | XCARTMODS reBOOT reDUX| Live
IONOS Hosting | Linux | PHP 7.4.5 | MySQL 5.7
Reply With Quote
  #2  
Old 07-18-2020, 11:06 AM
  cflsystems's Avatar 
cflsystems cflsystems is offline
 

Veteran
  
Join Date: Apr 2007
Posts: 13,891
 

Default Re: Advanced Product Reviews - Review won't launch

That woudl probably be the skin yu are using not properly adding the link for the reviews page or not loading some js needed for that.
__________________
Steve Stoyanov
CFLSystems.com
Web Development
Reply With Quote

The following user thanks cflsystems for this useful post:
peggyr (07-18-2020)
  #3  
Old 07-19-2020, 02:19 AM
  PhilJ's Avatar 
PhilJ PhilJ is offline
 

X-Guru
  
Join Date: Nov 2002
Location: UK
Posts: 3,728
 

Default Re: Advanced Product Reviews - Review won't launch

Clicking on that link should select and scroll to the reviews tab.

If you'd prefer it linked to the product reviews page instead, edit /skin/reboot/modules/Advanced_Customer_Reviews/vote_bar_basic.tpl

Replace...
Code:
javascript:;
With
Code:
reviews.php?productid={$product.productid}
Reply With Quote

The following user thanks PhilJ for this useful post:
peggyr (07-19-2020)
  #4  
Old 07-19-2020, 05:01 PM
 
peggyr peggyr is offline
 

X-Adept
  
Join Date: Dec 2005
Posts: 444
 

Default Re: Advanced Product Reviews - Review won't launch

Hi Phil,

My problem with product reviews not appearing, is I did NOT have 'Display reviews' was checked in reDUX

All is good now.

Thanks Steve and Phil

Peggy
__________________
X-Cart 4.7.12 GP | XCARTMODS reBOOT reDUX| Live
IONOS Hosting | Linux | PHP 7.4.5 | MySQL 5.7
Reply With Quote
Reply
   X-Cart forums > X-Cart 4 > Changing and adding new features


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -8. The time now is 08:16 AM.

   

 
X-Cart forums © 2001-2020