Follow us on Twitter X-Cart on Facebook Wiki
Shopping cart software Solutions for online shops and malls

X-payments Internal Error
 
Reply
   X-Cart forums > X-Payments > X-Payments issues & questions
 
Thread Tools
  #1  
Old 01-03-2013, 08:51 AM
 
pfpericpfp pfpericpfp is offline
 

Newbie
  
Join Date: Dec 2012
Posts: 7
 

Default X-payments Internal Error

Hopefully someone can help me out with this. I just signed up for the hosted x-payments and went through all the setup setup steps. Everything went smooth. I press the Test Module button and it checks out. However, when I try to test the payment process I get an Internal Error message (which doesn't fit within the iframe of the lite checkout by the way). This is the error log:

ERROR [2013-01-01 11:01:10]
User: unknown; IP: XX.X.XXX.XXX
Zone: Transport
Code: FILE_NOT_ACCESSIBLE (109)
File "/home/XXXXXXXXX/public_html/lib/XPay/Module/FirstData/1001281450.pem" does not exist or is not readable

Affected systems: Transport/File.php file (87:assert); Transport/File.php file (134:checkFile); Module/FirstData.php file (351:__construct); XPay_Module_FirstData class; Model/Base/Module.php file (256:call_user_func_array); Model/Module.php file (136:__call); Model/PaymentConf.php file (590:__call); Model/PaymentConf.php file (590:getRequest); Model/Payment.php file (1700:processPayment); Model/Payment.php file (1645:processInit); Controller/Payment/Main.php file (239:process); Controller/Payment/Main.php file (217:doPay); Core/Controller.php file (181:actionPay); Controller/Payment.php file (277:process); Core/Dispatcher.php file (148:process); Application.php file (156:dispatch); /home/XXXXXXXXX/public_html/payment.php file (26:run)

The .pem file is in the correct location (I just added the XXXXXXX for the sake of this post). It's a brand new file, just created and downloaded from FirstData.

Any ideas?
__________________
x-cart 4.5.4
X-Payments 1.0.5
Reply With Quote
  #2  
Old 01-03-2013, 01:41 PM
 
pfpericpfp pfpericpfp is offline
 

Newbie
  
Join Date: Dec 2012
Posts: 7
 

Default Re: X-payments Internal Error

Apparently I'm an idiot and just didn't have the .pem file in the correct spot.

Qualiteam put it in the right spot and now everything is peachy!
__________________
x-cart 4.5.4
X-Payments 1.0.5
Reply With Quote

The following user thanks pfpericpfp for this useful post:
ambal (01-04-2013)
  #3  
Old 01-04-2013, 12:40 AM
  ambal's Avatar 
ambal ambal is offline
 

X-Cart team
  
Join Date: Sep 2002
Posts: 4,102
 

Default Re: X-payments Internal Error

> Apparently I'm an idiot and just didn't have the .pem file in the correct spot.

I am pretty sure you are not that type of person and there is something in our knowledge base and instructions that confused you. May I know what place in our docs misled you? I'll correct them to avoid such cases in the future.
__________________
Sincerely yours,
Alex Mulin
VP of business development for X-Cart
X-Payments project manager

Last edited by ambal : 01-05-2013 at 02:52 AM.
Reply With Quote
  #4  
Old 02-12-2013, 02:30 PM
 
originalwest originalwest is offline
 

Member
  
Join Date: May 2004
Posts: 23
 

Default Re: X-payments Internal Error

Ok... I am getting a similar Internal Error

We have X-Cart Gold V4.5.4
and X-Payment V1.0.5

I believe, we have installed X-Payment correctly, but I cannot seem to have it talk to our Merchant Acct.

We use FirstData Cardservice / Linkpoint
(it has always worked fine in X-Cart Gold V 4.3.2 but the setup is different)





The path to the pem file seems correct:

File "/home/XXXXXXXXX/public_html/lib/XPay/Module/FirstData/123456.pem





Under the X-Payments Connector in X-Cart Gold
=============================================

I do the folowing TEST and it always shows:
"Test transaction completed successfully"

Test module

To test the module settings and connection with X-Payments click the button below. If the module is configured properly, a "Test transaction completed successfully" message is displayed at the top of the page.




Email Notice:
=========================

I keep getting this notice via email. I don't know what to do with it. I cannot see where the CHECKSUMS are to be generated.


Email Subject: Payment interface template files checksums are not generated.

Payment interface template files checksums have not been generated. You can generate them on the Dashboard page of the administrator interface.




the THUMBNAIL image:
========================
the the image shows that the "lite interface" but I never get the Text Boxes to type in the CCard Details. That option never opens up


Any advice or suggestions?

Thanks
Reply With Quote
  #5  
Old 02-12-2013, 11:14 PM
  ambal's Avatar 
ambal ambal is offline
 

X-Cart team
  
Join Date: Sep 2002
Posts: 4,102
 

Default Re: X-payments Internal Error

This may be the reason, too
http://help.x-cart.com/index.php?title=X-Payments:User_manual#CyberSource_Internal_Error

Just make sure your FirstData .pem file is readable by HTTP daemon on your X-Payments server and that you specify the right ***server*** path in config.
__________________
Sincerely yours,
Alex Mulin
VP of business development for X-Cart
X-Payments project manager
Reply With Quote
Reply
   X-Cart forums > X-Payments > X-Payments issues & questions


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -8. The time now is 02:07 PM.

   

 
X-Cart forums © 2001-2018