Follow us on Twitter X-Cart on Facebook Wiki
Shopping cart software Solutions for online shops and malls

X-Payments Connector - Response not valid. Check Logs
 
Reply
   X-Cart forums > X-Payments > X-Payments issues & questions
 
Thread Tools
  #1  
Old 10-16-2014, 02:28 PM
 
apkkmi apkkmi is offline
 

Newbie
  
Join Date: May 2012
Posts: 5
 

Default X-Payments Connector - Response not valid. Check Logs

We are on X-Cart 4.6.3 with X-Payments 1.0.6.

Our xpayments connector seems to have stopped working. At the cart the customer sees this message instead of the usual credit card form fields.

Internal error (Response is not valid.<br />Check logs.)

This is the same message we get when we test the module in the X-Cart admin area. This is what the logs are saying:

[16-Oct-2014 13:28:46] xpay_connector message:
Response is not valid.
Response headers: ''
Response:
Request URI: /payment/payment_cc.php
Backtrace:
/modules/XPayments_Connector/xpc_func.php:1993
/modules/XPayments_Connector/xpc_func.php:1651
/modules/XPayments_Connector/xpc_func.php:372
/payment/cc_xpc.php:389
/payment/payment_cc.php:351

I've updated the encryption keys with the X-Payments backend and redeployed. This did not change anything. I've searched the forums and found what sounded like similar issues but nothing has worked.

Anyone know what could cause blank response headers?
__________________
X-Cart Gold 4.6.3
X-Payments 1.0.6
Reply With Quote
  #2  
Old 10-17-2014, 01:09 AM
 
thomasg thomasg is offline
 

Newbie
  
Join Date: Jan 2010
Posts: 5
 

Default Re: X-Payments Connector - Response not valid. Check Logs

I have the same issue Xcart version 4.5.5
__________________
hg
Reply With Quote
  #3  
Old 10-17-2014, 04:30 AM
  ambal's Avatar 
ambal ambal is offline
 

X-Cart team
  
Join Date: Sep 2002
Posts: 4,102
 

Default Re: X-Payments Connector - Response not valid. Check Logs

Hi Everyone,

I see you both use X-Payments Enterprise/Downloadable licenses.

Most likely your hosting disabled SSLv3 due to POODLE - see https://www.digitalocean.com/community/tutorials/how-to-protect-your-server-against-the-poodle-sslv3-vulnerability

Your version of X-Cart connector for X-Payments may require SSLv3 and that's why it stopped working all of sudden.

We are preparing a newsletter about what to do. Please stay tuned and I will post an update shortly today.
__________________
Sincerely yours,
Alex Mulin
VP of business development for X-Cart
X-Payments project manager
Reply With Quote
  #4  
Old 10-17-2014, 05:59 AM
  ambal's Avatar 
ambal ambal is offline
 

X-Cart team
  
Join Date: Sep 2002
Posts: 4,102
 

Default Re: X-Payments Connector - Response not valid. Check Logs

See http://forum.x-cart.com/showthread.php?t=70268
__________________
Sincerely yours,
Alex Mulin
VP of business development for X-Cart
X-Payments project manager
Reply With Quote
  #5  
Old 10-17-2014, 09:41 AM
 
rct rct is offline
 

Advanced Member
  
Join Date: Dec 2004
Posts: 89
 

Default Re: X-Payments Connector - Response not valid. Check Logs

I am using X-cart v.4.4.5, using 2.1.1 x-payment.
We tried to update the x-payment-connector, however it is not working.

Error:
[17-Oct-2014 09:08:27] (shop: 17-Oct-2014 09:08:27) xpay_connector message:
Response is not valid.
Response headers: ''
Response:
Request URI: /admin/xpc_admin.php
Backtrace:
17-Oct-2014 09:08:27] (shop: 17-Oct-2014 09:08:27) xpay_connector message:
Response is not valid.
Response headers: ''
Response:
Request URI: /admin/xpc_admin.php
Backtrace:
/home/xxx/public_html/modules/XPayments_Connector/xpc_func.php:2127
/home/xxx/public_html/modules/XPayments_Connector/xpc_func.php:1774
/home/xxx/public_html/modules/XPayments_Connector/xpc_func.php:1231
/home/xxx/public_html/modules/XPayments_Connector/xpc_func.php:2999
/home/xxx/public_html/modules/XPayments_Connector/xpc_admin.php:111
/home/xxx/public_html/admin/xpc_admin.php:84
-------------------------------------------------
[17-Oct-2014 09:08:27] (shop: 17-Oct-2014 09:08:27) xpay_connector message:
Internal error.
Request URI: /admin/xpc_admin.php
Backtrace:
/home/xxx/public_html/modules/XPayments_Connector/xpc_func.php:2127
/home/xxx/public_html/modules/XPayments_Connector/xpc_func.php:1867
/home/xxx/public_html/modules/XPayments_Connector/xpc_func.php:1820
/home/xxx/public_html/modules/XPayments_Connector/xpc_func.php:1251
/home/xxx/public_html/modules/XPayments_Connector/xpc_func.php:2999
/home/xxx/public_html/modules/XPayments_Connector/xpc_admin.php:111
/home/xxx/public_html/admin/xpc_admin.php:84


Also at the x-cart admin backend, after we input the configuration bundle and click on deploy, it will loop back to the welcome#xpc-tabs-payment-methods , hence we have NO IDEA if it is working or not.

Does anyone can help?
__________________
JOHN - v.5.3.X biz, X-payment 3.X
Reply With Quote
  #6  
Old 10-17-2014, 09:42 AM
  ambal's Avatar 
ambal ambal is offline
 

X-Cart team
  
Join Date: Sep 2002
Posts: 4,102
 

Default Re: X-Payments Connector - Response not valid. Check Logs

See my above posts and links
__________________
Sincerely yours,
Alex Mulin
VP of business development for X-Cart
X-Payments project manager
Reply With Quote
  #7  
Old 10-17-2014, 09:50 AM
 
apkkmi apkkmi is offline
 

Newbie
  
Join Date: May 2012
Posts: 5
 

Default Re: X-Payments Connector - Response not valid. Check Logs

The issue seems to have been the SSLv3 disabling due to POODLE.

The patch provided here worked.

Thanks

Quote:
Originally Posted by ambal
__________________
X-Cart Gold 4.6.3
X-Payments 1.0.6
Reply With Quote

The following user thanks apkkmi for this useful post:
ambal (10-21-2014)
Reply
   X-Cart forums > X-Payments > X-Payments issues & questions


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -8. The time now is 08:06 PM.

   

 
X-Cart forums © 2001-2018