Follow us on Twitter X-Cart on Facebook Wiki
Shopping cart software Solutions for online shops and malls

Can't get API results to show up in my code

 
Reply
   X-Cart forums > X-Cart 5 > Modules and themes (X-Cart 5)
 
Thread Tools Search this Thread
  #1  
Old 06-03-2020, 04:18 AM
 
atclarkson atclarkson is offline
 

Newbie
  
Join Date: Mar 2015
Posts: 7
 

Default Can't get API results to show up in my code

I'm sure this will come down to some misunderstanding on my part.

I can make an API call to my store and get the results to show up in my browser window and in Postman. But when I try to make the call using some C++ code I wrote I get an HTTP response code of 200 but I don't get the JSON as I expected to.

When testing my code with a placeholder API like https://jsonplaceholder.typicode.com/posts
It works just fine.

Am I missing something obvious? Is the xCart API different somehow?

If anyone has more experience than me and could help me out I would be greatly appreciative.
__________________
X-Cart Business 5.3.6.6
www.agritronixcorp.com
Reply With Quote
Reply
   X-Cart forums > X-Cart 5 > Modules and themes (X-Cart 5)


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -8. The time now is 12:05 AM.

   

 
X-Cart forums © 2001-2020