Follow us on Twitter X-Cart on Facebook Wiki
Shopping cart software Solutions for online shops and malls

"Internal Error " message
 
Reply
   X-Cart forums > X-Payments > X-Payments issues & questions
 
Thread Tools
  #11  
Old 07-25-2014, 06:25 AM
  mcanitano's Avatar 
mcanitano mcanitano is offline
 

eXpert
  
Join Date: Feb 2006
Location: Melbourne, FL
Posts: 216
 

Default Re: "Internal Error " message

I've had problems with X-payments as well. First make sure you follow the steps in:

http://help.x-cart.com/index.php?title=X-Payments:Installation

Next, we ran into a problem with our hosting and SSL. Are you hosting x-cart/x-payments yourself or using a service (such as EWD Hosting or Total Server Solutions)

If so, have them check your problem, as they seemed to help us very easily and recognize exactly what is going on.
__________________
Marcello Canitano
New Site: X-Cart v4.5.5 GOLD
X-Cart Mobile v1.4.3
X-Payments v1.0.6
CDSEO Pro v2
Total Server Solutions xCDN

www.silverhorseracing.com
Reply With Quote
  #12  
Old 07-25-2014, 07:57 AM
 
vraj123@yahoo.com vraj123@yahoo.com is offline
 

Member
  
Join Date: Jun 2010
Posts: 27
 

Default Re: "Internal Error " message

I have my OWN server and SSl from Godaddy which seems perfectly fine
becuase i can see verification certificate from Godaddy upon clicking on LOCksign besides URL
__________________
i am using New PHP and MYSQl i=on new server... the problem is FRENCH is not working properly .. can anyone help?? also if i want to upgrade my licence version of X cart to new one... how can i do that keeping same layout and DB.. my store is very very busy
Reply With Quote
  #13  
Old 07-25-2014, 08:32 AM
 
vraj123@yahoo.com vraj123@yahoo.com is offline
 

Member
  
Join Date: Jun 2010
Posts: 27
 

Default Re: "Internal Error " message

now something new on TEST MODULE it says "response is not valid"
all i regenerate the key on x-payment and deploy bundle to x-connector
__________________
i am using New PHP and MYSQl i=on new server... the problem is FRENCH is not working properly .. can anyone help?? also if i want to upgrade my licence version of X cart to new one... how can i do that keeping same layout and DB.. my store is very very busy
Reply With Quote
  #14  
Old 07-25-2014, 08:38 AM
  mcanitano's Avatar 
mcanitano mcanitano is offline
 

eXpert
  
Join Date: Feb 2006
Location: Melbourne, FL
Posts: 216
 

Default Re: "Internal Error " message

Quote:
Originally Posted by vraj123@yahoo.com
now something new on TEST MODULE it says "response is not valid"
all i regenerate the key on x-payment and deploy bundle to x-connector

I had the exact same problem.

We had to switch our SSL to OpenSSL (Admin side, go to General Settings and scroll down). Then the hosting provider messed with the SSL.

My hosting provider solved it, this was their response:

"We have tweaked the cipher suite for SSL on the server and the test connection now works. It seems that something has changed this week in regards to the SSL ciphers and what is and isn't acceptable for X-Payments."

This seems like an X-Payments problem. Hopefully XC team can figure out what happened so it doesn't happen to others.
__________________
Marcello Canitano
New Site: X-Cart v4.5.5 GOLD
X-Cart Mobile v1.4.3
X-Payments v1.0.6
CDSEO Pro v2
Total Server Solutions xCDN

www.silverhorseracing.com
Reply With Quote
  #15  
Old 07-25-2014, 12:15 PM
 
vraj123@yahoo.com vraj123@yahoo.com is offline
 

Member
  
Join Date: Jun 2010
Posts: 27
 

Default Re: "Internal Error " message

how ever if i go back to previous configuration.. it works but still same error
"RESPONSE IS NOT VALID"
__________________
i am using New PHP and MYSQl i=on new server... the problem is FRENCH is not working properly .. can anyone help?? also if i want to upgrade my licence version of X cart to new one... how can i do that keeping same layout and DB.. my store is very very busy
Reply With Quote
  #16  
Old 08-04-2014, 06:59 AM
  ambal's Avatar 
ambal ambal is offline
 

X-Cart team
  
Join Date: Sep 2002
Posts: 4,099
 

Default Re: "Internal Error " message

Vraj,

In order to figure out exact reason we need to go into your server and investigate there.
__________________
Sincerely yours,
Alex Mulin
VP of business development for X-Cart
X-Payments project manager
Reply With Quote
  #17  
Old 10-22-2014, 06:52 AM
 
dcplastics dcplastics is offline
 

Advanced Member
  
Join Date: Sep 2008
Posts: 48
 

Default Internal Error During Checkout

Getting the following issue when random customers are checking out. It works for some and does not work for others. Internal Servor Error (R)

Once you click the submit button, it doesn't even take you to the credit card details entry page. It just gives an error message.


[22-Oct-2014 10:37:01] PAYMENTS message:
Payment processing failure.
Login:
IP: 216.25.191.122
----
Payment method: Credit Card (X-Payments: PayPal WPP Direct Payment)
bill_output = Array
(
[cvvmes] => not set /
[code] => 2
[billmes] => Internal error (R)
)
original_bill_output = Array
(
[cvvmes] => not set /
[code] => 2
[billmes] => Internal error (R)
)
Request URI: /xcart/payment/payment_cc.php
Backtrace:
D:\Domains\dcvmx.com\wwwroot\xcart\payment\payment _ccmid.php:457
D:\Domains\dcvmx.com\wwwroot\xcart\payment\payment _ccend.php:48
D:\Domains\dcvmx.com\wwwroot\xcart\payment\payment _cc.php:337
__________________
X-Cart Gold
4.5.4
Reply With Quote
  #18  
Old 10-22-2014, 06:53 AM
 
dcplastics dcplastics is offline
 

Advanced Member
  
Join Date: Sep 2008
Posts: 48
 

Default Re: Internal Error During Checkout

X-Cart version 4.5.4
__________________
X-Cart Gold
4.5.4
Reply With Quote
  #19  
Old 10-22-2014, 11:41 PM
  ambal's Avatar 
ambal ambal is offline
 

X-Cart team
  
Join Date: Sep 2002
Posts: 4,099
 

Default Re: "Internal Error " message

Hi dcplastics,

Possible reasons are explained at http://help.x-cart.com/index.php?title=X-Payments:Troubleshooting#No_credit_card_form_displ ayed_when_a_customer_pays

Also, make sure this is not related to the POODLE issue - see http://forum.x-cart.com/showthread.php?t=70268 - your host could disable SSLv3 support and you might need to apply a patch that will enable X-Payments connector module in your X-Cart to use TLS instead of SSLv3.

Also, I recommend you to install our new updated X-Cart connector for your version - see http://forum.x-cart.com/showthread.php?t=69505
__________________
Sincerely yours,
Alex Mulin
VP of business development for X-Cart
X-Payments project manager
Reply With Quote
Reply
   X-Cart forums > X-Payments > X-Payments issues & questions


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -8. The time now is 09:15 AM.

   

 
X-Cart forums © 2001-2018