Follow us on Twitter X-Cart on Facebook Wiki
Shopping cart software Solutions for online shops and malls

Advice on how to develop 5.0 from 4.6.x...
 
Reply
   X-Cart forums > Considering X-Cart > Considering using X-Cart for my project
 
Thread Tools Search this Thread
  #1  
Old 03-17-2014, 06:25 PM
 
kevinrm kevinrm is online now
 

X-Adept
  
Join Date: Aug 2003
Posts: 967
 

Default Advice on how to develop 5.0 from 4.6.x...

Could someone please give me some advice?

I have a live 4.6.3 store. I would like to develop it to 5.0.x, but I realize this will take time. For starters, there is still no multi-currency module and I need that. However, I could at least get it started, right? So I download a trial version into a subdirectory and start working on it. I like it enough - I'll purchase an upgrade license. However, they tell me I would have to exchange the license - shut down my live store to make the 5.0.x work. No, not ready for that! It takes weeks to get a store readyy. Since I don't have a license for the 5.0.x version yet, I can't upgrade anything on it, it won't let me unless I have a license. I contact them, no, they say they can only issue me one license at a time.

So how does X-Cart expect me to upgrade my store from 4.6.3 to 5.0.x, and while it's being developed, be unable to upgrade it because I still don't have a license for it? If I buy an exchange license, then they expect me to shut my live store down. This is ridiculous, I've been using x-cart since version 3.4, but now I cannot develop and upgrade this damn thing to 5.0.x without shutting down my live store?!?!

I guess I'm expected to re-download each version of 5.0.x and re-build it each time. Forget it!
__________________
X-Cart 5.3.6.4 Live
PHP7.2.22
FPM/FastCGI - enabled
Zend OpCache OFF - Won't work with phar extension in cPanel on
10.3.16-MariaDB
Apache 2.4.34
CENTOS 6.8 64Bit Single Quad-Core E3-1241v3 3.4Ghz 8M 1600 w/ HT
32GB RAM 2x 512GB Samsung 850 Pro SSD RAID 1
Reply With Quote
  #2  
Old 03-17-2014, 07:34 PM
  cflsystems's Avatar 
cflsystems cflsystems is offline
 

Veteran
  
Join Date: Apr 2007
Posts: 13,615
 

Default Re: Advice on how to develop 5.0 from 4.6.x...

This doesn't sound right. It has always been that you can buy as many XC licenses as you want. It has always been that you can have temp url for the license...
Are you saying if you just go to x-cart.com (not through QT support) and try to purchase a license of XC5 it will not let you as long as you have XC4 license active?

No this doesn't sound right...
__________________
Steve Stoyanov
CFLSystems.com
Web Development
Reply With Quote
  #3  
Old 03-17-2014, 08:48 PM
 
kevinrm kevinrm is online now
 

X-Adept
  
Join Date: Aug 2003
Posts: 967
 

Default Re: Advice on how to develop 5.0 from 4.6.x...

I don't need two licenses, just one. One is active, my live 4.6 store. I'm trying to develop XC5 in a subdirectory, I installed it. However, they're upgrading that thing almost by the day and XC5 won't allow me to upgrade, it requires a license to upgrade anything on it. I will have to re-download and re-install the whole thing all over again I guess! So I asked them if I can pay for the 4.6 to 5.0 upgrade and leave my live store alone while I develop this XC5 in the subdirectory and not take it live - they say "no". So I guess I will have to wait until XC5 is developed sufficiently (has a multi currency mod, etc) before I can even start it, spend a lot of time (weeks) working on it, and hope they don't upgrade it again before I transfer the license.

This is really short sighted, just saying'!
__________________
X-Cart 5.3.6.4 Live
PHP7.2.22
FPM/FastCGI - enabled
Zend OpCache OFF - Won't work with phar extension in cPanel on
10.3.16-MariaDB
Apache 2.4.34
CENTOS 6.8 64Bit Single Quad-Core E3-1241v3 3.4Ghz 8M 1600 w/ HT
32GB RAM 2x 512GB Samsung 850 Pro SSD RAID 1
Reply With Quote
  #4  
Old 03-18-2014, 02:47 AM
 
Kirill Kirill is offline
Advanced Staff Users
 

X-Cart team
  
Join Date: Nov 2013
Posts: 105
 

Default Re: Advice on how to develop 5.0 from 4.6.x...

Dear Kevin,

I apologize for the inconvenience.

Thank you for attracting our attention to this issue.

We've discussed it and from now on those migrating from X-Cart 4 to X-Cart 5 will be able to keep using their original store while developing the new one even if they've already exchanged the license.

You will just need to mention this during the purchase of the license exchange and we will make all the necessary adjustments.

And, of course, there will be no limit for the development period.
__________________
X-Cart team
Reply With Quote

The following 2 users thank Kirill for this useful post:
cflsystems (03-19-2014), Ksenia (03-18-2014)
  #5  
Old 03-18-2014, 10:21 PM
 
kevinrm kevinrm is online now
 

X-Adept
  
Join Date: Aug 2003
Posts: 967
 

Default Re: Advice on how to develop 5.0 from 4.6.x...

Thank you, upgrade license purchased!
__________________
X-Cart 5.3.6.4 Live
PHP7.2.22
FPM/FastCGI - enabled
Zend OpCache OFF - Won't work with phar extension in cPanel on
10.3.16-MariaDB
Apache 2.4.34
CENTOS 6.8 64Bit Single Quad-Core E3-1241v3 3.4Ghz 8M 1600 w/ HT
32GB RAM 2x 512GB Samsung 850 Pro SSD RAID 1
Reply With Quote
Reply
   X-Cart forums > Considering X-Cart > Considering using X-Cart for my project


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -8. The time now is 04:48 PM.

   

 
X-Cart forums © 2001-2018