Follow us on Twitter X-Cart on Facebook Wiki
Shopping cart software Solutions for online shops and malls

Php 7.1 Problem

 
Reply
   X-Cart forums > X-Cart 4 > Third Party Add-Ons for X-Cart 4
 
Thread Tools
  #1  
Old 04-26-2018, 09:26 PM
  Blainevk's Avatar 
Blainevk Blainevk is offline
 

Senior Member
  
Join Date: Dec 2004
Location: Atlanta, GA
Posts: 153
 

Default Php 7.1 Problem

COPIES TO:
Xcart.com
BCS Engineering
XcartMods
---------------------------------

Hello,

I wanted to explain where I am on changing my server to PHP 7.1

Upon doing so, my Xcart store & admin became blank White Pages, it has been incapacitated for about a month+.

Somewhere/somehow along the way, Admin became accessible again!?

I put the word out to Xcart and two 3rd Party Add-on Modules, "BCS Engineering's Customer Reward Points" and the beautiful skin template, reBOOT, from XcartMods.

Nobody believed that their product was causing the problem (blank White Page store).

I received suggestions from all and one offered to research the problem for a fee. I tried all suggestions and the one that seemed to have the best results was "Try un-enabling each module" and see if that helps.

Well, it did. I un-enabled "Customer Reward Points", nothing happened, but when I un-enabled "reBOOT" my store appeared again in all it's glory... but, the strange thing is, with "reBOOT" un-enabled (turned-off) it was still working in the store, BUT it was NOT accessible in my Xcart Admin.... If I enable it again, it will appear in Admin but my store reappears again as an all White Blank Page.... un-enable it again, it works in the store but is inaccessible in my admin! "GREMLINS I TELL YOU!"

Any ideas from anyone?

I CREATED A NEW SUBCATEGORY:
Yesterday, I decided that since my store seemed to be working again, I wanted to start adding more products to my store.

The first thing I did was create a NEW Category: Gift Cards

... after clicking "Apply Changes", I was instantly logged out of Admin... I didn't think much of it, so I logged back in and "Gift Cards" had been added as a new SubCategory under Redemption Center.

ADDED A NEW PRODUCT:
As I began adding my first new product to the new Category, when I was adding the product picture, it went through the process but never installed... I continued creating the product, clicked "Apply Changes" and when I checked the product it appeared under the "Gift Card" subcategory "without" a photo... I tried several times but was not able to add an image or thumbnail.

MULTIPLE PRICES NOT CHANGING:
The Gift Card that I added had multiple prices and after it was created, when I selected a different price in the pull-down, the price did not change next to, "Cash Price:"

I VIEWED CART:
I decided to check a few more things, I added a product to my Cart, it did nothing, when I went to view my cart, I GOT A BLANK WHITE PAGE.

MAINTENANCE / CAN'T RE-GENERATE THE IMAGE CACHE:
I decided to try emptying cache to see if that might help... I went into Admin / Tools / Maintenance, optimized tables, emptied cache, rebuilt category indexes... I did it ALL, but when I tried to "Re-generate The Image Cache", NOTHING HAPPENED, the page just sat there displaying: "Re-generating the image cache: (0%)"!

I CHECKED FOR PERMISSIONS:
image folder -- 705
B, C, D, F, G, , , , , Z, etc, folders -- 705

========================

All products created before (probably before I changed PHP to 7.1) seem to be working fine, but the new Category & Gift Card that I created yesterday, not so much!

Does anyone have any ideas or other suggestions to try to fix this? (I'm getting frustrated and I want to get my business back on track.

I'm currently using Xcart Version 4.7.5, and I thought about upgrading to the new 4.7.9 to see it that would solve my problem but decided not to, in case it would case even more problems.

XcartMods is looking into things to see if reBOOT has a glitch, or a combination of PHP 7.1, my current version of Xcart, or conflict with the other mods and PHP 7.1... Forgive me, for I wish I was more Tech Savy.

========================

If everyone can put their heads together and help solve this situation, it may help other Xcart owners in the future, and/or help in the development of future versions of Xcart, Customer Rewards and reBOOT!

Looking for anyone's help,
Blaine Klingaman
__________________
Blaine

X-Cart Multi-vendor 5.4.1.5
PHP version: 7.2.23

Blaine's Travel Network - http://blainestravelnetwork.net
__________________________________________________ ________

Travel Points Gift Mall - https://blainestravelnetwork.net/travelpoints/giftmall/

Create a Rewards Program - http://blainestravelnetwork.net/travelpoints/

Grow Your Business - http://blainevk.blainestravelnetwork.net/business/

Making Money & Fun - http://blainestravelnetwork.net/powerpyramid/
Reply With Quote
  #2  
Old 04-27-2018, 12:36 AM
 
aim aim is offline
Advanced Staff Users
 

X-Cart team
  
Join Date: Dec 2008
Posts: 928
 

Default Re: Php 7.1 Problem

Hello, Blaine,

X-Cart 4.7.5 doesn't support PHP7.1 by default.
The best way to solve it is to upgrade to X-Cart 4.7.9 which even supports PHP7.2
https://www.x-cart.com/blog/x-cart-v4-7-9-released-skrill-paypal-updates-store-notifications-seo-bug-fixes.html

Alternatively, you can apply the attached patches to make X-Cart 4.7.5 PHP7.1 compatible.

PHP7.0Critical.4.7.5.diff
PHP7.1Critical.4.7.5.diff

As for 3rd-party skins/modules I suggest you refer to the mod's authors.

The quickest way to localize the problem with the white screen is checking for var/log/x-errors_php-<date>.php log files.

Do you have such a file?
var/log/x-errors_php-<date>.php

Thank you.
Attached Files
File Type: diff PHP7.0Critical.4.7.5.diff (4.6 KB, 3 views)
File Type: diff PHP7.1Critical.4.7.5.diff (7.5 KB, 5 views)
__________________
Sincerely yours,
Ildar Amankulov
Head of Maintenance group
Reply With Quote

The following user thanks aim for this useful post:
PhilJ (04-27-2018)
  #3  
Old 04-27-2018, 01:15 AM
 
PhilJ PhilJ is offline
 

X-Guru
  
Join Date: Nov 2002
Posts: 3,929
 

Default Re: Php 7.1 Problem

Give it a go Blaine, any problems, don't ask me.

Just kidding, update the ticket
__________________
XCARTMODS.CO.UK | reBOOT Template | Changelog
Reply With Quote
  #4  
Old 04-27-2018, 11:31 AM
  Blainevk's Avatar 
Blainevk Blainevk is offline
 

Senior Member
  
Join Date: Dec 2004
Location: Atlanta, GA
Posts: 153
 

Wink Re: Php 7.1 Problem

Quote:
Originally Posted by PhilJ
Give it a go Blaine, any problems, don't ask me.

Just kidding, update the ticket

I did update the ticket, but I know you're busy finishing reDUX
__________________
Blaine

X-Cart Multi-vendor 5.4.1.5
PHP version: 7.2.23

Blaine's Travel Network - http://blainestravelnetwork.net
__________________________________________________ ________

Travel Points Gift Mall - https://blainestravelnetwork.net/travelpoints/giftmall/

Create a Rewards Program - http://blainestravelnetwork.net/travelpoints/

Grow Your Business - http://blainevk.blainestravelnetwork.net/business/

Making Money & Fun - http://blainestravelnetwork.net/powerpyramid/
Reply With Quote
Reply
   X-Cart forums > X-Cart 4 > Third Party Add-Ons for X-Cart 4


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -8. The time now is 09:21 AM.

   

 
X-Cart forums © 2001-2020