Follow us on Twitter X-Cart on Facebook Wiki
Shopping cart software Solutions for online shops and malls

X-Payments/X-Cart Future Compatibility
 
Reply
   X-Cart forums > X-Payments > X-Payments issues & questions
 
Thread Tools
  #1  
Old 08-29-2012, 05:44 AM
 
topspin6711 topspin6711 is offline
 

Member
  
Join Date: May 2010
Posts: 22
 

Default X-Payments/X-Cart Future Compatibility

Alex,

I have another concern with using x-payments. (BTW, I have just installed 1.0.5 along with x-cart 4.5.2 for a new project and had no problems with the install once I got my SSL cert.)

My concern is with future upgrades and upgrade paths if I really go with x-payments. I was talking with Steve of cflsystems who is so much more knowledgable of x-cart and upgrades than me and he was not sure either. However, he seems to believe the following:
PCI compliance will require future upgrades of x-payments within some specified time. It may be 30 days, it may be 90 days, but it will be required.
Now my concern. It's not easy to upgrade x-cart when you are talking about major versions. I had almost completed my new store on 4.4.5 when I decided to scrap it for 4.5.2 and basically start over.

Using x-payments will I find a day when a PCI required upgrade of X-Payments will necessitate a major upgrade of x-cart to continue working? My concern is that because the upgrade of x-payments will be required in a limited timeframe, I will find myself scrambling to upgrade x-cart at perhaps the worst time when I have so many other things on my plate. A time when I had no plans to upgrade x-cart.

I would think this has to be a real concern. So can you say X-Payments going forward will always remain backward compatible with say x-cart 4.5.x and forward?

Thank you.
__________________
X-Cart 4.5.2 Gold Live
X-Cart 4.7.3 Gold Dev
Reply With Quote
  #2  
Old 08-29-2012, 05:53 AM
  ambal's Avatar 
ambal ambal is offline
 

X-Cart team
  
Join Date: Sep 2002
Posts: 4,102
 

Default Re: X-Payments/X-Cart Future Compatibility

> So can you say X-Payments going forward will always remain backward compatible
> with say x-cart 4.5.x and forward?

Quote:
Want to make the God laugh - tell him about your plans (c)

We can't promise that and we can't promise the opposite. What we can promise is that we will develop X-Payments further (e.g. we are planning version 1.1 this fall).

Also, upgrade of X-Payments is very easy (especially comparing with X-Cart) - in nutshell it is simple overwrite of files. See http://help.x-cart.com/index.php?title=X-Payments:Upgrading
__________________
Sincerely yours,
Alex Mulin
VP of business development for X-Cart
X-Payments project manager
Reply With Quote
  #3  
Old 08-29-2012, 06:21 AM
 
topspin6711 topspin6711 is offline
 

Member
  
Join Date: May 2010
Posts: 22
 

Default Re: X-Payments/X-Cart Future Compatibility

Thanks Alex,

Can you say anything about upgrades of x-payments and PCI compliance? What are the rules for staying on the latest and greatest?
__________________
X-Cart 4.5.2 Gold Live
X-Cart 4.7.3 Gold Dev
Reply With Quote
  #4  
Old 08-29-2012, 06:24 AM
  ambal's Avatar 
ambal ambal is offline
 

X-Cart team
  
Join Date: Sep 2002
Posts: 4,102
 

Default Re: X-Payments/X-Cart Future Compatibility

You should be compliant by using major version of X-Payments listed at the PCI council site.
Currently X-Payments version 1.0.x is listed at
https://www.pcisecuritystandards.org/approved_companies_providers/validated_payment_applications.php?agree=true

However, you should understand that "PCI compliance" is not just using PA-DSS certified software. It assumes other requirements, too. PA-DSS certification for software is just one of them.
__________________
Sincerely yours,
Alex Mulin
VP of business development for X-Cart
X-Payments project manager
Reply With Quote

The following user thanks ambal for this useful post:
totaltec (08-29-2012)
Reply
   X-Cart forums > X-Payments > X-Payments issues & questions


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -8. The time now is 01:08 AM.

   

 
X-Cart forums © 2001-2018