Follow us on Twitter X-Cart on Facebook Wiki
Shopping cart software Solutions for online shops and malls

Is X-Payments 2.0 required for 4.6.x?
 
Reply
   X-Cart forums > X-Payments > X-Payments issues & questions
 
Thread Tools
  #1  
Old 05-13-2014, 06:16 PM
 
NuAlpha NuAlpha is offline
 

X-Adept
  
Join Date: Aug 2003
Location: US
Posts: 598
 

Question Is X-Payments 2.0 required for 4.6.x?

I am planning to upgrade from 4.5.5 to 4.6.3. Is X-Payments 2.0 required for 4.6.3 or can I continue to use X-Payments 1.0.6?
__________________
X-Cart Pro 4.5.5 Platinum
X-Payments 1.0.6
PHP 5.3.14
MySQL 5.1.68
Apache 2.2.23
Reply With Quote
  #2  
Old 05-13-2014, 07:20 PM
  totaltec's Avatar 
totaltec totaltec is offline
 

X-Guru
  
Join Date: Jan 2007
Location: Louisville, KY USA
Posts: 5,825
 

Default Re: Is X-Payments 2.0 required for 4.6.x?

I don't think so. You should be able to continue to use your version of X-payments.

I see this from Alex's blog post:

"Those who installed and started using X-Payments v1.0 can just continue doing so for any time ahead as it is acceptable for existing deployments. New deployments of X-Payments v1.0 are not allowed after October 28th 2013 due to the PCI Council regulations for PA-DSS certified applications and we have already stopped selling this version."


This seem to just be new deployments of X-payments. Not X-cart. I think both software packages are backward compatible. Though I have no proof of that.
__________________
Mike White - Now Accepting new clients and projects! Work with the best, get a US based development team for just $125 an hour. Call 1-502-773-6454, email mike at babymonkeystudios.com, or skype b8bym0nkey

XcartGuru
X-cart Tutorials | X-cart 5 Tutorials

Check out the responsive template for X-cart.
Reply With Quote
  #3  
Old 05-13-2014, 11:50 PM
  ambal's Avatar 
ambal ambal is offline
 

X-Cart team
  
Join Date: Sep 2002
Posts: 4,102
 

Default Re: Is X-Payments 2.0 required for 4.6.x?

Quote:
Originally Posted by NuAlpha
I am planning to upgrade from 4.5.5 to 4.6.3. Is X-Payments 2.0 required for 4.6.3 or can I continue to use X-Payments 1.0.6?

You can continue using an existing installation of v1.0.6 of course, but it won't support PCI compliant credit card saving for customers new orders and recurring billing as this is supported in X-Payments v2.x.

If you are deploying a new X-Payments installation you have to go with X-Payments v2.x due to PA-DSS regulations - see http://forum.x-cart.com/showthread.php?t=68020 for more details why.
__________________
Sincerely yours,
Alex Mulin
VP of business development for X-Cart
X-Payments project manager
Reply With Quote

The following user thanks ambal for this useful post:
totaltec (05-14-2014)
  #4  
Old 05-14-2014, 05:23 AM
 
NuAlpha NuAlpha is offline
 

X-Adept
  
Join Date: Aug 2003
Location: US
Posts: 598
 

Default Re: Is X-Payments 2.0 required for 4.6.x?

Much appreciated!
__________________
X-Cart Pro 4.5.5 Platinum
X-Payments 1.0.6
PHP 5.3.14
MySQL 5.1.68
Apache 2.2.23
Reply With Quote
Reply
   X-Cart forums > X-Payments > X-Payments issues & questions


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -8. The time now is 11:39 PM.

   

 
X-Cart forums © 2001-2018