Follow us on Twitter X-Cart on Facebook Wiki
Shopping cart software Solutions for online shops and malls

Subscription status: Not created
 
Reply
   X-Cart forums > X-Payments > X-Payments issues & questions
 
Thread Tools
  #1  
Old 06-06-2018, 12:20 PM
 
Gunstar1 Gunstar1 is offline
 

Newbie
  
Join Date: Oct 2009
Posts: 3
 

Default Subscription status: Not created

I have seen a few of these now on subscriptions with a successful checkout. There are not many, maybe 10 in the last 200 subscriptions, but still there seems to be some sort of problem.

Below is an x-payment connector error for the same time as the latest "not created".

Code:
[05-Jun-2018 20:55:51] xpay_connector message: Process callback data. Transaction id is not found Request URI: /store/payment/cc_xpc.php Backtrace: /public_html/store/modules/XPayments_Connector/xpc_func.php:2278 /public_html/store/modules/XPayments_Connector/xpc_func.php:862 /public_html/store/payment/cc_xpc.php:380

However, I get this error showing up in the logs a number of times (30 in the last 400 orders).

If I were to guess, it is that the when one of the above errors happens and it is for a subscription, that is the cause of the "not created". Though I am not sure.

Any ideas on why this error is happening? Some timeout or something I have set too low on my server? X-payments is hosted, but xcart is on my own server.
__________________
XC Plat 4.7.3
XPay Hosted
Reply With Quote
  #2  
Old 06-08-2018, 11:44 AM
  random's Avatar 
random random is offline
Advanced Staff Users
 

X-Cart team
  
Join Date: Dec 2008
Posts: 79
 

Default Re: Subscription status: Not created

Quote:
Originally Posted by Gunstar1
I have seen a few of these now on subscriptions with a successful checkout. There are not many, maybe 10 in the last 200 subscriptions, but still there seems to be some sort of problem.

Below is an x-payment connector error for the same time as the latest "not created".

Code:
[05-Jun-2018 20:55:51] xpay_connector message: Process callback data. Transaction id is not found Request URI: /store/payment/cc_xpc.php Backtrace: /public_html/store/modules/XPayments_Connector/xpc_func.php:2278 /public_html/store/modules/XPayments_Connector/xpc_func.php:862 /public_html/store/payment/cc_xpc.php:380

However, I get this error showing up in the logs a number of times (30 in the last 400 orders).

If I were to guess, it is that the when one of the above errors happens and it is for a subscription, that is the cause of the "not created". Though I am not sure.

Any ideas on why this error is happening? Some timeout or something I have set too low on my server? X-payments is hosted, but xcart is on my own server.

Probably these error log entries were caused by the fact that callback from X-Payments about placed order reached your server earlier than X-Cart actually stored the order in database. That is not an issue generally because order status is updated also when customer payment is completed.

So, deeper investigation of this issues is required. You may contact our technical support team on this matter.
__________________
Sincerely yours,
Vladimir Petrov
Senior X-Payments Developer
Reply With Quote
Reply
   X-Cart forums > X-Payments > X-Payments issues & questions


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -8. The time now is 12:27 PM.

   

 
X-Cart forums © 2001-2018