Follow us on Twitter X-Cart on Facebook Wiki
Shopping cart software Solutions for online shops and malls

iframe problem
 
Reply
   X-Cart forums > X-Payments > X-Payments issues & questions
 
Thread Tools
  #1  
Old 09-14-2012, 09:09 AM
 
Nick S. Nick S. is offline
 

Newbie
  
Join Date: Nov 2011
Posts: 4
 

Default iframe problem

When we enable "Use lite interface" option for a payment method iframe area is blank on checkout page.

it generates the following error:
PHP Notice: Undefined index: xpc_action in /httpdocs/payment/cc_xpc_iframe.php on line 48, referer: https://*IP*/cart.php?mode=checkout

Any ideas what can be wrong?
Can it be related to ssl certificate? We are testing the store using IP address.
Attached Images
File Type: png checkout.png (23.3 KB, 29 views)
__________________
1
Reply With Quote
  #2  
Old 09-15-2012, 01:24 PM
  mcanitano's Avatar 
mcanitano mcanitano is offline
 

eXpert
  
Join Date: Feb 2006
Location: Melbourne, FL
Posts: 216
 

Default Re: iframe problem

I too am having this problem with the iframe area being blank on the checkout page.

I previously had it working, but when switching between a different payment method back to X-Payments method, the iframe would refresh and load the parent page (my website) inside of it, thus causing a loop because it would load the same page inside of it, with the same iframe, over and over.

Now I can not even simply get the iframe to appear.

I attached a picture of mine as well.
Attached Images
File Type: png x-payments-error.PNG (77.7 KB, 15 views)
__________________
Marcello Canitano
New Site: X-Cart v4.5.5 GOLD
X-Cart Mobile v1.4.3
X-Payments v1.0.6
CDSEO Pro v2
Total Server Solutions xCDN

www.silverhorseracing.com
Reply With Quote
  #3  
Old 09-15-2012, 03:54 PM
  cflsystems's Avatar 
cflsystems cflsystems is offline
 

Veteran
  
Join Date: Apr 2007
Posts: 13,615
 

Default Re: iframe problem

Look at the page source code and see if the code for the iframe is in there and just showing somewhere where it can't be seen
__________________
Steve Stoyanov
CFLSystems.com
Web Development
Reply With Quote
  #4  
Old 09-17-2012, 06:33 AM
  mcanitano's Avatar 
mcanitano mcanitano is offline
 

eXpert
  
Join Date: Feb 2006
Location: Melbourne, FL
Posts: 216
 

Default Re: iframe problem

This is the code I copied and pasted from my code source. I see the <iframe> tag is there but there is nothing inside of it.

Code:
<tr class="payment-details" id="pmbox_30"> <td colspan="3"> <div class="opc-payment-options"> <fieldset class="registerform"><script type="text/javascript"> xpc_paymentids[30] = 30; </script> <iframe style="width: 100%; border: 0px; height: 0px;" border="0" marginheight="0" marginwidth="0" frameborder="0" class="xpc_iframe" id="xpc_iframe30" name="xpc_iframe30"> </iframe> <div class="button-hider"> &nbsp; </div></fieldset> </div> </td> </tr>

Oh and also very interesting, using Google Chrome's "inspect element" feature on the right-click menu, I viewed the source code of the <iframe> and saw

Code:
<iframe style="width: 100%; border: 0px; height: 0px;" border="0" marginheight="0" marginwidth="0" frameborder="0" class="xpc_iframe xpc-iframe-shown" id="xpc_iframe30" name="xpc_iframe30" src="payment/cc_xpc_iframe.php?paymentid=30"> </iframe>

Then opened the iframe's src (src="payment/cc_xpc_iframe.php?paymentid=30") and got an error:

Server error
The website encountered an error while retrieving https://MYDOMAIN.com/payment/payment_cc.php. It may be down for maintenance or configured incorrectly.
__________________
Marcello Canitano
New Site: X-Cart v4.5.5 GOLD
X-Cart Mobile v1.4.3
X-Payments v1.0.6
CDSEO Pro v2
Total Server Solutions xCDN

www.silverhorseracing.com
Reply With Quote
  #5  
Old 09-17-2012, 07:31 AM
  cflsystems's Avatar 
cflsystems cflsystems is offline
 

Veteran
  
Join Date: Apr 2007
Posts: 13,615
 

Default Re: iframe problem

Are you sure everything is configured correctly on both sides - XC and X-Payments
__________________
Steve Stoyanov
CFLSystems.com
Web Development
Reply With Quote
  #6  
Old 09-17-2012, 07:38 AM
  mcanitano's Avatar 
mcanitano mcanitano is offline
 

eXpert
  
Join Date: Feb 2006
Location: Melbourne, FL
Posts: 216
 

Default Re: iframe problem

Quote:
Originally Posted by cflsystems
Are you sure everything is configured correctly on both sides - XC and X-Payments

Yes, I went through and tested the X-Payments Connector module through the admin side of my store and it said "Test Transaction Completed Successfully" so that means it is connected correctly. The X-Payments Payment Method is set to "lite" interface, and the Payment Configuration on my X-Payments back side is set to the "lite" template.
__________________
Marcello Canitano
New Site: X-Cart v4.5.5 GOLD
X-Cart Mobile v1.4.3
X-Payments v1.0.6
CDSEO Pro v2
Total Server Solutions xCDN

www.silverhorseracing.com
Reply With Quote
Reply
   X-Cart forums > X-Payments > X-Payments issues & questions


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -8. The time now is 08:29 AM.

   

 
X-Cart forums © 2001-2018