Follow us on Twitter X-Cart on Facebook Wiki
Shopping cart software Solutions for online shops and malls

X Payments Failing after Server Move
 
Reply
   X-Cart forums > X-Payments > X-Payments issues & questions
 
Thread Tools
  #1  
Old 02-02-2018, 12:51 PM
 
Snowfox Snowfox is offline
 

Advanced Member
  
Join Date: Aug 2006
Posts: 81
 

Default X Payments Failing after Server Move

Hi,

We run XCart 4.5.5 and our host needed to migrate our website to a new server. They moved everything, the website and Xcart. Everything works after migration but all orders are failing and looks like it is because of xpayments. The website domain did not change but we have a new IP.

My question, are these failing because of the propagation time or is there something we need to change in XPayments set up to reflect the new IP?

Thanks in advance,
Kaci
__________________
X-Cart 4.75
Linux Servers
Reply With Quote
  #2  
Old 02-02-2018, 12:53 PM
  cflsystems's Avatar 
cflsystems cflsystems is offline
 

Veteran
  
Join Date: Apr 2007
Posts: 13,297
 

Default Re: X Payments Failing after Server Move

Check your X-Payments Connector settings - you may have an IP for the callback entered there.
__________________
Steve Stoyanov
CFLSystems.com
Web Development
Reply With Quote
  #3  
Old 02-02-2018, 01:20 PM
 
Snowfox Snowfox is offline
 

Advanced Member
  
Join Date: Aug 2006
Posts: 81
 

Default Re: X Payments Failing after Server Move

Thanks so much for helping.

I have checked the connector, there is no IP address listed.

I just realized the problem is after migration, I think invoice numbers are being duplicated. The fail shows that invoice number already was processed.

So what I have to do is change the invoice number so it does not conflict. Just a new starting number. I am not sure where to do that, if you know it would be wonderful.

Thanks!
__________________
X-Cart 4.75
Linux Servers
Reply With Quote
  #4  
Old 02-02-2018, 01:24 PM
  cflsystems's Avatar 
cflsystems cflsystems is offline
 

Veteran
  
Join Date: Apr 2007
Posts: 13,297
 

Default Re: X Payments Failing after Server Move

Maintenance page in admin at the bottom of the page you can enter new starting order number.

You can also run this sql on upgrade page sql box
Code:
ALTER TABLE xcart_orders AUTO_INCREMENT = XXX;
where XXX is the next number you want to use. Careful with this - not tested.

Or directly change the next record number in database for orders table
__________________
Steve Stoyanov
CFLSystems.com
Web Development
Reply With Quote
  #5  
Old 02-02-2018, 01:57 PM
 
Snowfox Snowfox is offline
 

Advanced Member
  
Join Date: Aug 2006
Posts: 81
 

Default Re: X Payments Failing after Server Move

THANK YOU SO MUCH!! I cannot tell you how glad I am you helped. Everything is working now.
__________________
X-Cart 4.75
Linux Servers
Reply With Quote

The following user thanks Snowfox for this useful post:
cflsystems (02-02-2018)
  #6  
Old 02-02-2018, 01:57 PM
  cflsystems's Avatar 
cflsystems cflsystems is offline
 

Veteran
  
Join Date: Apr 2007
Posts: 13,297
 

Default Re: X Payments Failing after Server Move

Good to hear
__________________
Steve Stoyanov
CFLSystems.com
Web Development
Reply With Quote

The following user thanks cflsystems for this useful post:
Snowfox (02-02-2018)
  #7  
Old 02-03-2018, 01:40 AM
  ambal's Avatar 
ambal ambal is offline
 

X-Cart team
  
Join Date: Sep 2002
Posts: 4,094
 

Default Re: X Payments Failing after Server Move

Quote:
Originally Posted by Snowfox
Hi,

We run XCart 4.5.5 and our host needed to migrate our website to a new server. They moved everything, the website and Xcart. Everything works after migration but all orders are failing and looks like it is because of xpayments. The website domain did not change but we have a new IP.

My question, are these failing because of the propagation time or is there something we need to change in XPayments set up to reflect the new IP?

Thanks in advance,
Kaci

If you are using a hosted X-Payments instance make sure your new X-Cart server supports TLS 1.2. We disabled SSLv3/TLS 1.0 due to PCI compliance requirements.
__________________
Sincerely yours,
Alex Mulin
VP of business development for X-Cart
X-Payments project manager
Reply With Quote
  #8  
Old 02-05-2018, 09:54 AM
 
Snowfox Snowfox is offline
 

Advanced Member
  
Join Date: Aug 2006
Posts: 81
 

Default Re: X Payments Failing after Server Move

Thanks, I will check on the TLS 1.2
__________________
X-Cart 4.75
Linux Servers
Reply With Quote
Reply
   X-Cart forums > X-Payments > X-Payments issues & questions


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -8. The time now is 09:17 AM.

   

 
X-Cart forums © 2001-2018