Follow us on Twitter X-Cart on Facebook Wiki
Shopping cart software Solutions for online shops and malls

Double release: 5.3.1 and 5.2.16, XC4 to XC5 Migration Wizard, New Developer Portal
 
Reply
   X-Cart forums > News and Announcements
 
Thread Tools
  #21  
Old 08-09-2016, 04:23 PM
 
mgwashburn mgwashburn is offline
 

Advanced Member
  
Join Date: Sep 2013
Posts: 72
 

Default Re: Double release: 5.3.1 and 5.2.16, XC4 to XC5 Migration Wizard, New Developer Portal

OK, you can call me an idiot...

I saw the release of 5.2.16 along with 20+ module updates and decided to give it a whirl on one of our slower x-cart 5.2.15 sites. Zipped up a backup of the folder and backed up the database and tried an 'upgrade all'.

well, that didn't work as it errored out, so I did the update by doing 2-4 modules at a time until they all worked.

There was a module or two that simply would not update which I wasn't using anyways so I removed them (I think one was Skrill payment method?).

In any case it finally finished and everything looked great.

Here is where I got stupid! It seemed smooth enough to I repeated this on our main money site....ugh!

it again seemed to work, but ...

next morning I tried to change a shipping method and it wouldn't let me save the changes...it looked like it worked, but it didn't.

then I realized that the Coupon Code module would not work either, any attempt to change or add a coupon would come back with:

ERROR: "Includes\ErrorHandler::FATAL_ERROR" (code 2)
Call to undefined function XLite\View\FormField\Input\Base\mb_substr()

even worse, I opened a trouble ticket with x-cart support and tried to create an admin account so they could access and fix...and guess what. I cannot add/change or remove any users right now...it errors out as well with:

http://www.naturalbathbody.com/images/xcart-error.png

we are still in that phase of debate with tier I support to see if this is our fault and we need to pay for support or if this is a general problem with one of the updated modules.

but since we are experiencing this on two separate vanilla x-cart websites located on two separate vanilla Amazon AWS EC2 Linux servers...what else could it be?

There is not custom modifications to either of these sites and the only thing that has me a bit worried is that we are running PHP 5.3.x which is the default on Amazon Linux Servers...not sure that matters, but I tried to upgrade a few weeks ago and had to revert as it bombed out on me when trying to go to PHP 5.6.x

Anyone else experience this problem upgrading from 5.2.15 to the new version?
__________________
Marc Washburn
www.EverythingGraphic.com
Five successful X-cart 5.2.x installations
Reply With Quote
  #22  
Old 08-09-2016, 05:27 PM
 
Triple A Racing Triple A Racing is offline
 

X-Adept
  
Join Date: Jul 2008
Location: Manchester UK
Posts: 785
 

Default Re: Double release: 5.3.1 and 5.2.16, XC4 to XC5 Migration Wizard, New Developer Portal

Quote:
Originally Posted by mgwashburn
Anyone else experience this problem upgrading from 5.2.15 to the new version?
With XC5.2.* We now always test every single upgrade within our Dev Store first before going live, as for us anyway, there has ALWAYS been some new challenges somewhere, as part of the 5.2.* upgrade process...

This time, apart from some CSS re-work after the Simple CMS Module was upgraded (which always seems to affect our very simple setup for some reason) and one XC Module that had a glitch when running on XC5.2.16 (which to be fair, was solved and the module upgraded very quickly by XC) we have had no issues going from 5.2.15 to 5.2.16. No errors, no loops, no inoperative functions nothing at all. It is all good at present which is about time! 5.2.16 (finally) works at a good acceptable level for us.

We'll be looking at XC5.3.* from a distance, but not the current 5.3.1.1 stable release because there will definitely be some early bugs in that. It's the law of new software It's too early for lots of time consuming beta-testing. We did all that on XC5.2.* We'll definitely be testing 5.3.* to death, but we are hoping for great things from XC5.3.* onwards
__________________
Live Store & Dev Store / XC Business 5.4.0.6 / PHP 7.3.12
Ubuntu 18.04.3 LTS (HWE 5.0.0-37.40 Kernel) / Plesk Obsidian
Nginx 1.16.1 / Apache 2.4.29 (Ubuntu Backported) / MariaDB 10.3.21
Reply With Quote
  #23  
Old 08-09-2016, 08:14 PM
  cflsystems's Avatar 
cflsystems cflsystems is offline
 

Veteran
  
Join Date: Apr 2007
Posts: 13,616
 

Default Re: Double release: 5.3.1 and 5.2.16, XC4 to XC5 Migration Wizard, New Developer Portal

Do you have the php mbstring extension installed? You can check with phpinfo
__________________
Steve Stoyanov
CFLSystems.com
Web Development
Reply With Quote

The following user thanks cflsystems for this useful post:
mgwashburn (08-09-2016)
  #24  
Old 08-09-2016, 09:18 PM
 
mgwashburn mgwashburn is offline
 

Advanced Member
  
Join Date: Sep 2013
Posts: 72
 

Default Re: Double release: 5.3.1 and 5.2.16, XC4 to XC5 Migration Wizard, New Developer Portal

Quote:
Originally Posted by cflsystems
Do you have the php mbstring extension installed? You can check with phpinfo
OMG!!!

Once again Steve at CFL Systems comes through....yes I was able to fix both x-cart 5.2.16 installations by simply:

yum install php-mbstring

I did a php - i | more and I did see one mention of mbstring, but I could not determine whether or not it was actually installed or not.

So being a somewhat casual Linux user I decided to go ahead and issue the yum command to install it as if it was already installed it would tell me and if not then it would simply add it.

I am SOOOOOO grateful, thank you so much, I will post this solution back to my trouble ticket so tier 1 support at x-cart can add this to their database.

So, the take away is that the standard Amazon AWS EC2 linux distribution does not install this module.

just a heads up to anyone else out there using Amazon's servers.
__________________
Marc Washburn
www.EverythingGraphic.com
Five successful X-cart 5.2.x installations
Reply With Quote

The following 2 users thank mgwashburn for this useful post:
cflsystems (08-10-2016), seyfin (08-10-2016)
  #25  
Old 08-09-2016, 11:14 PM
 
kevinrm kevinrm is offline
 

X-Adept
  
Join Date: Aug 2003
Posts: 967
 

Default Re: Double release: 5.3.1 and 5.2.16, XC4 to XC5 Migration Wizard, New Developer Portal

Very glad I did not run this upgrade on my live store!

I created a development copy under /dev, copied the database, everything seems to be working okay. When I try to upgrade core only from 5.2.15 to 5.2.16, I get stuck at step 5:

Deploying store [step 5 of 13], please wait...

Run the "Doctrine_Plugin_UpdateSchema" plugin...
Error
ERROR: "0" (code N/A)

An exception occurred while executing 'ALTER TABLE `xc_profiles` ADD CONSTRAINT FK_564F69D78D9F6D38 FOREIGN KEY (order_id) REFERENCES xc_orders (order_id) ON DELETE CASCADE': SQLSTATE[23000]: Integrity constraint violation: 1452 Cannot add or update a child row: a foreign key constraint fails (`ocha_xcDev`.`#sql-42dd_2fc3`, CONSTRAINT `FK_564F69D78D9F6D38` FOREIGN KEY (`order_id`) REFERENCES `xc_orders` (`order_id`) ON DELETE CASCADE)

Deleting /var/run and .rebuildMark, .rebuildStarted is all to no avail.

Any ideas?
__________________
X-Cart 5.3.6.4 Live
PHP7.2.22
FPM/FastCGI - enabled
Zend OpCache OFF - Won't work with phar extension in cPanel on
10.3.16-MariaDB
Apache 2.4.34
CENTOS 6.8 64Bit Single Quad-Core E3-1241v3 3.4Ghz 8M 1600 w/ HT
32GB RAM 2x 512GB Samsung 850 Pro SSD RAID 1
Reply With Quote
  #26  
Old 08-10-2016, 01:53 AM
  seyfin's Avatar 
seyfin seyfin is offline
 

X-Cart team
  
Join Date: May 2004
Posts: 1,223
 

Default Re: Double release: 5.3.1 and 5.2.16, XC4 to XC5 Migration Wizard, New Developer Portal

Dear Kevin,

The error in question might be caused by some integrity issues with your existing X-Cart database.

Could you please create a development copy once again, from scratch, and submit a new support ticket in your personal Helpdesk area, our support engineers will investigate the case.

Thank you.
__________________
Sincerely yours,
Sergey Fomin
X-Cart team
Chief support group engineer

===

Check this out. Totally revamped X-Cart hosting
http://www.x-cart.com/hosting.html

Follow us:
https://twitter.com/x_cart / https://www.facebook.com/xcart / https://www.instagram.com/xcart
Reply With Quote

The following user thanks seyfin for this useful post:
kevinrm (08-10-2016)
  #27  
Old 08-10-2016, 12:56 PM
  cherie's Avatar 
cherie cherie is online now
 

X-Wizard
  
Join Date: May 2003
Location: USA
Posts: 1,532
 

Default Re: Double release: 5.3.1 and 5.2.16, XC4 to XC5 Migration Wizard, New Developer Portal

Quote:
Call to undefined function XLite\View\FormField\Input\Base\mb_substr()
Quote:
Do you have the php mbstring extension installed? You can check with phpinfo
Sounds like X-Cart is not checking for something it requires.
__________________
redlimeweb.com
custom mods and design integration
4.7 linux
Reply With Quote
  #28  
Old 08-11-2016, 12:25 AM
 
kevinrm kevinrm is offline
 

X-Adept
  
Join Date: Aug 2003
Posts: 967
 

Default Re: Double release: 5.3.1 and 5.2.16, XC4 to XC5 Migration Wizard, New Developer Portal

There were indeed some database issues, Qualteam helped me fix those - thank you.

Development copy was upgraded, the only issue I see now is the top menu for the Simple CMS is fully expanded without any mouse over, I've got a big green box up there with links in it. Hmmm…

NOTE: Re-cached the store, that resolved itself.
__________________
X-Cart 5.3.6.4 Live
PHP7.2.22
FPM/FastCGI - enabled
Zend OpCache OFF - Won't work with phar extension in cPanel on
10.3.16-MariaDB
Apache 2.4.34
CENTOS 6.8 64Bit Single Quad-Core E3-1241v3 3.4Ghz 8M 1600 w/ HT
32GB RAM 2x 512GB Samsung 850 Pro SSD RAID 1
Reply With Quote
  #29  
Old 08-11-2016, 02:31 AM
 
xim xim is offline
 

X-Cart team
  
Join Date: Nov 2004
Posts: 675
 

Default Re: Double release: 5.3.1 and 5.2.16, XC4 to XC5 Migration Wizard, New Developer Portal

Here is the list of the ideas which have been closed with the latest releases. Thank for our customers to share it with us (especially @RichieRich) and developers for releasing 3d party extensions (Carry and Steve)

7502173-unavailable-for-purchase

7871154-newsletter-email-list-for-x5

10371060-categories-selector-helper

10000515-alipay-payment-module-integration

6637530-improve-custom-skin-to-allow-override-template

759866-super-simple-layout-editing-tools-like-drag-and-dr

4860374-product-returns

3286312-amazon-store-feed

4860415-color-swatches-for-product-options

8126661-update-multiple-products

6082261-new-arrivals-and-coming-soon-labels

4860447-paypal-website-payments-pro-hosted-api

11662269-item-count-in-shipping-invoice-packing-slip

10620861-delivery-method-product-specific

11708595-default-alt-text-on-product-images
__________________
Sincerely yours, Max Vydrin
Reply With Quote
  #30  
Old 08-17-2016, 05:07 AM
 
xim xim is offline
 

X-Cart team
  
Join Date: Nov 2004
Posts: 675
 

Default Re: Double release: 5.3.1 and 5.2.16, XC4 to XC5 Migration Wizard, New Developer Portal

cflsystems

http://devs.x-cart.com/en/migration_guides/module_changelogs.html
__________________
Sincerely yours, Max Vydrin
Reply With Quote
Reply
   X-Cart forums > News and Announcements


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -8. The time now is 08:01 AM.

   

 
X-Cart forums © 2001-2018