Follow us on Twitter X-Cart on Facebook Wiki
Shopping cart software Solutions for online shops and malls

Callback to online store is failed
 
Reply
   X-Cart forums > X-Payments > X-Payments issues & questions
 
Thread Tools
  #1  
Old 11-11-2013, 07:38 AM
 
gblair gblair is offline
 

Advanced Member
  
Join Date: Jul 2008
Posts: 69
 

Default Callback to online store is failed

I received this message on 11/10/2013 -

"Callback to online store is failed. This notification has been sent by X-Payments installation at 'www.mysite.com'"

Now all credit card transactions are failing and the credit card fields for secure checkout on my website are missing.

I've had X-Payments installed and working since June 2012. I use PayPal Payments Pro as my payment gateway. I'm wondering why all of a sudden I'm having this issue and what I need to do to correct it.

I am using X-Payments version 1.0.4.

Thank you.
__________________
paperwhimsy.com
Gale Blair
4.1.10
Reply With Quote
  #2  
Old 11-11-2013, 08:40 AM
  ambal's Avatar 
ambal ambal is offline
 

X-Cart team
  
Join Date: Sep 2002
Posts: 4,099
 

Default Re: Callback to online store is failed

Have you changed anything in your X-Cart store (i.e. modifications, upgrades, changed configuration, etc.)? Such sudden changes do not happen without someone doing something somewhere.
__________________
Sincerely yours,
Alex Mulin
VP of business development for X-Cart
X-Payments project manager
Reply With Quote
  #3  
Old 11-11-2013, 08:55 AM
 
gblair gblair is offline
 

Advanced Member
  
Join Date: Jul 2008
Posts: 69
 

Default Re: Callback to online store is failed

Alex, we made some cosmetic changes to our website over the weekend - color scheme. However, no modifications to the cart (unless changing the color from peach to white is a modification).

On 10/31/2013 we changed the usage status on our X-Payments license from "Under construction" to "Live" (not sure why this was never changed). But since that time we've had successful credit card transactions.

A few weeks ago we did a patch to upgrade from PHP 5.2 to PHP 5.3, but we've had successful credit card transactions since then.

Is there an error log where we can identify the specific problem? The email was very generic. We logged into X-Payments but nothing jumped out at us.

Quote:
Originally Posted by ambal
Have you changed anything in your X-Cart store (i.e. modifications, upgrades, changed configuration, etc.)? Such sudden changes do not happen without someone doing something somewhere.
__________________
paperwhimsy.com
Gale Blair
4.1.10
Reply With Quote
  #4  
Old 11-12-2013, 09:32 PM
  ambal's Avatar 
ambal ambal is offline
 

X-Cart team
  
Join Date: Sep 2002
Posts: 4,099
 

Default Re: Callback to online store is failed

Quote:
Originally Posted by gblair
Alex, we made some cosmetic changes to our website over the weekend - color scheme. However, no modifications to the cart (unless changing the color from peach to white is a modification).

On 10/31/2013 we changed the usage status on our X-Payments license from "Under construction" to "Live" (not sure why this was never changed). But since that time we've had successful credit card transactions.

A few weeks ago we did a patch to upgrade from PHP 5.2 to PHP 5.3, but we've had successful credit card transactions since then.


Nothing of the above should cause the trouble. But in order to find out what's wrong investigation on your X-Cart and X-Payments servers is needed.


Quote:
Originally Posted by gblair
Is there an error log where we can identify the specific problem? The email was very generic. We logged into X-Payments but nothing jumped out at us.

Detailed information about errors can be found in the X-Payments and X-Cart logs:
  • X-Payments: See the <xpay-dir>/var/log/ directory
  • X-Cart: See the <xcart-dir>/var/log/x-errors_xpay_connector-YYMMDD.php files
http://help.x-cart.com/index.php?title=X-Payments:FAQ#Where_can_I_find_X-Payments_logs.3F
__________________
Sincerely yours,
Alex Mulin
VP of business development for X-Cart
X-Payments project manager

Last edited by ambal : 11-12-2013 at 11:10 PM.
Reply With Quote
  #5  
Old 11-20-2013, 10:43 AM
 
Lloyds Lloyds is offline
 

Advanced Member
  
Join Date: Apr 2013
Posts: 70
 

Default Re: Callback to online store is failed

Quote:
Originally Posted by gblair
Alex, we made some cosmetic changes to our website over the weekend - color scheme. However, no modifications to the cart (unless changing the color from peach to white is a modification).

On 10/31/2013 we changed the usage status on our X-Payments license from "Under construction" to "Live" (not sure why this was never changed). But since that time we've had successful credit card transactions.

A few weeks ago we did a patch to upgrade from PHP 5.2 to PHP 5.3, but we've had successful credit card transactions since then.

Is there an error log where we can identify the specific problem? The email was very generic. We logged into X-Payments but nothing jumped out at us.

Did you ever find the problem? I am having a similar issue now too. Since Monday, we have had several orders fail on us and customers have had to call to complete the order with us.

The back-end says X-Payments Started - after the third attempt they call us.

I have followed up and they all say the credit card fields are not being loaded.
__________________
4.7.5 - lloydsofindiana.com

5.3.2.7 - Customprintproducts.com

Lloyds of Indiana
Binding Machines, Binding Supplies, Laminators, UV Coating
Reply With Quote
  #6  
Old 11-20-2013, 04:40 PM
 
gblair gblair is offline
 

Advanced Member
  
Join Date: Jul 2008
Posts: 69
 

Default Re: Callback to online store is failed

Actually, the pingback failure wasn't the reason we'd lost our credit card fields though we did receive a pingback failure notification. Since that one failure we haven't had any additional notifications.

What our problem was pertained to our regenerating of encryption codes in X-Payments. We had done that but neglected to update the information in X-Cart, hence the credit card fields were not loading when the customer was attempting to use a credit card for payment.

To remedy this we went into X-Payments, copied the new encryption codes and pasted them into X-Cart in the appropriate fields (Payment Methods → Credit Card → X-Payments connector module settings).

Whether this will remedy your issue I do not know, but because we'd regenerated encryption codes in X-Payments we "broke" (for lack of a better word) the connection between X-Payments and X-Cart.

We've had no apparent credit card payment issues since we updated the X-Payment encryption codes in X-Cart.

We still have no idea what the issue was with the pingback failure and why it happened but at this moment we're running fine.




Quote:
Originally Posted by Lloyds
Did you ever find the problem? I am having a similar issue now too. Since Monday, we have had several orders fail on us and customers have had to call to complete the order with us.

The back-end says X-Payments Started - after the third attempt they call us.

I have followed up and they all say the credit card fields are not being loaded.
__________________
paperwhimsy.com
Gale Blair
4.1.10
Reply With Quote
Reply
   X-Cart forums > X-Payments > X-Payments issues & questions


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -8. The time now is 10:13 AM.

   

 
X-Cart forums © 2001-2018