Follow us on Twitter X-Cart on Facebook Wiki
Shopping cart software Solutions for online shops and malls

PHP 5.4 compatibility for older versions of X-Cart (4.0.19; 4.1.12)
 
Reply
   X-Cart forums > News and Announcements
 
Thread Tools
  #21  
Old 01-03-2014, 08:56 AM
  photo's Avatar 
photo photo is offline
 

X-Wizard
  
Join Date: Feb 2006
Location: UK
Posts: 1,146
 

Default Re: PHP 5.4 compatibility for older versions of X-Cart (4.0.19; 4.1.12)

Quote:
Originally Posted by cflsystems
Thanks for confirming. Is this going to be another not tested patch?

Thanks for bringing this issue up Steve. Please update this thread if/when you find out anything.

Lets hope we get a responce from QT on this asap.

I am looking to upgrade to v4.6.x but with not saving annon customer data not yet resolved as well as a couple of other issues I been dragging my feet.
__________________
v4.1.10
In Dev v4.5.x


"If you don't keep an eye on your business, someone else will."
Reply With Quote
  #22  
Old 01-04-2014, 05:16 AM
 
roband roband is offline
 

Member
  
Join Date: Apr 2005
Posts: 21
 

Default Re: PHP 5.4 compatibility for older versions of X-Cart (4.0.19; 4.1.12)

Wasn't this already addressed by QT in
http://bt.x-cart.com/view.php?id=43030

See the extra patch added there.

Basically you need to add to top.inc.php:
# If register_long_arrays = off (php5)
if (empty($HTTP_SERVER_VARS)) {
$HTTP_SERVER_VARS = (array)$_SERVER;
$HTTP_GET_VARS = (array)$_GET;
$HTTP_POST_VARS = (array)$_POST;
$HTTP_COOKIE_VARS = (array)$_COOKIE;
$HTTP_POST_FILES = (array)$_FILES;
$HTTP_ENV_VARS = (array)$_ENV;
}
__________________
X-Cart Gold v4.5.1
Reply With Quote

The following user thanks roband for this useful post:
cflsystems (01-04-2014)
  #23  
Old 01-04-2014, 09:17 AM
  cflsystems's Avatar 
cflsystems cflsystems is offline
 

Veteran
  
Join Date: Apr 2007
Posts: 13,615
 

Default Re: PHP 5.4 compatibility for older versions of X-Cart (4.0.19; 4.1.12)

Thank you for this link.
This is the problem - first the bugtracker does not work and it is easier to find a fly on elephant's ass than something in the bugtracker; and the link to this very important fix is just posted without any explanation of what it is or for what - I missed it.... FOR THE OTHERs WHICH SEEMS TO MISSED IT AS WELL - POST #11
This is still a major flow of how to handle the situation given the fact that the bug tracker basically does not exist in the shape it is right now and Post#11 could have mentioned something to bring up everyones attanetion to this....
__________________
Steve Stoyanov
CFLSystems.com
Web Development
Reply With Quote
  #24  
Old 01-04-2014, 04:36 PM
  cherie's Avatar 
cherie cherie is offline
 

X-Wizard
  
Join Date: May 2003
Location: USA
Posts: 1,532
 

Default Re: PHP 5.4 compatibility for older versions of X-Cart (4.0.19; 4.1.12)

Is it too much to ask for Bug Tracker to at least be back to what it was before the recent change, some context on the BT links in this thread, and the first post be updated so it reads as a single comprehensive guide?
__________________
redlimeweb.com
custom mods and design integration
4.7 linux
Reply With Quote

The following user thanks cherie for this useful post:
Ksenia (01-08-2014)
  #25  
Old 01-08-2014, 03:18 AM
  Ksenia's Avatar 
Ksenia Ksenia is offline
 

X-Cart team
  
Join Date: Apr 2013
Posts: 735
 

Default Re: PHP 5.4 compatibility for older versions of X-Cart (4.0.19; 4.1.12)

Thank you, the 1st post of the thread is updated to include the info from post #11.
__________________
X-Cart team
Reply With Quote
  #26  
Old 01-23-2014, 07:30 PM
 
markwhoo markwhoo is offline
 

X-Adept
  
Join Date: Nov 2003
Posts: 799
 

Default Re: PHP 5.4 compatibility for older versions of X-Cart (4.1.19; 4.1.12)

I am not sure if anyone has thought of this until it may have been too late, but has anyone taken add on mods into consideration with php 5.4 comparability?

I see everyone has spoken of cart compatibility from as early as inception, but no one has said if they had issues with their mods or add ons.

I have a lot of both, and I wonder if anyone has had issues with any of BCS's, Jon's CDSEO, Altered Cart, Firetank mods or add ons etc?

Would anyone like to chime in and let us know if they upgraded to 5.4.x and lost the use of some mods?

The reason I say this is MySQL is also upgraded when updating php to 5.4.x, and once it is updated you cannot downgrade MySQL so it would be a total loss and big issues.


Have you had issues or total success, or have you not tested add ons or mods post update and just don't know?
__________________
vs 4.1.12
Reply With Quote
  #27  
Old 02-03-2014, 08:51 AM
 
Isleman Isleman is offline
 

Senior Member
  
Join Date: Jan 2005
Location: UK
Posts: 128
 

Default Re: PHP 5.4 compatibility for older versions of X-Cart (4.0.19; 4.1.12)

I have applied the php5.3.x-patch-2010-04-12_4.1.12 to my 4.1.11 X-cart store as I have been prompted by our ISP they will be changing soon to PHP 5.3 .
When looking into summary under php info, the site is still saying that is running PHP 5.2.17.
How can I check that the patch has been applied properly ?
__________________
X-Cart ver. 4.4.2 ( www.responseelectronics.com )
X-Cart ver. 4.1.11 ( www.mrdoorbell.com)
Reply With Quote
  #28  
Old 02-04-2014, 08:25 AM
  cflsystems's Avatar 
cflsystems cflsystems is offline
 

Veteran
  
Join Date: Apr 2007
Posts: 13,615
 

Default Re: PHP 5.4 compatibility for older versions of X-Cart (4.0.19; 4.1.12)

If you have applied the patch (modified the files) then it is applied. The PHP version under Summary is the PHP installed on the server - it has nothing to do with XC. This number will change if/when your host upgrades PHP.
__________________
Steve Stoyanov
CFLSystems.com
Web Development
Reply With Quote

The following 2 users thank cflsystems for this useful post:
aim (02-05-2014), Isleman (02-04-2014)
  #29  
Old 04-25-2014, 02:26 PM
 
smokinghunks smokinghunks is offline
 

Newbie
  
Join Date: Apr 2014
Posts: 2
 

Default Re: PHP 5.4 compatibility for older versions of X-Cart (4.0.19; 4.1.12)

i was able to fix my XCART Version 4.1.10 to perfect work under PHP 5.4 just by going to the check_requirements.php and editing line 162 from 1 to 0 for the option :

if (phpversion() >= "5.0.0") {
$CHECK_REQUIREMENTS["req_vars"][] = array (
"option" =>"register_long_arrays",
"req_val" =>1,
"real_val"=>"",
"critical"=>0);
}

i hope this can help anybody else with the same issue

Junior
__________________
https://waynerogersvideo.com/xcart/VERSION
Reply With Quote

The following 2 users thank smokinghunks for this useful post:
Kit-Tronics (08-04-2014), neonrider (02-19-2017)
  #30  
Old 05-25-2014, 01:06 PM
 
Thomasb134 Thomasb134 is online now
 

X-Adept
  
Join Date: Apr 2007
Location: USA
Posts: 760
 

Default Re: PHP 5.4 compatibility for older versions of X-Cart (4.0.19; 4.1.12)

Quote:
Originally Posted by cflsystems
{Snip}QT - this post is misleading since the patch provided doesn't fix older XC versions for use with PHP 5.4.x and up. Please fix and provide new 5.4.x patch.
This does not affect newer XC releases like 4.5.x and 4.6.x
P.S. If anyone had tested or running older versions of XC on PHP 5.4.x without any issues please share so we can get to the bottom of this....
Some feedback on my V4.4.5 installation to share: My host upgraded all customer accounts from PHP 5.3 to PHP5.4 yesterday. They had given me a heads-up about the upgrade so I was not surprised to see the cart crash after the switch.

The crash was due to a PHP5.3 entry in the php.ini file that conflicted with PHP5.4. The php.ini file was not needed so it was removed and the cart was back online. However, later in the day I found hundreds of those dreaded "Illegal string offset" warnings caused by xcart's modules and third party add-on modules.

I understand that these warnings will not cause the cart to fail. However, I decided that rather than fill the logs with warnings (or force their suppression), I instead reverted back to PHP5.3.

Fortunately my host's control panel allows the users to select the version they want. The default PHP5.3 settings were chosen; All is back to normal now.
__________________
Thomas / USA
XCart V4.4.5 Gold
XCart Mobile V1.4.12
XCart X-PDF
XCart X-HotProducts
AlteredCart Checkout One (One Page Checkout)
BCSE Back In Stock
CFL Holiday Message
CFL System Message
Smack Digital (WebsiteCM) Remember Anon Carts
xcartmods Testimonials
Unix, PHP 7.0 (patched 5.4). Currently patching PHP 7.1
MySQL 5.6
Reply With Quote
Reply
   X-Cart forums > News and Announcements


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -8. The time now is 03:17 AM.

   

 
X-Cart forums © 2001-2018