Follow us on Twitter X-Cart on Facebook Wiki
Shopping cart software Solutions for online shops and malls

Xcart and Xpayments not working together
 
Reply
   X-Cart forums > X-Payments > X-Payments issues & questions
 
Thread Tools
  #1  
Old 10-30-2012, 02:17 AM
  smithlarry's Avatar 
smithlarry smithlarry is offline
 

Advanced Member
  
Join Date: May 2005
Location: Blairs, VA USA
Posts: 31
 

Default Xcart and Xpayments not working together

I'm using USAEpay xcart 4.5.3 xpayments 1.0.5 and am having a big problem. My customers submit an order and are taken to a declined page. Here is the problem:

1. The order is marked failed in xcart.
2. The order is charged to the credit card at USAEpay.
3. I get a payment error email and a transaction approved email for the same order.
4. I had a customer try 5 times and I got the same results on each try.
5. The next customers order went through fine I think.

Here is the errors I'm getting:

In xpayments

ERROR [2012-29-10 15:47:16]
User: unknown; IP:
Zone: VSNode
Code: ENUM_WRONG_VALUE (1532)
Data validation error, node "UMcardLevelResult": Passed value is not allowed. Value - "F", possible values - "('A','B','C','D','G','H','I','K','M','S','U','G1' ,'G2','J1','J2','J3','J4','K1','S1','S2','S3','DI' ,'AX','')" (value: 'F')

Affected systems: VSNode/Base/Node.php file (124:assert); VSNode/Enum.php file (102:assert); VSNode/Base/Array.php file (97:validate); VSNode/ArrayKeyString.php file (53:validate); Transport/ValidationSchema.php file (111:validate); Model/PaymentConf.php file (600:validate); Model/Payment.php file (1700:processPayment); Model/Payment.php file (1645:processInit); Controller/Payment/Main.php file (239:process); Controller/Payment/Main.php file (217:doPay); Core/Controller.php file (181:actionPay); Controller/Payment.php file (277:process); Core/Dispatcher.php file (148:process); Application.php file (156:dispatch); /home/brother2/public_html/xpayments/payment.php file (26:run)

In xcart payment errors:

[29-Oct-2012 15:44:27] (shop: 29-Oct-2012 17:44:26) PAYMENTS message:
Payment processing failure.
Login:
IP:
----
Payment method: Credit Card Using Our Secure Server (X-Payments: USA ePay - Transaction Gateway API)
bill_output = Array
(
[sessid] => e64b7fd3738e84387db1e7055401b3a0
[code] => 2
[billmes] => Aborted due to errors during transaction processing
)
original_bill_output = Array
(
[sessid] => e64b7fd3738e84387db1e7055401b3a0
[code] => 2
[billmes] => Aborted due to errors during transaction processing
)
_GET = Array
(
[target] => main
[token] => 1a889e5e8b45dbac776fa76586c68324
[action] => abort
[refId] => 11204
[txnId] => 3ffd28976804245c1d41a8f31735efef
)
_POST = Array
(
)
Request URI: /payment/cc_xpc.php?target=main&token=1a889e5e8b45dbac776fa 76586c68324&action=abort&refId=11204&txnId=3ffd289 76804245c1d41a8f31735efef
Backtrace:
/home/brother2/public_html/payment/payment_ccmid.php:453
/home/brother2/public_html/payment/payment_ccend.php:48
/home/brother2/public_html/payment/cc_xpc.php:181

I also get the occasional your order was lost error.

in internal errors I get:

[29-Oct-2012 00:34:05] (shop: 29-Oct-2012 02:34:05) INTERNAL message:
Recorded error 80
Request URI: //pages.php?xid=

So far I have been able to take care of my customers but not for long. Please help.
__________________
BrotherSmith
Xcart Version 4.5.4
Xpayments 1.0.5
Adapt Template
ECC intergration
Reply With Quote
  #2  
Old 10-31-2012, 01:38 AM
  smithlarry's Avatar 
smithlarry smithlarry is offline
 

Advanced Member
  
Join Date: May 2005
Location: Blairs, VA USA
Posts: 31
 

Default Re: Xcart and Xpayments not working together

Anyone out there?
__________________
BrotherSmith
Xcart Version 4.5.4
Xpayments 1.0.5
Adapt Template
ECC intergration
Reply With Quote
  #3  
Old 10-31-2012, 09:22 AM
  smithlarry's Avatar 
smithlarry smithlarry is offline
 

Advanced Member
  
Join Date: May 2005
Location: Blairs, VA USA
Posts: 31
 

Default Errors in Xpayments

I'm using USAEpay xcart 4.5.3 xpayments 1.0.5 and am having a big problem. My customers submit an order and are taken to a declined page. Here is the problem:

1. The order is marked failed in xcart.
2. The order is charged to the credit card at USAEpay.
3. I get a payment error email and a transaction approved email for the same order.
4. I had a customer try 5 times and I got the same results on each try.
5. The next customers order went through fine I think.

Here is the errors I'm getting:

In xpayments

ERROR [2012-29-10 15:47:16]
User: unknown; IP:
Zone: VSNode
Code: ENUM_WRONG_VALUE (1532)
Data validation error, node "UMcardLevelResult": Passed value is not allowed. Value - "F", possible values - "('A','B','C','D','G','H','I','K','M','S','U','G1' ,'G2','J1','J2','J3','J4','K1','S1','S2','S3','DI' ,'AX','')" (value: 'F')

Affected systems: VSNode/Base/Node.php file (124:assert); VSNode/Enum.php file (102:assert); VSNode/Base/Array.php file (97:validate); VSNode/ArrayKeyString.php file (53:validate); Transport/ValidationSchema.php file (111:validate); Model/PaymentConf.php file (600:validate); Model/Payment.php file (1700:processPayment); Model/Payment.php file (1645:processInit); Controller/Payment/Main.php file (239:process); Controller/Payment/Main.php file (217:doPay); Core/Controller.php file (181:actionPay); Controller/Payment.php file (277:process); Core/Dispatcher.php file (148:process); Application.php file (156:dispatch); /home/brother2/public_html/xpayments/payment.php file (26:run)

In xcart payment errors:

[29-Oct-2012 15:44:27] (shop: 29-Oct-2012 17:44:26) PAYMENTS message:
Payment processing failure.
Login:
IP:
----
Payment method: Credit Card Using Our Secure Server (X-Payments: USA ePay - Transaction Gateway API)
bill_output = Array
(
[sessid] => e64b7fd3738e84387db1e7055401b3a0
[code] => 2
[billmes] => Aborted due to errors during transaction processing
)
original_bill_output = Array
(
[sessid] => e64b7fd3738e84387db1e7055401b3a0
[code] => 2
[billmes] => Aborted due to errors during transaction processing
)
_GET = Array
(
[target] => main
[token] => 1a889e5e8b45dbac776fa76586c68324
[action] => abort
[refId] => 11204
[txnId] => 3ffd28976804245c1d41a8f31735efef
)
_POST = Array
(
)
Request URI: /payment/cc_xpc.php?target=main&token=1a889e5e8b45dbac776fa 76586c68324&action=abort&refId=11204&txnId=3ffd289 76804245c1d41a8f31735efef
Backtrace:
/home/brother2/public_html/payment/payment_ccmid.php:453
/home/brother2/public_html/payment/payment_ccend.php:48
/home/brother2/public_html/payment/cc_xpc.php:181

I also get the occasional your order was lost error.

in internal errors I get:

[29-Oct-2012 00:34:05] (shop: 29-Oct-2012 02:34:05) INTERNAL message:
Recorded error 80
Request URI: //pages.php?xid=

So far I have been able to take care of my customers but not for long. Please help.
__________________
BrotherSmith
Xcart Version 4.5.4
Xpayments 1.0.5
Adapt Template
ECC intergration
Reply With Quote
  #4  
Old 10-31-2012, 10:29 PM
  enterfusion's Avatar 
enterfusion enterfusion is offline
 

Advanced Member
  
Join Date: Mar 2004
Location: Pittsburg, CA
Posts: 65
 

Default Re: Xcart and Xpayments not working together

I recommend putting in a trouble ticket. Both systems should work seamlessly together, so perhaps its something with that particular payment processor. Either way Qualiteam should have an answer.
__________________
-Eric

X-cart 4.3.2 up and running.
Apache, PHP 5.2, APC, Redhat, Checkout One, On Sale, Smart Search, Remember Cart.
Lots of other customization's, but perhaps typical of x-cart installations.

X-cart 5 sort of in limbo, trying to make things work without much luck.
Reply With Quote
  #5  
Old 11-01-2012, 01:36 AM
  smithlarry's Avatar 
smithlarry smithlarry is offline
 

Advanced Member
  
Join Date: May 2005
Location: Blairs, VA USA
Posts: 31
 

Default Re: Xcart and Xpayments not working together

Thanks, I tried that and they sent me here.
__________________
BrotherSmith
Xcart Version 4.5.4
Xpayments 1.0.5
Adapt Template
ECC intergration
Reply With Quote
  #6  
Old 11-03-2012, 02:05 AM
  smithlarry's Avatar 
smithlarry smithlarry is offline
 

Advanced Member
  
Join Date: May 2005
Location: Blairs, VA USA
Posts: 31
 

Default Re: Xcart and Xpayments not working together

Someone at QT needs to address this. Xpayments is not working right and I'm loosing orders.
__________________
BrotherSmith
Xcart Version 4.5.4
Xpayments 1.0.5
Adapt Template
ECC intergration
Reply With Quote
  #7  
Old 11-06-2012, 11:24 PM
  rocky's Avatar 
rocky rocky is offline
 

X-Cart team
  
Join Date: Jul 2005
Posts: 715
 

Default Re: Xcart and Xpayments not working together

Quote:
Originally Posted by smithlarry
Someone at QT needs to address this. Xpayments is not working right and I'm loosing orders.


Please refer to your HelpDesk account message board for solution.
__________________
Alexander Diatchkov
Head of Technical Support Department

Official X-Cart Support at:
http://www.x-cart.com/technical-support.html
Reply With Quote
  #8  
Old 11-07-2012, 01:54 AM
  smithlarry's Avatar 
smithlarry smithlarry is offline
 

Advanced Member
  
Join Date: May 2005
Location: Blairs, VA USA
Posts: 31
 

Default Re: Xcart and Xpayments not working together

Here is the fix if anyone else has this problem:

1. Find "lib/XPay/Module/USAePay.php" on your server

2. Open it for editing

3. Find the following part of code (line 227 approximately):



private $cardLevelResults = array(
'A' => 'Visa Traditional',
'B' => 'Visa Traditional Rewards',
'C' => 'Visa Signature',


and replace it with:



private $cardLevelResults = array(
'F' => 'Other card',
'A' => 'Visa Traditional',
'B' => 'Visa Traditional Rewards',
'C' => 'Visa Signature',


4. Save the changes.

Thank you
__________________
BrotherSmith
Xcart Version 4.5.4
Xpayments 1.0.5
Adapt Template
ECC intergration
Reply With Quote

The following user thanks smithlarry for this useful post:
ambal (11-08-2012)
Reply
   X-Cart forums > X-Payments > X-Payments issues & questions


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -8. The time now is 12:53 PM.

   

 
X-Cart forums © 2001-2018