Follow us on Twitter X-Cart on Facebook Wiki
Shopping cart software Solutions for online shops and malls

POODLE vulnerability in SSLv3
 
Reply
   X-Cart forums > X-Payments > X-Payments issues & questions
 
Thread Tools
  #131  
Old 03-12-2015, 05:40 AM
 
rct rct is offline
 

Advanced Member
  
Join Date: Dec 2004
Posts: 89
 

Default Re: POODLE vulnerability in SSLv3

Quote:
Originally Posted by totaltec
Me too, had several client sited whose UPS shipping went down.

I used the following way to solve the UPS problem.
http://forum.x-cart.com/showpost.php?p=379525&postcount=98
Hope it helps
__________________
JOHN - v.5.3.X biz, X-payment 3.X
Reply With Quote

The following user thanks rct for this useful post:
totaltec (03-12-2015)
  #132  
Old 03-12-2015, 05:53 AM
  totaltec's Avatar 
totaltec totaltec is offline
 

X-Guru
  
Join Date: Jan 2007
Location: Louisville, KY USA
Posts: 5,825
 

Default Re: POODLE vulnerability in SSLv3

Quote:
Originally Posted by rct
I used the following way to solve the UPS problem.
http://forum.x-cart.com/showpost.php?p=379525&postcount=98
Hope it helps
Thanks, we already fixed them of course. Just SSL/TLS problems that are solved by the patch.
__________________
Mike White - Now Accepting new clients and projects! Work with the best, get a US based development team for just $125 an hour. Call 1-502-773-6454, email mike at babymonkeystudios.com, or skype b8bym0nkey

XcartGuru
X-cart Tutorials | X-cart 5 Tutorials

Check out the responsive template for X-cart.
Reply With Quote
  #133  
Old 03-12-2015, 06:05 AM
  BCSE's Avatar 
BCSE BCSE is offline
 

X-Man
  
Join Date: Apr 2003
Location: Ohio - bcsengineering.com
Posts: 2,875
 

Default Re: POODLE vulnerability in SSLv3

Yes we've fixed several clients as well here.

Carrie
__________________
Custom Development, Custom Coding and Pre-built modules for X-cart since 2002!

We support X-cart versions 3.x through 5.x!

Home of the famous Authorize.net DPM & CIM Modules, Reward Points Module, Point of Sale module, Speed Booster modules and more!


Over 200 X-cart Mods available & Thousands of Customizations Since 2002 - bcsengineering.com

Please E-Mail us for questions/support!
Reply With Quote
  #134  
Old 03-12-2015, 07:59 AM
  qualiteam's Avatar 
qualiteam qualiteam is offline
 

X-Guru
  
Join Date: Dec 2010
Posts: 6,373
 

Default Re: POODLE vulnerability in SSLv3

Hello!

The X-Cart 4 dev team has investigated the issue and the problem may be in the "unofficial" patches which were made available for downloading 6 years ago in this forum thread:
http://forum.x-cart.com/showthread.php?t=47262

The patches will likely break the UPS integration (and, perhaps, some custom payment integrations) in the following X-Cart versions: 3.5.x, 4.0.x, 4.1.x and 4.2.0-4.2.1.

So, if you have these patches installed in your store, you may have to revert them to get this issue fixed.
__________________
Alex Solovev,
Qualiteam

---

User manual Video tutorials X-Cart FAQ

You are welcome to press "Thanks" button
if you find this post useful

Click here to learn how to apply patches

X-Cart Extensions
Reply With Quote
  #135  
Old 03-12-2015, 10:03 AM
  cherie's Avatar 
cherie cherie is offline
 

X-Wizard
  
Join Date: May 2003
Location: USA
Posts: 1,530
 

Default Re: POODLE vulnerability in SSLv3

I think the better solution would have been to consider those X-Cart-provided patches official.
__________________
redli.me | xcarthelp.com
custom mods and design integration
4.7 linux
Reply With Quote
Reply
   X-Cart forums > X-Payments > X-Payments issues & questions


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -8. The time now is 01:20 AM.

   

 
X-Cart forums © 2001-2018