Follow us on Twitter X-Cart on Facebook Wiki
Shopping cart software Solutions for online shops and malls

Upgrade to 5.2 fails

 
Reply
   X-Cart forums > X-Cart 5 > Dev Questions (X-Cart 5)
 
Thread Tools Search this Thread
  #51  
Old 04-09-2015, 01:03 AM
 
Kirill Kirill is offline
Advanced Staff Users
 

X-Cart team
  
Join Date: Nov 2013
Posts: 105
 

Default Re: Upgrade to 5.2 fails

Sorry to hear that.

However looks like some misunderstanding has occurred - we do not have "priority" or "non-priority" customers

Our support service with the guaranteed response time of one business day is provided on commercial basis.

However since you do not have an active support subscription or have not purchased a support incident, your request has been assigned to our free generic support team that does not have a guaranteed response time.
This is a separate team of engineers, however the amount of requests may sometimes cause such delays.
That is what my colleagues were trying to inform you about.

Quote:
Originally Posted by cerberuscoins
Hi Kirill

I havent tried any of those but have tried another US based service thats highly recommended by people on this forum. My site spent significant amounts of time down.

I hope the installation service is better than the support desk who advised me that because Im not a priority customer they can address a support ticket whenever they have time to do it - which was 8 days after lodgement.
__________________
X-Cart team
Reply With Quote
  #52  
Old 04-09-2015, 01:08 AM
 
cerberuscoins cerberuscoins is offline
 

eXpert
  
Join Date: Dec 2009
Posts: 279
 

Default Re: Upgrade to 5.2 fails

Ive submitted a support ticket.
__________________
X-Cart 5.2.4
Reply With Quote
  #53  
Old 04-10-2015, 04:03 AM
 
cerberuscoins cerberuscoins is offline
 

eXpert
  
Join Date: Dec 2009
Posts: 279
 

Default Re: Upgrade to 5.2 fails

The tech support person said:

Most likely this won't work since your database may contain records which are absent in a stock X-Cart version. At least I can't guarantee that this solution will work. Thus, I'd recommend you to restore your site from a backup and try to upgrade it once again.
__________________
X-Cart 5.2.4
Reply With Quote
  #54  
Old 04-14-2015, 05:17 AM
  tony_sologubov's Avatar 
tony_sologubov tony_sologubov is offline
 

X-Cart team
  
Join Date: Jan 2009
Posts: 2,431
 

Default Re: Upgrade to 5.2 fails

Hello @cerberuscoins,

As I see, our support team is already working around this problem, so they will set everything up for you.
__________________
Found a bug in X-Cart? Post it to our bug tracker!
Know how to make X-Cart better? Suggest an idea!
Reply With Quote
  #55  
Old 04-15-2015, 12:27 AM
 
cerberuscoins cerberuscoins is offline
 

eXpert
  
Join Date: Dec 2009
Posts: 279
 

Default Re: Upgrade to 5.2 fails

Hi Tony

They installed cart 4.1.11. I uploaded the SQL file and it logged me out. I cant log back in with the new or old password. I cant reset the password as I get a garbled email which doesnt give me a link to click.

My storefront doesnt work.

I have no access to my administration.

I have no store.
__________________
X-Cart 5.2.4
Reply With Quote
  #56  
Old 04-15-2015, 12:27 AM
 
cerberuscoins cerberuscoins is offline
 

eXpert
  
Join Date: Dec 2009
Posts: 279
 

Default Re: Upgrade to 5.2 fails

Apparently this issue is caused by the fact that you uploaded sql base to the new store.

I'm sorry but I cannot provide you with the solution for this issue in bounds of install service. A thorough investigation should be made.

I would like to suggest you the following options:

1) Upgrade service. Let me know if you are interested and I'll forward your request to our Quote manager for the price estimation.
2) X-Cart hosting solution. If you decide to switch to our hosting we will try to restore and upgrade your store free of charge

Please let me know if you have any questions.
__________________
X-Cart 5.2.4
Reply With Quote
  #57  
Old 04-15-2015, 04:22 AM
  tony_sologubov's Avatar 
tony_sologubov tony_sologubov is offline
 

X-Cart team
  
Join Date: Jan 2009
Posts: 2,431
 

Default Re: Upgrade to 5.2 fails

Hello @cerberuscoins, I have passed your comments to our support team and I am in conversation with them right now. We will get back to you as soon as possible.

Tony
__________________
Found a bug in X-Cart? Post it to our bug tracker!
Know how to make X-Cart better? Suggest an idea!
Reply With Quote
  #58  
Old 04-20-2015, 07:53 PM
 
cerberuscoins cerberuscoins is offline
 

eXpert
  
Join Date: Dec 2009
Posts: 279
 

Default Re: Upgrade to 5.2 fails

Hi Tony

Sergey has been working with me and doing a great job.

My live website has been unlocked. After installing 5.1.11 and applying the SQL file my site died in a great heap. Sergey got it working again so that at least I can advise my customers not to make any orders.

We are now going to work on my test environment store where the upgrade failed due to an issue with my webhost. Once thats been fixed we will take the store live.
__________________
X-Cart 5.2.4
Reply With Quote

The following user thanks cerberuscoins for this useful post:
Ksenia (04-22-2015)
  #59  
Old 05-05-2015, 05:52 AM
 
rviersel rviersel is offline
 

Newbie
  
Join Date: Apr 2015
Posts: 4
 

Default Re: Upgrade to 5.2 fails

Hi Tony,

Hereby the log file when upgrading from v5.1.11 to v5.2 on the DEV environment which breaks the cleanURLs functionality which renders the website/store useless for customers.

php_errors_log:
Quote:
<?php die(1); ?>
[05-May-2015 16:47:32] Error (code: 0): An exception occurred while executing 'INSERT INTO xc_config_translations (option_name, option_comment, code, id) VALUES (?, ?, ?, ?)' with params [null, "Changing the value of this or any other fields on this page will not affect the signature in your store's email notifications. The signature for notifications can be edited on the <a href=\"admin.php?target=notification_common\">Head ers & signatures<\/a> page.", "nl", 18]:

SQLSTATE[23000]: Integrity constraint violation: 1048 Column 'option_name' cannot be null
Server API: apache2handler;
Request method: GET;
URI: /admin.php?target=upgrade;
Backtrace:
#0 /Applications/MAMP/htdocs/xcart/lib/Doctrine/DBAL/DBALException.php(116): Doctrine\DBAL\Driver\AbstractMySQLDriver->convertException('An exception oc...', Object(Doctrine\DBAL\Driver\PDOException))
#1 /Applications/MAMP/htdocs/xcart/lib/Doctrine/DBAL/Statement.php(172): Doctrine\DBAL\DBALException::driverExceptionDuring Query(Object(XLite\Core\PDOMySqlDriver), Object(Doctrine\DBAL\Driver\PDOException), 'INSERT INTO xc_...', Array)
#2 /Applications/MAMP/htdocs/xcart/var/run/classes/XLite/Core/Statement.php(49): Doctrine\DBAL\Statement->execute(NULL)
#3 /Applications/MAMP/htdocs/xcart/lib/Doctrine/ORM/Persisters/BasicEntityPersister.php(279): XLite\Core\Statement->execute()
#4 /Applications/MAMP/htdocs/xcart/lib/Doctrine/ORM/UnitOfWork.php(966): Doctrine\ORM\Persisters\BasicEntityPersister->executeInserts()
#5 /Applications/MAMP/htdocs/xcart/lib/Doctrine/ORM/UnitOfWork.php(335): Doctrine\ORM\UnitOfWork->executeInserts(Object(Doctrine\ORM\Mapping\ClassM etadata))
#6 /Applications/MAMP/htdocs/xcart/lib/Doctrine/ORM/EntityManager.php(389): Doctrine\ORM\UnitOfWork->commit(NULL)
#7 /Applications/MAMP/htdocs/xcart/upgrade/5.2/0/post_rebuild.php(57): Doctrine\ORM\EntityManager->flush()
#8 /Applications/MAMP/htdocs/xcart/var/run/classes/XLite/Upgrade/Entry/AEntry.php(981): XLite\Upgrade\Entry\AEntry->{closure}()
#9 /Applications/MAMP/htdocs/xcart/var/run/classes/XLite/Upgrade/Cell.php(993): XLite\Upgrade\Entry\AEntry->runHelpers('post_rebuild')
#10 /Applications/MAMP/htdocs/xcart/var/run/classes/XLite/Controller/Admin/Upgrade.php(105): XLite\Upgrade\Cell->runHelpers('post_rebuild')
#11 /Applications/MAMP/htdocs/xcart/var/run/classes/XLite/Controller/AControllerAbstract.php(504): XLite\Controller\Admin\Upgrade->run()
#12 /Applications/MAMP/htdocs/xcart/var/run/classes/XLite/Module/QSL/CloudSearch/Controller/AController.php(49): XLite\Controller\AControllerAbstract->handleRequest()
#13 /Applications/MAMP/htdocs/xcart/var/run/classes/XLite/Controller/Admin/AAdmin.php(140): XLite\Module\QSL\CloudSearch\Controller\AControlle r->handleRequest()
#14 /Applications/MAMP/htdocs/xcart/var/run/classes/XLite.php(490): XLite\Controller\Admin\AAdmin->handleRequest()
#15 /Applications/MAMP/htdocs/xcart/var/run/classes/XLite.php(515): XLite->runController()
#16 /Applications/MAMP/htdocs/xcart/admin.php(39): XLite->processRequest()
#17 {main}

[05-May-2015 16:47:32 Europe/Berlin] PHP Fatal error: Uncaught exception 'Doctrine\ORM\ORMException' with message 'The EntityManager is closed.' in /Applications/MAMP/htdocs/xcart/lib/Doctrine/ORM/ORMException.php:129
Stack trace:
#0 /Applications/MAMP/htdocs/xcart/lib/Doctrine/ORM/EntityManager.php(806): Doctrine\ORM\ORMException::entityManagerClosed()
#1 /Applications/MAMP/htdocs/xcart/lib/Doctrine/ORM/EntityManager.php(387): Doctrine\ORM\EntityManager->errorIfClosed()
#2 /Applications/MAMP/htdocs/xcart/var/run/classes/XLite/Core/TmpVars.php(6: Doctrine\ORM\EntityManager->flush(Object(XLite\Model\TmpVar))
#3 /Applications/MAMP/htdocs/xcart/var/run/classes/XLite/Upgrade/Cell.php(504): XLite\Core\TmpVars->__set('upgradeCell', Array)
#4 [internal function]: XLite\Upgrade\Cell->__destruct()
#5 {main}
thrown in /Applications/MAMP/htdocs/xcart/lib/Doctrine/ORM/ORMException.php on line 129


xlite_log

Quote:
<?php die(1); ?>
May 05 16:48:03 XLite [warning] Warning: strstr(): Empty needle in /Applications/MAMP/htdocs/xcart/var/run/classes/XLite/Core/Converter.php on line 494
Server API: apache2handler;
Request method: GET;
URI: /;

May 05 16:48:03 XLite [warning] Warning: strstr(): Empty needle in /Applications/MAMP/htdocs/xcart/var/run/classes/XLite/Core/Converter.php on line 494
Server API: apache2handler;
Request method: GET;
URI: /;

May 05 16:48:03 XLite [warning] Warning: strstr(): Empty needle in /Applications/MAMP/htdocs/xcart/var/run/classes/XLite/Core/Converter.php on line 494
Server API: apache2handler;
Request method: GET;
URI: /;

May 05 16:48:03 XLite [warning] Warning: strstr(): Empty needle in /Applications/MAMP/htdocs/xcart/var/run/classes/XLite/Core/Converter.php on line 494
Server API: apache2handler;
Request method: GET;
URI: /;

May 05 16:48:03 XLite [warning] Warning: strstr(): Empty needle in /Applications/MAMP/htdocs/xcart/var/run/classes/XLite/Core/Converter.php on line 494
Server API: apache2handler;
Request method: GET;
URI: /;

May 05 16:48:05 XLite [warning] Warning: strstr(): Empty needle in /Applications/MAMP/htdocs/xcart/var/run/classes/XLite/Core/Converter.php on line 494
Server API: apache2handler;
Request method: GET;
URI: /;

__________________
Remko
Reply With Quote
  #60  
Old 05-06-2015, 02:25 AM
  tony_sologubov's Avatar 
tony_sologubov tony_sologubov is offline
 

X-Cart team
  
Join Date: Jan 2009
Posts: 2,431
 

Default Re: Upgrade to 5.2 fails

Hello @rviersel,

Could you please send us an email to sales@x-cart.com with reference to this ticket and saying that it is for Tony Sologubov? If possible, I would like to check the problem directly on your server.

Tony
__________________
Found a bug in X-Cart? Post it to our bug tracker!
Know how to make X-Cart better? Suggest an idea!
Reply With Quote
Reply
   X-Cart forums > X-Cart 5 > Dev Questions (X-Cart 5)


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -8. The time now is 07:43 PM.

   

 
X-Cart forums © 2001-2020