Follow us on Twitter X-Cart on Facebook Wiki
Shopping cart software Solutions for online shops and malls

PHP Support & Security - List Of Expiry Dates
 
Reply
   X-Cart forums > General > General talk
 
Thread Tools
  #1  
Old 09-06-2018, 07:33 PM
 
Triple A Racing Triple A Racing is offline
 

X-Adept
  
Join Date: Jul 2008
Location: Manchester UK
Posts: 658
 

Default PHP Support & Security - List Of Expiry Dates

Fortunately, XC have always been pretty robust in ensuring that XC5 runs on the latest releases of PHP via their own upgrade programme. The same approach to PHP releases is not always the case with upgrade programmes from hosting companies though...

The list of PHP support & security expiry dates is shown clearly on here: https://secure.php.net/supported-versions.php

Some hosting companies (but not many) provide their own in-house PHP support which includes recent EOL releases, so there's no problem there. Others don't offer any PHP support and are also, pretty slow to add additional PHP releases. If you have no choice, but to use PHP releases at anything less than PHP 7.1 (which itself, only has Security support in 2019...) it might be worth pushing your hosting company for these choices to be upgraded. If you run your own server, then you have complete control of this anyway.
__________________
Business XC 5.3.5.5 Live & Dev Stores For Testing
Ubuntu 18.04.1 / Nginx 1.14.0 / Plesk 17.8.11
Apache 2.4.29 / MariaDB 10.2.17 / PHP 7.2.10
Reply With Quote

The following 2 users thank Triple A Racing for this useful post:
PhilJ (09-06-2018), qualiteam (09-09-2018)
  #2  
Old 09-09-2018, 09:20 AM
  qualiteam's Avatar 
qualiteam qualiteam is offline
 

X-Guru
  
Join Date: Dec 2010
Posts: 6,158
 

Default Re: PHP Support & Security - List Of Expiry Dates

I have to add that not only running the store on the latest PHP version is a matter of security, but also it improves performance significantly.
The difference in first byte times between PHP 5.5.9 and 7.2.9 is almost 3x (tested on X-Cart 5.3.5).
Everyone should be upgrading PHP to the latest supported version.
Maximum PHP version supported list is below.
X-Cart 5.0.0 - X-Cart 5.2.23 - PHP 5.6
X-Cart 5.3.0.0 - X-Cart 5.3.2.12 - PHP 7.0
X-Cart 5.3.3.0 - X-Cart 5.3.4.4 - PHP 7.1
X-Cart 5.3.4.5 and higher - PHP 7.2
__________________
Alex Solovev,
Qualiteam

---

User manual Video tutorials X-Cart FAQ

You are welcome to press "Thanks" button
if you find this post useful

Click here to learn how to apply patches

X-Cart Extensions
Reply With Quote
  #3  
Old 09-09-2018, 01:18 PM
  cflsystems's Avatar 
cflsystems cflsystems is offline
 

Veteran
  
Join Date: Apr 2007
Posts: 13,259
 

Default Re: PHP Support & Security - List Of Expiry Dates

Let's not forget though - and this is my own believe which may or may not be true - XC4 carts are still way more than XC5 ones. And most of them are older version. Even if they are patched for PHP 7 it is for PHP 7.0 with 3rd party encrypted modules which makes it either difficult or impossible to use latest stable PHP.
With most of the XC4 users not even wanting to hear about an upgrade to XC5 due for number of reasons.
__________________
Steve Stoyanov
CFLSystems.com
Web Development
Reply With Quote

The following user thanks cflsystems for this useful post:
PhilJ (09-11-2018)
  #4  
Old 09-10-2018, 08:17 AM
 
kevinrm kevinrm is offline
 

X-Adept
  
Join Date: Aug 2003
Posts: 915
 

Default Re: PHP Support & Security - List Of Expiry Dates

I cannot get my cart to run properly on anything above php 7.0, always same phar problem, categories don't show in mobile mode, etc. I've tried everything to make it work but it just doesn't, I basically gave up on that.
__________________
X-Cart 5.3.5.5 Live
PHP7.2.9
FPM/FastCGI - enabled
Zend OpCache OFF - Won't work with phar extension in cPanel on PHP7.1+
10.1.36-MariaDB
Apache 2.4.34
CENTOS 6.8 64Bit Single Quad-Core E3-1241v3 3.4Ghz 8M 1600 w/ HT
32GB RAM 2x 512GB Samsung 850 Pro SSD RAID 1
Reply With Quote
  #5  
Old 09-13-2018, 12:09 PM
  qualiteam's Avatar 
qualiteam qualiteam is offline
 

X-Guru
  
Join Date: Dec 2010
Posts: 6,158
 

Default Re: PHP Support & Security - List Of Expiry Dates

Quote:
Originally Posted by kevinrm
I cannot get my cart to run properly on anything above php 7.0, always same phar problem, categories don't show in mobile mode, etc. I've tried everything to make it work but it just doesn't, I basically gave up on that.


What kind of server control panel do you have? Is it cPanel?
I saw something similar on a cPanel server, the problem was with fpm, opcache and some other PHP extensions not being able to work together. We considered it a cPanel issue, but the issue does not occur on pure nginx + php-fpm.
__________________
Alex Solovev,
Qualiteam

---

User manual Video tutorials X-Cart FAQ

You are welcome to press "Thanks" button
if you find this post useful

Click here to learn how to apply patches

X-Cart Extensions
Reply With Quote
  #6  
Old 09-13-2018, 06:45 PM
 
Triple A Racing Triple A Racing is offline
 

X-Adept
  
Join Date: Jul 2008
Location: Manchester UK
Posts: 658
 

Default Re: PHP Support & Security - List Of Expiry Dates

There's a separate thread on the phar issue mentioned here... THIS is the latest post
__________________
Business XC 5.3.5.5 Live & Dev Stores For Testing
Ubuntu 18.04.1 / Nginx 1.14.0 / Plesk 17.8.11
Apache 2.4.29 / MariaDB 10.2.17 / PHP 7.2.10
Reply With Quote
  #7  
Old 09-15-2018, 07:18 PM
 
kevinrm kevinrm is offline
 

X-Adept
  
Join Date: Aug 2003
Posts: 915
 

Default Re: PHP Support & Security - List Of Expiry Dates

Quote:
Originally Posted by qualiteam
What kind of server control panel do you have? Is it cPanel?
I saw something similar on a cPanel server, the problem was with fpm, opcache and some other PHP extensions not being able to work together. We considered it a cPanel issue, but the issue does not occur on pure nginx + php-fpm.

Hello,

Yes, I have cPanel. with anything over php 7.0 it loads a blank page with the word "categories" up at the top, and only on mobile devices. I thought I had it working it php 7.2.9 but no...
__________________
X-Cart 5.3.5.5 Live
PHP7.2.9
FPM/FastCGI - enabled
Zend OpCache OFF - Won't work with phar extension in cPanel on PHP7.1+
10.1.36-MariaDB
Apache 2.4.34
CENTOS 6.8 64Bit Single Quad-Core E3-1241v3 3.4Ghz 8M 1600 w/ HT
32GB RAM 2x 512GB Samsung 850 Pro SSD RAID 1
Reply With Quote
  #8  
Old 09-15-2018, 08:45 PM
 
kevinrm kevinrm is offline
 

X-Adept
  
Join Date: Aug 2003
Posts: 915
 

Default Re: PHP Support & Security - List Of Expiry Dates

Quote:
Originally Posted by qualiteam
What kind of server control panel do you have? Is it cPanel?
I saw something similar on a cPanel server, the problem was with fpm, opcache and some other PHP extensions not being able to work together. We considered it a cPanel issue, but the issue does not occur on pure nginx + php-fpm.

So this cart will not work on cPanel with anything over php 7.0?
__________________
X-Cart 5.3.5.5 Live
PHP7.2.9
FPM/FastCGI - enabled
Zend OpCache OFF - Won't work with phar extension in cPanel on PHP7.1+
10.1.36-MariaDB
Apache 2.4.34
CENTOS 6.8 64Bit Single Quad-Core E3-1241v3 3.4Ghz 8M 1600 w/ HT
32GB RAM 2x 512GB Samsung 850 Pro SSD RAID 1
Reply With Quote
  #9  
Old 09-15-2018, 09:42 PM
 
kevinrm kevinrm is offline
 

X-Adept
  
Join Date: Aug 2003
Posts: 915
 

Default Re: PHP Support & Security - List Of Expiry Dates

I turned OpCache in PHP 7.2.9 to OFF, now it seems to load. Perhaps there is indeed some conflicts going on there. I might contact cPanel support on this...
__________________
X-Cart 5.3.5.5 Live
PHP7.2.9
FPM/FastCGI - enabled
Zend OpCache OFF - Won't work with phar extension in cPanel on PHP7.1+
10.1.36-MariaDB
Apache 2.4.34
CENTOS 6.8 64Bit Single Quad-Core E3-1241v3 3.4Ghz 8M 1600 w/ HT
32GB RAM 2x 512GB Samsung 850 Pro SSD RAID 1
Reply With Quote
Reply
   X-Cart forums > General > General talk


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -8. The time now is 10:43 PM.

   

 
X-Cart forums © 2001-2018