Follow us on Twitter X-Cart on Facebook Wiki
Shopping cart software Solutions for online shops and malls

X-Cart 5.2.3: upgrade issue fix for the users running MySQL v.5.6

 
Reply
   X-Cart forums > News and Announcements
 
Thread Tools
  #1  
Old 03-27-2015, 07:10 AM
  Ksenia's Avatar 
Ksenia Ksenia is offline
 

X-Cart team
  
Join Date: Apr 2013
Posts: 735
 

Default X-Cart 5.2.3: upgrade issue fix for the users running MySQL v.5.6

I didn't think we'll announce the new version today, but we had to release it to provide a hotfix for those who run X-Cart based stores in the servers with MySQLv.5.6:
http://blog.x-cart.com/5-2-3-upgrade-issue-fix-for-the-users-running-MySQL-5-6.html
__________________
X-Cart team

Last edited by Ksenia : 03-27-2015 at 07:38 AM.
Reply With Quote

The following user thanks Ksenia for this useful post:
RichieRich (03-27-2015)
  #2  
Old 03-27-2015, 10:37 AM
  zychen's Avatar 
zychen zychen is offline
 

Advanced Member
  
Join Date: Jul 2007
Posts: 48
 

Default Re: X-Cart 5.2.3: upgrade issue fix for the users running MySQL v.5.6

Does the Webmaster Kit work for anyone else?
My Webmaster Kit doesn't mark the templates anymore.
__________________
X-Cart 5.1.10
X-Cart Next 5.2.1 Beta
Reply With Quote
  #3  
Old 03-27-2015, 10:44 AM
  zychen's Avatar 
zychen zychen is offline
 

Advanced Member
  
Join Date: Jul 2007
Posts: 48
 

Default Re: X-Cart 5.2.3: upgrade issue fix for the users running MySQL v.5.6

Ok, I fixed the issue.
You will have to disable then re-enable Webmaster Mode through "Look & Feel" then it would work.
__________________
X-Cart 5.1.10
X-Cart Next 5.2.1 Beta
Reply With Quote
  #4  
Old 03-27-2015, 01:50 PM
  RichieRich's Avatar 
RichieRich RichieRich is offline
 

X-Adept
  
Join Date: Sep 2004
Location: London, England
Posts: 750
 

Default Re: X-Cart 5.2.3: upgrade issue fix for the users running MySQL v.5.6

I have tried twice the instructions, but the page stops at step 5 still.

Quote:
Deploying store [step 5 of 12], please wait...

Run the "Doctrine_Plugin_UpdateSchema" plugin...
Error
Sorry, there seems to be a problem with the site. Please, try again later.

I uploaded new database file over the previous. Remove the file and folder mentioned. Go to admin URL, cache-rebuild stops at step 5.
__________________
Richard


Ultimate 5.4 testing
Reply With Quote
  #5  
Old 03-29-2015, 07:17 PM
 
fixh fixh is offline
 

Advanced Member
  
Join Date: Jun 2006
Posts: 71
 

Default Re: X-Cart 5.2.3: upgrade issue fix for the users running MySQL v.5.6

Hello,

I'm trying to Upgrade my X-Cart 5.1.11 to the current 5.2.3 and it gets stuck on "5" of "11" and I have to click out and I get this ERROR:
===========================
Deploying store [step 5 of 12], please wait...

Run the "Doctrine_Plugin_UpdateSchema" plugin...
Error
ERROR: "0" (code N/A)

An exception occurred while executing 'ALTER TABLE xc_cart_reminder_translations DROP FOREIGN KEY FK_5B5ECA2BBF396750': SQLSTATE[42S02]: Base table or view not found: 1146 Table 'acaiber2_xcart.xc_cart_reminder_translations' doesn't exist
============================

I had to restore my site from a back up as the upgrade completely messed up my site. I tried it two times with the same results.

Is this a bug?

Thanks,

Kevin
__________________
Version 4.1
Reply With Quote
  #6  
Old 03-29-2015, 10:45 PM
  xplorer's Avatar 
xplorer xplorer is offline
 

X-Cart team
  
Join Date: Jul 2004
Posts: 925
 

Default Re: X-Cart 5.2.3: upgrade issue fix for the users running MySQL v.5.6

Hello Kevin,

We will appreciate if you supply us with the site backup so that we could reproduce the issue and debug it on a local computer.

Please check my message at https://secure.x-cart.com/

Thanks!

Quote:
Originally Posted by fixh
Hello,

I'm trying to Upgrade my X-Cart 5.1.11 to the current 5.2.3 and it gets stuck on "5" of "11" and I have to click out and I get this ERROR:
===========================
Deploying store [step 5 of 12], please wait...

Run the "Doctrine_Plugin_UpdateSchema" plugin...
Error
ERROR: "0" (code N/A)

An exception occurred while executing 'ALTER TABLE xc_cart_reminder_translations DROP FOREIGN KEY FK_5B5ECA2BBF396750': SQLSTATE[42S02]: Base table or view not found: 1146 Table 'acaiber2_xcart.xc_cart_reminder_translations' doesn't exist
============================

I had to restore my site from a back up as the upgrade completely messed up my site. I tried it two times with the same results.

Is this a bug?

Thanks,

Kevin
Reply With Quote
  #7  
Old 03-30-2015, 09:25 AM
  xplorer's Avatar 
xplorer xplorer is offline
 

X-Cart team
  
Join Date: Jul 2004
Posts: 925
 

Default Re: X-Cart 5.2.3: upgrade issue fix for the users running MySQL v.5.6

Hello Kevin,

We have made some debugging and it seems to be a problem in the module.
We will release the fixed module version as soon as possible.

There are other modules which may be affected (for example, Banner System).
These modules will be updated soon too.
Reply With Quote
  #8  
Old 03-30-2015, 01:07 PM
  RichieRich's Avatar 
RichieRich RichieRich is offline
 

X-Adept
  
Join Date: Sep 2004
Location: London, England
Posts: 750
 

Default Re: X-Cart 5.2.3: upgrade issue fix for the users running MySQL v.5.6

Ok so to confirm, the 5.2.3 release does not fix the issue of upgrading 5.1.11 to 5.2.2? And we should wait for 5.2.4 version?
__________________
Richard


Ultimate 5.4 testing
Reply With Quote
  #9  
Old 03-30-2015, 02:01 PM
  qualiteam's Avatar 
qualiteam qualiteam is offline
 

X-Guru
  
Join Date: Dec 2010
Posts: 6,373
 

Default Re: X-Cart 5.2.3: upgrade issue fix for the users running MySQL v.5.6

Quote:
Originally Posted by RichieRich
Ok so to confirm, the 5.2.3 release does not fix the issue of upgrading 5.1.11 to 5.2.2? And we should wait for 5.2.4 version?


As far as I know there is no need in the 5.2.4 release, and the problem will be fixed by updating modules that trigger the error.
If you installed Abandoned Cart Reminder or Banner System, it makes sense to wait until new versions of these modules are available.

I will tell you more details when I have replies from the X-Cart 5 dev team and module developers.
__________________
Alex Solovev,
Qualiteam

---

User manual Video tutorials X-Cart FAQ

You are welcome to press "Thanks" button
if you find this post useful

Click here to learn how to apply patches

X-Cart Extensions
Reply With Quote

The following user thanks qualiteam for this useful post:
RichieRich (03-31-2015)
  #10  
Old 03-30-2015, 03:03 PM
 
kurtiscoady kurtiscoady is offline
    
Join Date: Dec 2014
Posts: 1
 

Default Re: X-Cart 5.2.3: upgrade issue fix for the users running MySQL v.5.6

Totally crashed my site doing the upgrade. How do you pull a backup?
__________________
Kurtis Coady
Reply With Quote
Reply
   X-Cart forums > News and Announcements


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -8. The time now is 09:48 AM.

   

 
X-Cart forums © 2001-2020