Follow us on Twitter X-Cart on Facebook Wiki
Shopping cart software Solutions for online shops and malls

XC5 - Support for PHP 8.0 & subsequent PHP 8.* releases

 
Reply
   X-Cart forums > X-Cart 5 > General questions (X-Cart 5)
 
Thread Tools Search this Thread
  #21  
Old 10-20-2022, 07:56 AM
 
thebluedoorboutique thebluedoorboutique is offline
 

Senior Member
  
Join Date: May 2011
Posts: 161
 

Default Re: XC5 - Support for PHP 8.0 & subsequent PHP 8.* releases

Quote:
Originally Posted by cflsystems
PHP 7.4.x security support ends in a month - https://www.php.net/supported-versions.php
XC5 at its current stage is not PHP 8 ready and the new XC5 is not even close to being released (I suspect) and even if somewhat ready it will be a major upgrade. So lots of breaking changes, waiting on 3rd party modules, bugs, etc.

You should get new host right of way if the current one won't allow you to continue using PHP 7.4.x.

Steve really spoke this into existence. Good job Steve!

https://www.x-cart.com/blog/technology-upgrade.html
__________________
X-Cart Classic 4.4.X
Reply With Quote
  #22  
Old 10-21-2022, 04:58 AM
  cflsystems's Avatar 
cflsystems cflsystems is offline
 

Veteran
  
Join Date: Apr 2007
Posts: 14,132
 

Default Re: XC5 - Support for PHP 8.0 & subsequent PHP 8.* releases

Initial review shows most if not all 3rd party modules will require complete overhaul/rewrite. This doesn't sound like a major upgrade. More of a new XC5 platform.
The bad news here is 5.5.x "is out of beta" and we did not have a chance to adapt anything to it while it was in beta. Now any new XC5 installations will rely on QT/SL modules only. Any existing XC5 stores will not be able to upgrade for many months.
I have over 30 modules. There is no way all of them will be 5.5.x ready soon especially with holidays around the corner. Maybe thought this is a good thing - it will give a chance for the bugs to be worked out before any of the existing stores move to upgrade.
__________________
Steve Stoyanov
CFLSystems.com
Web Development
Reply With Quote

The following 2 users thank cflsystems for this useful post:
Ed B. (10-24-2022), Triple A Racing (10-21-2022)
  #23  
Old 10-23-2022, 09:53 PM
 
kevinrm kevinrm is online now
 

X-Wizard
  
Join Date: Aug 2003
Posts: 1,001
 

Default Re: XC5 - Support for PHP 8.0 & subsequent PHP 8.* releases

Since most of my vital/best mods are made by you, I won't be upgrading anything soon. Do keep us abreast of your status in upgrading if possible.
__________________
X-Cart 5.4.1.37 Live
PHP 7.4
10.3 MariaDB
Apache 2.4
CENTOS 7.8 64Bit Single Quad-Core E3-1241v3 3.4Ghz 8M 1600 w/ HT
32GB RAM 2x 512GB Samsung 850 Pro SSD RAID 1
Reply With Quote
Reply
   X-Cart forums > X-Cart 5 > General questions (X-Cart 5)


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -8. The time now is 08:59 AM.

   

 
X-Cart forums © 2001-2020