Follow us on Twitter X-Cart on Facebook Wiki
Shopping cart software Solutions for online shops and malls

New errors occuring after switch from dev to live server

 
Reply
   X-Cart forums > X-Cart 5 > Dev Questions (X-Cart 5)
 
Thread Tools Search this Thread
  #1  
Old 02-29-2016, 10:20 AM
 
jake.middleton jake.middleton is offline
 

Member
  
Join Date: Oct 2011
Posts: 14
 

Default New errors occuring after switch from dev to live server

My company recently decided to upgrade from X-Cart 4 to X-Cart 5, and we purchased a new VPS to dedicate to X-Cart 5 so there would be no issues.

In development we would access the server via IP address and everything was working well, however after going live with our X-Cart 5 site and pointing nameservers over to the X-Cart 5 server, now there are some unexplained issues going on that didn't happen at all in development.

The biggest issue is that we're sometimes having trouble accessing the admin panel, it throws the following error in xlite.log:

Code:
Feb 29 11:59:32 XLite [warning] Form ID checking failure (target: login, action: login) Runtime id: 3c235afa00f222147bf5f69a26b1d5f8; Server API: cgi-fcgi; IP: 97.100.92.212; Request method: POST; URI: /admin.php?target=login;

This however is not the only login issue, customers are having issues logging in to the frontend as well, and xlite.log reports the following:

Code:
Feb 29 11:59:10 XLite [warning] Log in action is failed (email@goes.here) Runtime id: adf6b374efa57e1dcd87803b69188c7a; Server API: cgi-fcgi; IP: 97.100.92.212; Request method: POST; URI: /cart.php;

Another issue that wasn't happening until going live is this issue in access.log which is reported as "Controller class not found!" This seems to happen on any and every page, and I'm concerned about if it's contributing to the other errors or not, because I can't find any visual effect the error is having on the pages delivered to the user. I've included some snippets below:

Code:
[01:13:09.000000] Controller class not found! Runtime id: adc8a8884bf47c5fba32912c6514fc42 SAPI: cgi-fcgi; IP: 195.154.185.20 URI: /login.php?xid_6ebdd=7900fddf1abd7d4c70b38eb584307b2a Method: GET [01:13:13.000000] Controller class not found! Runtime id: 13078ab8507ed218233fe0f9d883c78d SAPI: cgi-fcgi; IP: 68.180.229.93 URI: /login.php?xid_6ebdd=ced9abc7e70738ce135e502f9b6abe38 Method: GET [11:18:27.000000] Controller class not found! Runtime id: 335da9e2c5d739ca3a91ec6f926c6e77 SAPI: cgi-fcgi; IP: 40.77.167.7 URI: /login.php?xid_6ebdd=374259c2218849e7ebc3619b63d6e73b Method: GET [11:32:03.000000] Controller class not found! Runtime id: 828f4f87f409334897f6298daeec7193 SAPI: cgi-fcgi; IP: 169.230.99.35 URI: /capisco-ergonomic-chair-for-ct-mri.html Method: GET

Now I did a fair amount of debugging and things while in dev, but these errors don't seem to offer any information about what's causing them and they've only appeared after switching from IP address access to domain name access, so I'm hoping someone here might be able to shed some more light on the situation. Thanks for reading.
Reply With Quote
  #2  
Old 02-29-2016, 11:31 AM
  totaltec's Avatar 
totaltec totaltec is offline
 

X-Guru
  
Join Date: Jan 2007
Location: Louisville, KY USA
Posts: 5,823
 

Default Re: New errors occuring after switch from dev to live server

Just to be sure, you edited config.php to reflect the change from IP address to domain name?
__________________
Mike White - Now Accepting new clients and projects! Work with the best, get a US based development team for just $125 an hour. Call 1-502-773-6454, email mike at babymonkeystudios.com, or skype b8bym0nkey

XcartGuru
X-cart Tutorials | X-cart 5 Tutorials

Check out the responsive template for X-cart.
Reply With Quote

The following user thanks totaltec for this useful post:
jake.middleton (03-01-2016)
  #3  
Old 02-29-2016, 11:42 AM
 
jake.middleton jake.middleton is offline
 

Member
  
Join Date: Oct 2011
Posts: 14
 

Default Re: New errors occuring after switch from dev to live server

Quote:
Originally Posted by totaltec
Just to be sure, you edited config.php to reflect the change from IP address to domain name?

I did, yes. I also edited .htaccess to reflect the change as well. (Previously the site was accessed by IP and then temporary subdomain, like 198.1.2.125/~tempurl/, now it's the root directory of the domain)
Reply With Quote
  #4  
Old 02-29-2016, 02:55 PM
  totaltec's Avatar 
totaltec totaltec is offline
 

X-Guru
  
Join Date: Jan 2007
Location: Louisville, KY USA
Posts: 5,823
 

Default Re: New errors occuring after switch from dev to live server

Jake,
These are just silly simple suggestions, but I am covering the basics. Have you tried rebuilding/redeploying the store?

If you want to provide the URL to the site, please do so, might help someone glean some understanding as to what is going on.
__________________
Mike White - Now Accepting new clients and projects! Work with the best, get a US based development team for just $125 an hour. Call 1-502-773-6454, email mike at babymonkeystudios.com, or skype b8bym0nkey

XcartGuru
X-cart Tutorials | X-cart 5 Tutorials

Check out the responsive template for X-cart.
Reply With Quote

The following user thanks totaltec for this useful post:
jake.middleton (03-01-2016)
  #5  
Old 03-01-2016, 05:42 AM
 
jake.middleton jake.middleton is offline
 

Member
  
Join Date: Oct 2011
Posts: 14
 

Default Re: New errors occuring after switch from dev to live server

I appreciate any and all suggestions Mike, sometimes the 'silly' stuff is the stuff that gets overlooked.

I have redeployed the store multiple times to no avail, is rebuilding the store something different than redeploying the store? If so, I'm not sure that I've done that. I've tried deleting the var/datacache folder as well.

We've had to put the store into maintenance mode for the time being, but I'll provide the private link below so that anyone here can take a look and see if they can figure something out that I cannot.

https://www.soundergonomics.com/?shopKey=c49dbf42d40998328a431a2ca48fdcf7
Reply With Quote
  #6  
Old 03-01-2016, 05:54 AM
  totaltec's Avatar 
totaltec totaltec is offline
 

X-Guru
  
Join Date: Jan 2007
Location: Louisville, KY USA
Posts: 5,823
 

Default Re: New errors occuring after switch from dev to live server

Well, I went on and created an account. No problems, added to cart, went to checkout, almost went through with a PayPal transaction. No problems.

Tried to login to the admin, and was denied (as I should have been)

I do see the formid: eXoPnO05mZs0KV1SGWej4q9T35hQQHdU That was the one I received, and it threw no error, just denied my ability to login since I had the incorrect username and password for the admin.

Then I tried logging out, closing the browser, and coming back and logging in with the profile I just created. No problem, was able to proceed and add to cart and checkout.

Everything looks fine! I would clear your browser cache, or try a different browser, because from an outsider perspective, there is no issue that I can see.
__________________
Mike White - Now Accepting new clients and projects! Work with the best, get a US based development team for just $125 an hour. Call 1-502-773-6454, email mike at babymonkeystudios.com, or skype b8bym0nkey

XcartGuru
X-cart Tutorials | X-cart 5 Tutorials

Check out the responsive template for X-cart.
Reply With Quote

The following 2 users thank totaltec for this useful post:
ITVV (03-01-2016), jake.middleton (03-01-2016)
  #7  
Old 03-01-2016, 05:57 AM
 
ITVV ITVV is online now
 

X-Wizard
  
Join Date: Nov 2006
Location: UK
Posts: 1,094
 

Thumbs up Re: New errors occuring after switch from dev to live server

Hi,

Just tried your link and all seems to be OK here in the UK?

Site is loading fast and seems liquid and solid.

Hope you sorted it all now?

Kind regards from the UK

ITVV
__________________
X-Cart Pro 4.7.12 Active and working great with reBOOT-reDUX
X-Cart Pro 4.6.6 Retired after 6 years of first class service
X-Cart Pro 4.1.7 Retired after 9 years of first class service

Apache: 2.4.25
PHP: 7.4.5
MariaDB: 10.1.44
Arch: x86_64
Reply With Quote

The following user thanks ITVV for this useful post:
jake.middleton (03-01-2016)
  #8  
Old 03-01-2016, 07:20 AM
 
jake.middleton jake.middleton is offline
 

Member
  
Join Date: Oct 2011
Posts: 14
 

Default Re: New errors occuring after switch from dev to live server

Thank you both for testing it for me. I will set the website to live for now, and if I hear back from customers with any issues I will update the thread. Thank you again, hopefully this issue has been resolved through some combination of simple fixes.
Reply With Quote

The following 2 users thank jake.middleton for this useful post:
ITVV (03-01-2016), totaltec (03-01-2016)
  #9  
Old 07-30-2020, 02:47 AM
 
Hthr Hthr is offline
 

Member
  
Join Date: Sep 2002
Location: Canada
Posts: 18
 

Default Re: New errors occuring after switch from dev to live server

Jake,

I know this thread is quite old, but we are having the exact same issue the login in the front end of the cart.
Do you remember what it was the finally fixed the issue for you?

-G
__________________
Version 4.0.17
Reply With Quote
Reply
   X-Cart forums > X-Cart 5 > Dev Questions (X-Cart 5)


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -8. The time now is 03:44 PM.

   

 
X-Cart forums © 2001-2020