Follow us on Twitter X-Cart on Facebook Wiki
Shopping cart software Solutions for online shops and malls

USPS Module

 
Reply
   X-Cart forums > X-Cart 5 > Dev Questions (X-Cart 5)
 
Thread Tools Search this Thread
  #1  
Old 03-14-2014, 10:08 AM
 
mworsnop mworsnop is offline
 

Senior Member
  
Join Date: Mar 2014
Posts: 140
 

Default USPS Module

Has anyone tried the USPS module? I have USPS running on a quick piece of software I wrote and my login is working properly and returning proper information.

However on here the test module give me an error saying my login is not correct. Did the XML get parsed correctly on the send?
__________________
Mark Worsnop

vers 5.3.3
Reply With Quote
  #2  
Old 03-17-2014, 10:20 AM
  Luisv's Avatar 
Luisv Luisv is offline
 

Member
  
Join Date: Oct 2005
Location: Nebraska
Posts: 20
 

Default Re: USPS Module

I have the same problem.
__________________
Luis Villamonte
Computer Systems Engineer
Microsoft and CompTIA Certified
www.MagicKits.com
X-cart 5.0.12
Reply With Quote
  #3  
Old 03-18-2014, 08:18 AM
 
Ruslan Ruslan is offline
 

X-Cart team
  
Join Date: Jul 2013
Posts: 30
 

Default Re: USPS Module

Hi Mark and Luis!

Unfortunately I failed to replicate the issue which you mentioned. But there are some tricks with this module.

1 - First of all you should enter right "U.S.P.S. API server URL" , testing or production. It depends on your account type http://awesomescreenshot.com/00f2ie2j14

2 - Test rates calculation
http://awesomescreenshot.com/0032ie5z86

3 - If USPS module can find new shipping methods(which are not included in our USPS module) in the response they will be added to database as disabled methods. You should enable them http://awesomescreenshot.com/0da2ie5vb4

4 - Go to checkout page and test it.
http://awesomescreenshot.com/05e2ie8t63

Sorry for this inconvenience, we will add all this new USPS shipping methods as enabled methods in the next version of "USPS" module.
__________________
X-Cart 5
Reply With Quote
  #4  
Old 03-18-2014, 09:05 AM
 
mworsnop mworsnop is offline
 

Senior Member
  
Join Date: Mar 2014
Posts: 140
 

Default Re: USPS Module

There must be a step we are missing. This is what I did:

1. I have my user ID from USPS. I entered this into the user ID

2. Here is the email from USPS. I entered both of these URLs

Depending on the API, the address to the test server is either http://production.shippingapis.com/ShippingAPITest.dll or https://secure.shippingapis.com/ShippingAPITest.dll. Use this information in combination with your User ID and your XML string to send a request to the USPS servers.

3. I clicked on SAVE

4. I went the the bottom of the screen and entered a zip code

5. I click on TEST

I get a new screen with the logs and it says
Authorization failure. You are not authorized to connect to this server.

I used my test program outside of XC and my login and both URLs work properly.

What steps are you taking exactly?
__________________
Mark Worsnop

vers 5.3.3
Reply With Quote
  #5  
Old 03-18-2014, 09:43 AM
  Luisv's Avatar 
Luisv Luisv is offline
 

Member
  
Join Date: Oct 2005
Location: Nebraska
Posts: 20
 

Default Re: USPS Module

I cannot get it to work as well. I've tried with my ID and without my ID. I've enabled the shipping method and used the API URL I received in the email from USPS. I too must be missing something.
__________________
Luis Villamonte
Computer Systems Engineer
Microsoft and CompTIA Certified
www.MagicKits.com
X-cart 5.0.12
Reply With Quote
  #6  
Old 03-18-2014, 11:27 AM
 
Ruslan Ruslan is offline
 

X-Cart team
  
Join Date: Jul 2013
Posts: 30
 

Default Re: USPS Module

Mark, Luis did you contact the USPS Internet Customer Care Center (ICCC) to be granted permission to use the API?
X-Cart uses API=RateV4

Quote:
Your Web Tools User ID, shown above, is required to integrate with USPS Web Tools APIs. In order to start your integration process you must contact the USPS Internet Customer Care Center (ICCC) via phone or email to be granted permission to use the APIs you need. They will switch your profile to allow you access to the production server and will provide you with the production URLs.
__________________
X-Cart 5
Reply With Quote
  #7  
Old 03-18-2014, 11:56 AM
 
mworsnop mworsnop is offline
 

Senior Member
  
Join Date: Mar 2014
Posts: 140
 

Default Re: USPS Module

I am using the same login on a test app and it works. Also the email from USPS says contact them when you are finished testing.


Your Web Tools User ID, shown above, is required to test and integrate USPS Web Tools APIs. With this ID, you may begin sending calls to the test server. Depending on the API, the address to the test server is either http://production.shippingapis.com/ShippingAPITest.dll or https://secure.shippingapis.com/ShippingAPITest.dll. Use this information in combination with your User ID and your XML string to send a request to the USPS servers. For more details, refer to the programming guides (located at http://www.usps.com/webtools) for the specific API you are integrating.

A sample test request would look like: "http://production.shippingapis.com/ShippingAPITest.dll?API=[API_Name]&XML=[XML_String_containing_User_ID]"

When you have completed your testing, email the USPS Internet Customer Care Center (ICCC). They will switch your profile to allow you access to the production server and will provide you with the production URLs.

The ICCC is staffed as follows:
Monday through Friday from 8:00AM to 8:30PM Eastern Time
Saturday from 8:00AM to 6:00PM Eastern Time
Sunday and Postal Holidays - Closed except for the following Holidays: Martin Luther King; President's Day; Columbus Day; & Veteran's Day with hours from 9:00AM to 6:00PM Eastern Time
__________________
Mark Worsnop

vers 5.3.3
Reply With Quote
  #8  
Old 03-18-2014, 12:39 PM
 
Ruslan Ruslan is offline
 

X-Cart team
  
Join Date: Jul 2013
Posts: 30
 

Default Re: USPS Module

Mark, did you use API=RateV4 in your test app?

I believe that the problem is that your account doesn't have permissions to use API=RateV4.

Quote:
RateV4 is not applicable in Testing server, therefore you won't be able to obtain any response. And, in regards to RateV4 in Production server, you will need to obtain permission from ICCC, USPS.

There is the solution for the same problem with USPS in X-Cart 4
http://help.x-cart.com/index.php?title=X-Cart:USPS#USPS_error:_Authorization_failure._You_a re_not_author...to_this_server.

And some related issues from stackoverflow.com
http://stackoverflow.com/questions/15236053/usps-shipping-calculator-api-not-returning-valid-response
http://stackoverflow.com/questions/7885269/response-from-usps-rate-calculator

Please contac the Internet Customer Care Center (USPS) and ask them to switch your profile to allow you access to the production server.
__________________
X-Cart 5
Reply With Quote
  #9  
Old 03-18-2014, 12:50 PM
 
mworsnop mworsnop is offline
 

Senior Member
  
Join Date: Mar 2014
Posts: 140
 

Default Re: USPS Module

Ruslan, are you using Vers 5?

I am just trying to use the XCART FIVE module.

I sent a message to USPS to enable my account for production. Seems weird though as I entered test server addresses.
Let see if that fixes it.
__________________
Mark Worsnop

vers 5.3.3
Reply With Quote
  #10  
Old 03-19-2014, 04:09 AM
  tony_sologubov's Avatar 
tony_sologubov tony_sologubov is offline
 

X-Cart team
  
Join Date: Jan 2009
Posts: 2,431
 

Default Re: USPS Module

Hi guys!

As I understand your situation as follows: if you are using test USPS account it works fine, if you are using live USPS account, it returns "Authorization failed" error message.

This is usual thing when it comes to USPS. You need to call or email USPS support team and ask them to move your USPS account to production servers, so you would be able use it in your store.

Just contact them and the same account that now returns "Authorization failed" error message will start working after they apply their changes.
Reply With Quote
Reply
   X-Cart forums > X-Cart 5 > Dev Questions (X-Cart 5)


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -8. The time now is 09:05 AM.

   

 
X-Cart forums © 2001-2020