Follow us on Twitter X-Cart on Facebook Wiki
Shopping cart software Solutions for online shops and malls

Upgrade to 5.2 fails

 
Reply
   X-Cart forums > X-Cart 5 > Modifying the design and features (X-Cart 5)
 
Thread Tools Search this Thread
  #1  
Old 03-26-2015, 04:50 AM
 
Burt Burt is offline
 

Newbie
  
Join Date: Jun 2007
Posts: 6
 

Default Upgrade to 5.2 fails

We ran the upgrade for xcart 5 and now it is broken. This is the error message. No way of getting to the admin to try and sort.


==> php_errors.log.2015-03-26.php <==
[26-Mar-2015 13:23:01] Error (code: 1): Call to a member function log() on a non-object
Server API: litespeed;
Request method: GET;
URI: /;
Backtrace:
#0 Includes\ErrorHandler::logInfo(Call to a member function log() on a non-object, 1) called at [/home/xxxxx/public_html/xxxxxxxxxxxxxxx/Includes/ErrorHandler.php:327]
#1 Includes\ErrorHandler::handleError(Array ([type] => 1,[message] => Call to a member function log() on a non-object,[file] => /home/xxxxx/public_html/xxxxxxxxxxxx.co.uk/var/run/classes/XLite/Logger.php,[line] => 211)) called at [/home/xxxxx/public_html/xxxxxxxxxxxxx/Includes/ErrorHandler.php:312]
#2 Includes\ErrorHandler::shutdown()



==> xlite.log.2015-03-26.php <==
<?php die(1); ?>
__________________
Michael
Reply With Quote
  #2  
Old 03-26-2015, 05:27 AM
 
xim xim is offline
 

X-Cart team
  
Join Date: Nov 2004
Posts: 677
 

Default Re: website broken after upgrade

Please try to drop the cart cache manually and then re-create it. Please follow these instruction:

http://kb.x-cart.com/display/XDD/What+to+do+if+you+cannot+access+your+store+and+it+ says+we+are+deploying+new+changes
__________________
Sincerely yours, Max Vydrin
Reply With Quote
  #3  
Old 03-26-2015, 05:31 AM
 
xim xim is offline
 

X-Cart team
  
Join Date: Nov 2004
Posts: 677
 

Default Re: website broken after upgrade

And let us know the results, please
__________________
Sincerely yours, Max Vydrin
Reply With Quote
  #4  
Old 03-26-2015, 06:50 AM
 
skit skit is offline
 

Advanced Member
  
Join Date: Feb 2015
Posts: 40
 

Default Upgrade to 5.2 fails

I am getting this error.
Internal error. Contact the site administrator.

There is no css formatting showing and it all worked fine in 5.1.11.

Any ideas? I am using a custom module/skin
__________________
V5.2.13
Reply With Quote
  #5  
Old 03-26-2015, 08:19 AM
  RichieRich's Avatar 
RichieRich RichieRich is offline
 

X-Adept
  
Join Date: Sep 2004
Location: London, England
Posts: 750
 

Default Re: Meet X-Cart 5.2.2 STABLE

Going from 5.1.11 to 5.2.2;

Quote:
Deploying store [step 5 of 12], please wait...

Run the "Doctrine_Plugin_UpdateSchema" plugin...
Error
ERROR: "0" (code N/A)

An exception occurred while executing 'ALTER TABLE x5_banners CHANGE id id INT AUTO_INCREMENT NOT NULL, CHANGE enabled enabled TINYINT(1) NOT NULL, CHANGE home_page home_page TINYINT(1) NOT NULL, CHANGE secondary_pages secondary_pages TINYINT(1) NOT NULL, CHANGE navigation navigation TINYINT(1) NOT NULL, CHANGE arrows arrows TINYINT(1) NOT NULL': SQLSTATE[HY000]: General error: 1025 Error on rename of './dbXXX/#sql-1c35_b9abd' to './dbXXX/x5_banners' (errno: 150)
__________________
Richard


Ultimate 5.4 testing
Reply With Quote
  #6  
Old 03-26-2015, 08:49 AM
 
Burt Burt is offline
 

Newbie
  
Join Date: Jun 2007
Posts: 6
 

Default Re: website broken after upgrade

Thanks for the quick reply. Tried both methods but did not work. Site is broken. No idea how to restore it now.
__________________
Michael
Reply With Quote
  #7  
Old 03-26-2015, 08:51 AM
 
tony1100 tony1100 is offline
 

Advanced Member
  
Join Date: Oct 2012
Posts: 31
 

Default upgrade to 5.2 error

When trying to upgrade 5.2, store get stuck on building caching step 3.

any idea?
__________________
Tony
Reply With Quote
  #8  
Old 03-26-2015, 10:26 AM
 
tony1100 tony1100 is offline
 

Advanced Member
  
Join Date: Oct 2012
Posts: 31
 

Default Re: upgrade to 5.2 error

figure it out. disable all module, and after upgrade then enable module one by one. very frustating
__________________
Tony
Reply With Quote
  #9  
Old 03-26-2015, 10:30 AM
 
tony1100 tony1100 is offline
 

Advanced Member
  
Join Date: Oct 2012
Posts: 31
 

Default Re: Getting front end error after 5.2 upgrade

have you try to drop cache and rebuild cache? I was upgrade to 5.2, so frustrating, lots of info missing. still trying to make site back to normal
__________________
Tony
Reply With Quote
  #10  
Old 03-26-2015, 01:17 PM
 
xim xim is offline
 

X-Cart team
  
Join Date: Nov 2004
Posts: 677
 

Default Re: website broken after upgrade

Please, post the ticket under your help desk account, attach the logs and provide us with access info.

Did you make a backup before start to upgrade the store?
__________________
Sincerely yours, Max Vydrin
Reply With Quote
Reply
   X-Cart forums > X-Cart 5 > Modifying the design and features (X-Cart 5)


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -8. The time now is 11:52 PM.

   

 
X-Cart forums © 2001-2020