Follow us on Twitter X-Cart on Facebook Wiki
Shopping cart software Solutions for online shops and malls

eBay Integration for X-Cart 4
 
Reply
   X-Cart forums > News and Announcements
 
Thread Tools
  #1  
Old 09-08-2015, 10:41 AM
  Ksenia's Avatar 
Ksenia Ksenia is offline
 

X-Cart team
  
Join Date: Apr 2013
Posts: 735
 

Default eBay Integration for X-Cart 4

Hi friends.
I know many of you were looking forward to the moment when Maxim Korchagin, the author of eBay integration for X-Cart 5, adjusts his product for X-Cart 4.

We started from v.4.7.3, that's the only version it's compatible with currently, but Maxim is already working on adaptation for v.4.6.x for Adam, so I believe that you will see the connectors for the older versions soon too.

The integration currently supports the same set of features for both X-Cart 4 and 5, and it has a very good configuration wizard, making it way easier to setup and configure.

The pricing scheme is the same for both X-Cart platforms too - it's subscription-based and has a free trial for up to 300 requests. If you would like to be among the early birds, and your version is not supported yet, please let us know by commenting this thread.

Screenshots, description, pricing is here:
https://www.x-cart.com/extensions/modules/ebay-integration.html
__________________
X-Cart team
Reply With Quote

The following 2 users thank Ksenia for this useful post:
BBM_ (09-08-2015), elmirage001 (09-08-2015)
  #2  
Old 09-11-2015, 02:57 AM
 
admin admin is offline
Maxim Korchagin
 

X-Cart team
  
Join Date: May 2006
Posts: 4
 

Default Re: eBay Integration for X-Cart 4

Hi X-Carters.

I’m the developer of this module and I would like to update you regarding the progress. I have just finished the module adaptation for v.4.6.0 per the very first request of a user, who wanted to be an early-bird. I have plans to cover all the versions sooner or later, but I’m hesitating what version to proceed with next.

So if you do love this module and happy to buy the subscription, but it’s not available for your X-Cart store so far, please let me know, and the next module adaptation will be for your store version!
__________________
Sincerely yours,
Maxim Korchagin,
X-Cart Developer
Reply With Quote

The following user thanks admin for this useful post:
Ksenia (09-13-2015)
  #3  
Old 09-14-2015, 10:07 AM
 
jrusso jrusso is offline
    
Join Date: Mar 2014
Posts: 1
 

Default Re: eBay Integration for X-Cart 4

What version of PHP is needed to run this module?
__________________
4.6.3
Reply With Quote
  #4  
Old 09-15-2015, 04:24 AM
 
elmirage001 elmirage001 is offline
 

X-Wizard
  
Join Date: Apr 2007
Posts: 1,592
 

Default Re: eBay Integration for X-Cart 4

Dear X-Cart Team,

We definitely have plans to use this service starting around mid 2016. Too many things going on till then. Thank you so much for making this available for X-Cart 4!

Paul
__________________
X-Cart GoldPlus v4.7.11 | PHP 7.2.22
  • XCARTMODS.CO.UK | reBOOT Template |
  • Smack Digital | CDSEO Pro 2.0 + Custom Replacements | Category SEO Map |
  • Total Server Solutions Hosting | Linux | PHP v7.2 | MySQL v5.6.40 |
Reply With Quote

The following user thanks elmirage001 for this useful post:
Ksenia (09-15-2015)
  #5  
Old 09-15-2015, 10:48 PM
 
admin admin is offline
Maxim Korchagin
 

X-Cart team
  
Join Date: May 2006
Posts: 4
 

Default Re: eBay Integration for X-Cart 4

Quote:
Originally Posted by jrusso
What version of PHP is needed to run this module?

We recommend to use the same PHP version as used for your X-Cart installation.
For the latest X-Cart 4.7.3 we recommend to use PHP 5.3 and higher.
For your X-Cart 4.6.3 we recommend to use PHP 5.2 and higher.
__________________
Sincerely yours,
Maxim Korchagin,
X-Cart Developer

Last edited by admin : 09-15-2015 at 10:56 PM.
Reply With Quote
  #6  
Old 09-16-2015, 05:15 AM
  cflsystems's Avatar 
cflsystems cflsystems is offline
 

Veteran
  
Join Date: Apr 2007
Posts: 13,602
 

Default Re: eBay Integration for X-Cart 4

You cannot use PHP 5.3.x and lower anymore due to PCI compliance. These versions reached their EOL and are not supported.
__________________
Steve Stoyanov
CFLSystems.com
Web Development
Reply With Quote
  #7  
Old 09-16-2015, 05:30 AM
  Ksenia's Avatar 
Ksenia Ksenia is offline
 

X-Cart team
  
Join Date: Apr 2013
Posts: 735
 

Default Re: eBay Integration for X-Cart 4

Quote:
Originally Posted by cflsystems
You cannot use PHP 5.3.x and lower anymore due to PCI compliance. These versions reached their EOL and are not supported.


Hi Steve,
probably I'm missing something, but eBay integration module does not process credit cards etc, so why are we speaking about PCI compliance?

Moreover, if X-Cart itself uses redirect-based payment methods ( when the payer is sent to a payment page hosted by the payment gateway), the store is our of scope of PCI compliance regulations too. It simply never touches the sensitive CC info at all.

If "merchant-hosted" payment methods are used, the proper way is to process them via X-Payments, that's an independent software, PA DSS certified one, it has higher system requirements (compared to X-Cart) due to PCI compliance indeed, and yes, it requires PHP 5.3 or higher, but it can be installed on a separate server, other than the one used to host X-Cart itself. So PHP 5.3+ rule is rather applied to X-Payments, not X-Cart, if we speak about PCI compliance.

You may have many other reasons to use PHP 5.3 and higher, security is the most important one, but I still do not quite understand why you speak about PCI compliance in the context of ebay Integration for X-Cart.
__________________
X-Cart team
Reply With Quote
  #8  
Old 09-16-2015, 05:42 AM
  cflsystems's Avatar 
cflsystems cflsystems is offline
 

Veteran
  
Join Date: Apr 2007
Posts: 13,602
 

Default Re: eBay Integration for X-Cart 4

PCI compliance is not only about CC processing. It also covers all software and hardware the site/application runs on. An ecommerce store may not process onsite payments but this does not set them free form being PCi compliant for all other software in use - PHP, MySQL, server OS, etc. They all have to be PCi compliant. One of the requirements is not to use any old or out of support software.

So even if an XC store doe snot process payments on site they are still required to use active PHP version. PHP 5.3.x and below are out of support - meaning any security issues with them will not be officially patched and leave the store open for hackers. This is not allowed.
__________________
Steve Stoyanov
CFLSystems.com
Web Development
Reply With Quote
  #9  
Old 09-16-2015, 05:44 AM
  cflsystems's Avatar 
cflsystems cflsystems is offline
 

Veteran
  
Join Date: Apr 2007
Posts: 13,602
 

Default Re: eBay Integration for X-Cart 4

Ask TSS - all their servers are PCI compliant. This has nothing to do with XC or how payments are processed right. Yet it is still a requirement for the host and their software/hardware to be PCI compliant to run ecommerce on them.
__________________
Steve Stoyanov
CFLSystems.com
Web Development
Reply With Quote
  #10  
Old 09-17-2015, 09:06 PM
 
admin admin is offline
Maxim Korchagin
 

X-Cart team
  
Join Date: May 2006
Posts: 4
 

Default Re: eBay Integration for X-Cart 4

We have prepared a distribution packages of the eBay module for following versions:
X-Cart 4.6.1
X-Cart 4.6.5

The distribution packages are available on the page:
https://drive.google.com/a/x-cart.com/folderview?id=0B5HGLTCz_J7vfkFRUlkwaS1QNm45dGZzSHJ aajlUZmdGaE8wTVl...AxQnJZZkk#list
__________________
Sincerely yours,
Maxim Korchagin,
X-Cart Developer
Reply With Quote

The following 2 users thank admin for this useful post:
elmirage001 (09-18-2015), Ksenia (09-18-2015)
Reply
   X-Cart forums > News and Announcements


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -8. The time now is 08:01 AM.

   

 
X-Cart forums © 2001-2018