View Single Post
  #167  
Old 07-24-2018, 04:29 AM
 
Triple A Racing Triple A Racing is offline
 

X-Adept
  
Join Date: Jul 2008
Location: Manchester UK
Posts: 943
 

Default Re: Gdpr - upcoming law for European merchants

Quote:
Originally Posted by ITVV
XC5 users (and any other cart) should have been fully responsible for their own GDPR setup as of May 25th 2018
Yes.... but No. You're wrong if examined in fine detail. If (any cart) store owners are using a given, fully provided, non-customisable GDPR setup and then "...get caught" The provider will eventually be jointly liable with them, for any subsequent "failure to comply legal cases"

Absolutely not interested debating long legal / coulda / shoulda / woulda items on here (especially any of those originating from the USA aka #NoWinNoFeeLawSuitCentral) but do have a quick look at the sequence of failures involved in the McDonalds legal case on cup warnings about hot content... Amongst millions of other ultimate liability / responsibility cases Then again, don't waste any time looking for successful, big fine legal cases on the previous EU cookie law, as that's just a fool's errand
Quote:
Originally Posted by ITVV
How does the module "know" which Country the visitor is coming from if not using XC Geolocation Module????
Quite a lot of people still think Geolocation Modules are like an Epiphany... How does any Geolocation Module work with the aforementioned VPN / IP Spoofing or even more relevant; Smart DNS Proxys? Ask anybody who successfully uses streaming devices when outside their own country, but do prepare for howls of laughter from them about "...being located and then blocked by their IP address"

Meanwhile, the answer, to the question, is contained earlier in this thread, in the module itself (when setting it up) and by XC processes that don't involve or need the Geolocation Module. When you move over from XC4, then all will become clear Come and see!
__________________
Dev Store & Live Store: XC Business 5.4.1.19
Server; Ubuntu 18.04.5 LTS (HWE 5.4.0-54.60 Kernel) / Plesk Obsidian
Nginx 1.18.0 / Apache 2.4.29 (Ubuntu Backported) / MariaDB 10.5.8 / PHP 7.4.13
Reply With Quote