View Single Post
  #1  
Old 05-30-2017, 04:52 AM
 
dpcompany dpcompany is offline
 

eXpert
  
Join Date: Oct 2008
Posts: 264
 

Default X-Payments Issues

I am having 2 issues with X-Payments v3.0.2. The first issue I have posted a bug request (bt #0048001) but haven't received a response, so I am hoping that posting here will big some attention to it. The second is a randomly occurring issue that my customers have reported, but I can't quite nail it down.

Issue 1:
Customer places order on our site. Customer calls us after order is placed to add another product to the order resulting in an order total that is greater than the original authorized amount. So, we log into X-Payments to capture the original authorized amount. Then, we re-authorize the original card for the additional amount and capture it. This is where the issue lies: Upon returning to the X-Cart Admin section, there will be a "new order" in our orders list for the amount of money we just additionally captured. But that order has no products on it. This "new order" should have never been created, and never used to be created prior to v3.0.2.

Issue 2:
This issue is intermittent which is why it is so hard to nail down. We have our X-Payments set up to use Iframe at checkout. Occasionally, a customer will go to checkout, select credit card, the Iframe pops up, they enter their information, accept the terms and submit the order, but then are redirected to another X-Payments page to enter their credit card information. So, this obviously doesn't look right to the customer because they already previously entered credit card information in the Iframe on the previous page.

Has anyone here seen or heard of the above two issues? Any information would be greatly appreciated. See y'all in Tampa!
__________________
Michael

Development
X-Cart Gold Plus v4.7.12
- php 7.3
- reBOOT reDUX
- other goodies

X-Cart Gold v4.7.7
- reBOOT Template
- XPayments 3.0.2
- Abandoned Cart Reminder
- BCSE Reward Points
- BCSE Stock Notify
- XPDF Invoices
Reply With Quote