View Single Post
  #4  
Old 10-04-2018, 03:14 PM
  CenturyPerf's Avatar 
CenturyPerf CenturyPerf is offline
 

eXpert
  
Join Date: Jun 2003
Location: Reno, Nevada
Posts: 396
 

Default Re: X-Payments 3.1.4 Issues

I would agree Ambal, that deprecated files should not exist if the update process properly removed them.

Since X-Cart's Ransom Support has yet to respond to the ticket created yesterday, I went ahead and installed a fresh version of X-Payments 3.1.4 and new database. This has solved "almost" all of the issues.

As I mention in the support ticket, The one issue that still exists, and has been a problem for some time. No matter which web browser is used (Chrome, Firefox, Edge, Opera, Avast), upon reaching the checkout page, the payment template (where credit card data is entered) often does not populate without refreshing the page.

It does not seem to be on my end, as I've had a few customers complain that they had nowhere to enter credit card data at checkout. I've also had others perform tests, and sometimes the CC template from X-Payments loads, and other times it does not.

I've attached two images showing the checkout page upon initial arrival and then after having to manually refresh the page.

***Additional issue that "might" have been corrected with this fresh install of X-Payments. There were times where shipping charges did not properly transfer to X-Payments. I do not know if the behavior will occur with the fresh install of X-Payments, only time will tell. The total would show properly at checkout, but X-Payments would return an error that shipping charges did not match. Obviously, the totals were not properly communicating between the site and X-Payments.
Attached Images
File Type: jpg noCCtemplate.jpg (110.3 KB, 10 views)
File Type: jpg CCtemplateAfterRefresh.jpg (128.7 KB, 9 views)
__________________
Best Regards,

Sam Solace - Pres/CEO
Century Performance Center, Inc.
http://www.centuryperformance.com

(3) sites using X-Cart 5.3.5.5
X-Payments Enterprise 3.1.4
Reply With Quote