View Single Post
  #2  
Old 12-15-2020, 09:34 AM
 
memoto memoto is offline
 

X-Cart team
  
Join Date: Feb 2018
Posts: 240
 

Default Re: XC5 - Support for PHP 8.0 & subsequent PHP 8.* releases

Thanks for this question!

There is no ETA on this big change yet. 5.4.2.x won't be adapted to PHP 8 for sure.

The main issue is that a lot of libs don't support PHP 8 yet. Moreover, some of them have such plans (adapting), and some of them are going to be dropped (as a result, forks have to be developed and adapted). Some of the libs are going to support only the "upper" versions like >7.3 so all the previous ones won't be compatible.

Anyway, I will always post a "New 5.N.N.N version released" with a changelog link so you can see all the included changes/fixes/improvements.
__________________
X-Cart Team
Reply With Quote