View Single Post
  #27  
Old 11-16-2014, 12:58 AM
  vasilis's Avatar 
vasilis vasilis is offline
 

X-Adept
  
Join Date: Feb 2009
Posts: 750
 

Default Crypt_cell_is_not_detected (1311)

Have just fresh installed X-Payments 2.1.1 on a 4.6.4 store, having connected it with Authorize.NET AIM payment method.

When I submit test orders I get to the X-Payments cc form page, but I get Failed transactions, with
Quote:
'--- Advanced info ---
Reason: Aborted due to errors during transaction processing'
message in the Payment gateway log section of the order details and no log error in the X-Cart store, concerning X-Payments Connector errors.

In the X-Payments backend, these orders are listed under "Pending" status.

No reports for these transactions are created in the Authorize.NET backoffice side.

In the X-Payments logs though, I see the following errors:
Quote:
ERROR [2014-15-11 13:43:25]
User: unknown; IP: 68.195.69.133
Zone: Crypt/Cell
Code: CRYPT_CELL_IS_NOT_DETECTED (1311)
Encrypted cell for data with prefix '"false"' is not detected

Affected systems: Crypt/Cell.php file (91:assert); Core/ApiProtocol.php file (154:detect); Model/Payment.php file (4482:unpack); Model/Payment.php file (1838:checkCart); Model/Payment.php file (1750:processInit); Controller/Payment/Main.php file (242:process); Controller/Payment/Main.php file (220:doPay); Core/Controller.php file (181:actionPay); Controller/Payment.php file (277:process); Core/Dispatcher.php file (148:process); Application.php file (156:dispatch); /home/<user>/public_html/xpayments/payment.php file (26:run)

Any idea what this cryptic message means, or how to fix this?
Reply With Quote