View Single Post
  #5  
Old 09-29-2014, 04:39 AM
  ambal's Avatar 
ambal ambal is offline
 

X-Cart team
  
Join Date: Sep 2002
Posts: 4,113
 

Default Re: X-Payments transfer to other server with upgraded store

Quote:
Originally Posted by vasilis
The current x-payments is hosted in the xcart root directory.

And this is wrong as X-Payments must be installed separately in its own hosting account/VPS/server in order to be PCI compliant.
See http://help.x-cart.com/index.php?title=X-Cart_Payments:PCI_DSS_implementation_guide

We do not recommend to install X-Payments in the same hosting space/account where you run your X-Cart shop or other software as X-Payments can be compromised via them.

Quote:
Originally Posted by vasilis
I have the following questions:
  • Will I need to re-install and re-configure x-payments in the new server, or I just copy the files and database and just change any related settings, concerning the new server?


You may need to adjust X-Payments config.ini.php file and shop settings in X-Payments dashboard if the new server has other IP address/domain name. Also, you may need to re-deploy configuration bundle in connected X-Cart stores due to the same reason.



Quote:
Originally Posted by vasilis
  • Does the fact that x-payments will be deployed in the 4.6.4 upgraded store make any difference in the required steps?


X-Cart & X-Payments connection routine changed a lot in 4.6.4. Unfortunately, we haven't updated our user manual article about that yet. I am preparing a video that explains the new connection routine.


Quote:
Originally Posted by vasilis
  • In X-Payments Connector admin page, there is a 'API 1.1 version is supported' line. Does this mean that the installed x-payments version is 1.1 and if not, how do I check the version of x-payments?


Nope, that's X-Payments API version - see http://help.x-cart.com/index.php?title=X-Payments:API
Right now there are API versions 1.1, 1.2, 1.3 which are implemented in different X-Payments versions.
The latest version of X-Payments v1.x is 1.0.6, the latest (at the moment) version of X-Payments 2.x is 2.1.1


New X-Cart v4.6.4 connector for X-Payments defines API version automatically.


Quote:
So, I guess it is not required to upgrade the current x-payments, if I don't need to use the new x-payments features related with saving customers' cc data, or for recurring billing. Is this correct?

If it is not a new deployment of X-Payments for a new web-site/business you can keep using your v1.x version.



Quote:
  • On the other hand, I read the following excerpt in this thread:
    Does this hold only if you want to use the new features referred above? (saving customers' cc data, or for recurring billing)

Your new X-Cart 4.6.4 will work with your old X-Payments v1.x (i.e. it will process payments for orders of your shoppers) but it will not support new features of X-Payments 2.x. Also some of the usability improvements we added into new versions of X-cart connectors and X-Payments may not work either as they relay on using certain API calls we added into X-Payments v2.1.1.
__________________
Sincerely yours,
Alex Mulin
VP of Business Development for X-Cart
X-Payments product manager
Reply With Quote