View Single Post
  #2  
Old 03-02-2022, 04:23 AM
  cflsystems's Avatar 
cflsystems cflsystems is offline
 

Veteran
  
Join Date: Apr 2007
Posts: 14,132
 

Default Re: Help upgrading from 5.3 to 5.4

XC5 upgrade is done through the backend directly. It will pull all necessary files and install the upgrade. If you have any custom modules you will have to revised them and make them 5.4.x compatible first as the code is very different between 5.3.x and 5.4.x.
Also your server should be running on PHP and MySQL versions that are highest for 5.3.x and lowest for 5.4.x - PHP 7.2.x and MySQL 5.7. After the upgrade you should switch to PHP 7.4 and MySQL 8.
If you cannot do this on your own server you can do the upgrade on another server or even local machine and then push everything to the live server. Of course the live server.
If your live server will not run PHP 7 and up - get another host. Any PHP version below 7.4.x is out of support and should not be used.
__________________
Steve Stoyanov
CFLSystems.com
Web Development
Reply With Quote