View Single Post
  #2  
Old 08-08-2020, 03:40 PM
  cflsystems's Avatar 
cflsystems cflsystems is offline
 

Veteran
  
Join Date: Apr 2007
Posts: 13,940
 

Default Re: Webgility X Cart 5 and PHP 7.4

I have a client with 2 stores - one is on php 7.2 and the other on php 7.3 (want to move them to 7.4). The module works on the php 7.2 site (of course mcrypt is installed there) and does not work on the php 7.3 site (no mcrypt there).
From my experience and looking at the sites and the module code it is my understanding the reason is mcrypt. However this is what they told the client


Quote:
we are using both the auth method mcrypt and OpenSSL
for the server connection. So there is no issue with mcrypt Require. We
still have mcrypt in our code just for customers who are
still using the old version of PHP and We still have OpenSSL in
our code just for customers who are still using the latest version
of PHP so store URL working fine but we are getting script error
in-store connection and I have also mention script error on my
previous note.So please get in touch with your developer to get it fixed".



However I don't buy this because the module check fails with an error if mcrypt is not installed and as soon as I downgraded the php version to 7.2 it started working. Then I changed it back and waiting for confirmation from the client if it still works or not.


The client is looking for alternatives as well.
__________________
Steve Stoyanov
CFLSystems.com
Web Development
Reply With Quote