X-Cart: shopping cart software

X-Cart forums (https://forum.x-cart.com/index.php)
-   X-Payments issues & questions (https://forum.x-cart.com/forumdisplay.php?f=50)
-   -   OpenSSL Issue with X-Payments Connector (https://forum.x-cart.com/showthread.php?t=66761)

abbieroad 05-02-2013 02:32 PM

OpenSSL Issue with X-Payments Connector
 
We have just signed up for X-Payments and attempting to set up the X-Payments Connector in our x-cart to connect to the X-payments system. On the X-Payments configuration page, we get an error at the top of the page:

Failed to meet environment requirements

PHP extension OpenSSL is not installed on your server.

However, OpenSSL is installed, and verified by our host technicians:

root@srv [~]# php -m
[PHP Modules]
bcmath
calendar
ctype
curl
date
dom
eAccelerator
filter
ftp
gd
hash
iconv
imap
ionCube Loader
json
libxml
mysql
mysqli
openssl
pcre
posix
Reflection
session
SimpleXML
soap
sockets
SPL
SQLite
standard
tokenizer
xml
xmlreader
xmlwriter
Zend Optimizer
zlib

[Zend Modules]
Zend Optimizer
the ionCube PHP Loader

root@srv [~]# rpm -qa | grep openssl
openssl096b-0.9.6b-22.46.el4_8.1
xmlsec1-openssl-1.2.6-3.1
openssl-0.9.7a-43.18.el4
openssl-devel-0.9.7a-43.18.el4
root@srv [~]# which openssl
/usr/bin/openssl


Any idea what I might be missing or why X-cart is not recognizing the OpenSSL?


All times are GMT -8. The time now is 03:54 AM.

Powered by vBulletin Version 3.5.4
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.