X-Cart: shopping cart software

X-Cart forums (https://forum.x-cart.com/index.php)
-   X-Payments issues & questions (https://forum.x-cart.com/forumdisplay.php?f=50)
-   -   X-Payments 1.0.6 works with XC 4.5.4 (https://forum.x-cart.com/showthread.php?t=66346)

carpeperdiem 03-09-2013 06:00 AM

X-Payments 1.0.6 works with XC 4.5.4
 
I have successfully tested X-Payments 1.0.6 with X-Cart 4.5.4
I don't know why it was said that 4.5.5 was REQUIRED to use XP 1.0.6?

There appears to be two APIs (1.1, 1.2) and xc 4.5.4, it uses the "API 1.1 version is supported"

In practical use, there appears to be no difference to the 4.5.4 store to use X-P 1.0.6 (vs. 1.0.5)

I now have 1.0.6/4.5.4 provisioned with an iFrame using Altered Cart's X-Payments Connector For Checkout One and it's a SIGNIFICANT improvement over the stock code. But that's the subject of a new thread.

Just wanted to let everyone know that it's OK to use 1.0.6 w/ 4.5.4 and if your goal is improved iFrame support using Checkout_One and the C1 connector, this is the way to do it without "upgrading" to 4.5.5

PS -- if you start using a new XP version, make certain you run cleanup.php on your 4.5.4 store before you run a test transaction. (I didn't and received 403 errors on the transaction callback - after running cleanup.php, everything is perfect!)

J

ambal 03-10-2013 11:18 PM

Re: X-Payments 1.0.6 works with XC 4.5.4
 
Thank you, Jeremy, for sharing this information. We didn't test with the AlteredOne's mod and didn't know it allows XC 4.5.4 to work with iFrame provided by XP 1.0.6.

carpeperdiem 03-11-2013 12:06 AM

Re: X-Payments 1.0.6 works with XC 4.5.4
 
Quote:

Originally Posted by ambal
Thank you, Jeremy, for sharing this information. We didn't test with the AlteredOne's mod and didn't know it allows XC 4.5.4 to work with iFrame provided by XP 1.0.6.


Alex,

Let me clarify.

The iFrame provided by XP 1.0.6 is a very specific css made by Altered Cart.
To use this with X-Cart (I am using it with 4.5.4), you need to use the Altered Cart's X-Payments Connector For Checkout One. This is used IN ADDITION TO the stock XPC.

1. Deploy XP 1.0.6 in XC 4.5.4 using the stock XPC module, test. (this works fine)
2. in XP, assign the template to be used: checkout_one
3. in XCart, use the Altered Cart Checkout One module, enable iFrame.

This works exactly as needed. The order does not "process" until credit card is authorized.

It does not circumvent X-Payments in any way -- it is simply a much smarter way for X-Cart to operate.

This is how the stock XPC should have always worked.

My point about compatibility - I was under the impression that XP 1.0.6 required XC 4.5.5, but that does not appear to be the case. I am using XP 1.0.6 with XC 4.5.4 and it configured just fine. I tested this BEFORE using the Altered Cart code.

Hopefully, someone else with 4.5.4 can also install XP 1.0.6 and verify this.

ambal 03-11-2013 11:20 PM

Re: X-Payments 1.0.6 works with XC 4.5.4
 
Jeremy, I checked this and it looks like you are talking about "old lite interface" - it does work with 4.5.4 & 1.0.6 but it is the old one, not the new one. The improved iFrame integration works only in 4.5.5 & 1.0.6

I'll add a table of versions vs interface in our Knowledge base for better understanding.

ambal 03-12-2013 01:01 AM

Re: X-Payments 1.0.6 works with XC 4.5.4
 
Here is the table

http://help.x-cart.com/index.php?title=X-Cart:IFrame_integration_for_X-Payments_%26_X-Cart_checkout_routines

carpeperdiem 03-12-2013 05:19 AM

Re: X-Payments 1.0.6 works with XC 4.5.4
 
Alex,

Yes -- the "lite" interface was not tested (and I believe will not work) with 4.5.4 and XP 1.0.6, but the "default" template was, and it works fine.

As I stated above, 1.0.6 with the Altered Cart CheckoutOne XPC module also works fine with 4.5.4, and this DOES solve the iFrame issue for 4.5.4 carts without forcing us to upgrade to 4.5.5

The Altered Cart solution solves the iFrame issue and also solves the "not finished" order issue. Best $50 a store using Checkout One can invest.

J

carpeperdiem 03-12-2013 05:20 AM

Re: X-Payments 1.0.6 works with XC 4.5.4
 
Quote:

Originally Posted by ambal
I checked this and it looks like you are talking about "old lite interface"


No, please see above.


All times are GMT -8. The time now is 01:21 AM.

Powered by vBulletin Version 3.5.4
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.