X-Cart: shopping cart software

X-Cart forums (https://forum.x-cart.com/index.php)
-   General talk (https://forum.x-cart.com/forumdisplay.php?f=29)
-   -   Upgrade your store (https://forum.x-cart.com/showthread.php?t=38953)

Emerson 04-10-2008 07:26 AM

Upgrade your store
 
Hi Guys,

We have all been hearing about upgrading to PHP5 for a while now and as it stood we were ok until the end of the year.
We here at EWD started rolling out PHP5/MySQL5 servers last couple of weeks and it has come at a good time.

We have learned today that HackerGuardian is now marking PHP4 as non-PCI compliant so if that sticks all must upgrade.

What this means for you?
Basically if you are running x-cart older then 4.1 and do not upgrade you will be in trouble.

So anyone holding out upgrading their store(or any other php script that will not run on PHP5) now is the time to upgrade.

This also applies to MySQL.

balinor 04-10-2008 07:30 AM

Re: Upgrade your store
 
That is going to cost a LOT of people a LOT of money.....

Sure would be nice if Qualiteam would release an official patch to make 4.0 compatible with MySQL and PHP 5.

Emerson 04-10-2008 07:31 AM

Re: Upgrade your store
 
Sure is :(

Wish x-cart could come up with a solution that would make older versions compatible with php/mysql 5

Emerson 04-10-2008 07:32 AM

Re: Upgrade your store
 
haha
great minds, heh? lol

balinor 04-10-2008 07:35 AM

Re: Upgrade your store
 
There are some hacks in the forum here, but they are not 'official' and would really like a fully tested, fully debugged solution that I can easily implement for my clients that won't cost them $1000 in upgrade fees. I can't possibly upgrade all of them for free, as I would lose my shirt. You may get a mass migration of my hosted X-Cart clients if we can't find a solution ;)

pauldodman 04-10-2008 08:39 AM

Re: Upgrade your store
 
But doesn't x-cart 4.0 work with PHP4?
I thought it was just 3.x that didn't?

balinor 04-10-2008 08:40 AM

Re: Upgrade your store
 
4.0 does not run on MySQL 5. PHP/MySQL 4 are fine, but Emerson is saying that servers running anything prior to 5 will be considered non-compliant.

Emerson 04-10-2008 08:45 AM

Re: Upgrade your store
 
Right. And PHP4 is marked EOL(end of life) as Aug. 8, 2008 - That's 4 months from now.
After that date if any vulnerabilities are found in PHP4 they will not be patched by the PHP developers.

pauldodman 04-10-2008 09:04 AM

Re: Upgrade your store
 
Sure, but shop owners are thinking that if they don't upgrade their 4.0 sites by the end of the year, they are simply going to stop working just because php4 is "end of life" or the server is upgraded to php5 - which of course isn't the case, is it?

Emerson 04-10-2008 09:16 AM

Re: Upgrade your store
 
Quote:

Originally Posted by pauldodman
Sure, but shop owners are thinking that if they don't upgrade their 4.0 sites by the end of the year, they are simply going to stop working just because php4 is "end of life" or the server is upgraded to php5 - which of course isn't the case, is it?


Yes, that is the case.
Anyone with shops older then 4.1 are in trouble if hosts are forced to upgrade to PHP/MYSQL 5


All times are GMT -8. The time now is 03:49 PM.

Powered by vBulletin Version 3.5.4
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.