X-Cart: shopping cart software

X-Cart forums (https://forum.x-cart.com/index.php)
-   Third Party Add-Ons for X-Cart 4 (https://forum.x-cart.com/forumdisplay.php?f=45)
-   -   Module compatibility with minor versions (https://forum.x-cart.com/showthread.php?t=78343)

vasilis 12-29-2021 11:01 PM

Module compatibility with minor versions
 
I have been working on a module for X-Cart Classic for versions 4.4.x to 4.7.x. and I have created module distribution packs with installation script. The distribution packs' code is based on the last version of each branch, ie, based on the code of versions 4.4.5 (Gold/Pro), 4.5.5 (Gold/Platinum), 4.6.6 (Gold/Platinum) and 4.7.12 (Gold/Platinum).

I have noticed though that there are some code differences between the last minor versions in a branch and some of the lower minor versions, for example, there are code differences between 4.7.12 and 4.7.5 versions and when I use the installation script of the 4.7.12 distribution pack in a 4.7.5 site, some 4.7.5 files cannot be patched via the installation procedure - they have to be patched manually. So, the distribution pack does not work for all previous minor versions in the branch.

So, I guess, I will have to create a distribution pack for each single minor version in each branch that differs from the last version, and I understand that this is a heck of a lot of extra work.

The other alternative is to leave it like that, ie, with the distribution packs being compatible only with the last minor versions (and maybe with a couple of previous minor versions, depending on their code similarity).

The last alternative would be ok if the majority of X-Cart-Classic sites out there had already upgraded to the last minor version of each branch, but is this the case?

I would appreciate any input on these thoughts.

ITVV 12-30-2021 12:51 AM

Re: Module compatibility with minor versions
 
@vasillis
Quote:

The other alternative is to leave it like that, ie, with the distribution packs being compatible only with the last minor versions (and maybe with a couple of previous minor versions, depending on their code similarity).
I think you would be OK with the above option. If people have not bothered upgrading to the latest version of there branch they are clearly not interested in maintaining there ecommerce solution.

Just my two cents

Kind regards

ITVV


All times are GMT -8. The time now is 09:02 PM.

Powered by vBulletin Version 3.5.4
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.