X-Cart: shopping cart software

X-Cart forums (https://forum.x-cart.com/index.php)
-   General talk (https://forum.x-cart.com/forumdisplay.php?f=29)
-   -   Upgrade your store (https://forum.x-cart.com/showthread.php?t=38953)

Emerson 04-10-2008 07:26 AM

Upgrade your store
 
Hi Guys,

We have all been hearing about upgrading to PHP5 for a while now and as it stood we were ok until the end of the year.
We here at EWD started rolling out PHP5/MySQL5 servers last couple of weeks and it has come at a good time.

We have learned today that HackerGuardian is now marking PHP4 as non-PCI compliant so if that sticks all must upgrade.

What this means for you?
Basically if you are running x-cart older then 4.1 and do not upgrade you will be in trouble.

So anyone holding out upgrading their store(or any other php script that will not run on PHP5) now is the time to upgrade.

This also applies to MySQL.

balinor 04-10-2008 07:30 AM

Re: Upgrade your store
 
That is going to cost a LOT of people a LOT of money.....

Sure would be nice if Qualiteam would release an official patch to make 4.0 compatible with MySQL and PHP 5.

Emerson 04-10-2008 07:31 AM

Re: Upgrade your store
 
Sure is :(

Wish x-cart could come up with a solution that would make older versions compatible with php/mysql 5

Emerson 04-10-2008 07:32 AM

Re: Upgrade your store
 
haha
great minds, heh? lol

balinor 04-10-2008 07:35 AM

Re: Upgrade your store
 
There are some hacks in the forum here, but they are not 'official' and would really like a fully tested, fully debugged solution that I can easily implement for my clients that won't cost them $1000 in upgrade fees. I can't possibly upgrade all of them for free, as I would lose my shirt. You may get a mass migration of my hosted X-Cart clients if we can't find a solution ;)

pauldodman 04-10-2008 08:39 AM

Re: Upgrade your store
 
But doesn't x-cart 4.0 work with PHP4?
I thought it was just 3.x that didn't?

balinor 04-10-2008 08:40 AM

Re: Upgrade your store
 
4.0 does not run on MySQL 5. PHP/MySQL 4 are fine, but Emerson is saying that servers running anything prior to 5 will be considered non-compliant.

Emerson 04-10-2008 08:45 AM

Re: Upgrade your store
 
Right. And PHP4 is marked EOL(end of life) as Aug. 8, 2008 - That's 4 months from now.
After that date if any vulnerabilities are found in PHP4 they will not be patched by the PHP developers.

pauldodman 04-10-2008 09:04 AM

Re: Upgrade your store
 
Sure, but shop owners are thinking that if they don't upgrade their 4.0 sites by the end of the year, they are simply going to stop working just because php4 is "end of life" or the server is upgraded to php5 - which of course isn't the case, is it?

Emerson 04-10-2008 09:16 AM

Re: Upgrade your store
 
Quote:

Originally Posted by pauldodman
Sure, but shop owners are thinking that if they don't upgrade their 4.0 sites by the end of the year, they are simply going to stop working just because php4 is "end of life" or the server is upgraded to php5 - which of course isn't the case, is it?


Yes, that is the case.
Anyone with shops older then 4.1 are in trouble if hosts are forced to upgrade to PHP/MYSQL 5

balinor 04-10-2008 09:46 AM

Re: Upgrade your store
 
We are going to have to upgrade our servers because most of our clients are going to have to be PCI compliant.

Emerson 04-10-2008 09:51 AM

Re: Upgrade your store
 
I am going to hold out as much as I can.
Will move customers that need(and are ready) to PHP/MySQL 5 and keep the others at 4 as long as I can.

balinor 04-10-2008 11:16 AM

Re: Upgrade your store
 
I see you just notified your clients by the 100 panicked e-mails I just received :)

Emerson 04-10-2008 11:19 AM

Re: Upgrade your store
 
Yes I just sent out a mass mail informing everyone.
Rather do it now and give everyone time to take care of things.

johnrobholmes 04-10-2008 11:36 AM

Re: Upgrade your store
 
I hope you guys can figure out a way to get a patch for guys running 4.0, otherwise I may just swap out to another cart to avoid spending more money.


Kudos to Emerson for keeping us informed, I'm very glad I use you and will recommend to all of my friends.

intel352 04-10-2008 12:00 PM

Re: Upgrade your store
 
Could establish a combined effort to create the necessary patches for X-Cart 4.0.x, and have a variety of "pros" test patched carts on PHP/MySQL 5

Really, as mentioned, there are already patches in existence in the forum. Could just take those existing patches, make sure they're compatible with 4.0.x, and test the heck outta them, and I'm sure there are users that would much rather take some time to test, rather than having to pay hundreds of $$ for upgrades.

balinor 04-10-2008 12:08 PM

Re: Upgrade your store
 
Quote:

another cart to avoid spending more money

That will cost you more than upgrading, so that is not a solution.

If a team of developers could tackle the issue and get X-Cart 4.x to run on PHP/MySQL 5, it would certainly save everyone a lot of time, money and headaches.

Emerson 04-10-2008 12:19 PM

Re: Upgrade your store
 
Quote:

Originally Posted by balinor
That will cost you more than upgrading, so that is not a solution.

If a team of developers could tackle the issue and get X-Cart 4.x to run on PHP/MySQL 5, it would certainly save everyone a lot of time, money and headaches.


This would be nice and I assume people would donate to the cause to help with everyone's time put into it.
I would definetely throw some $ in.

balinor 04-10-2008 12:27 PM

Re: Upgrade your store
 
I'd chip in as much as necessary to get it done, and done right. I do not relish the thought of upgrading 100 carts....

david_ygao 04-10-2008 12:28 PM

Re: Upgrade your store
 
In X-cart reference manual (Version: March 19, 2006):
Minimal system requirements
╖ PHP 4.0.6 or later (PHP 5 is also supported).


So it means X-cart 4.0.18 can be supported in PHP 5 server ?

Are you sure X-car 4.0.18 store will not work in PHP 5 server ?

balinor 04-10-2008 12:31 PM

Re: Upgrade your store
 
MySQL is the issue, and correct me if I am wrong Emerson, but don't you need MySQL 5 if you are running PHP 5?

intel352 04-10-2008 12:33 PM

Re: Upgrade your store
 
Hi David, they're saying that along with the PHP 5 upgrade, MySQL 5 is going to be upgraded as well. X-Cart 4.0.x has issues with MySQL 5. it's more of a MySQL issue than a PHP issue


Padraic/Emerson, unless someone else takes care of it first, I'll look through the proposed fixes in the forum, make sure it applies to all area of X-Cart 4.0, make sure it's in a Patch form, and upload the patch for testers to have a go at it. If one of you guys would be interested in coordinating this, gathering some willing testers, etc, that'd be great.

Emerson 04-10-2008 12:34 PM

Re: Upgrade your store
 
Yes, both php and mysql would be upgraded to 5

So the issue is on both ends.

Emerson 04-10-2008 12:39 PM

Re: Upgrade your store
 
And to be clear. Both PHP4 and MySQL 4 are EOL

PHP4 EOL is 08/08/08
MySQL 4 EOL is 12/31/08

Emerson 04-10-2008 12:42 PM

Re: Upgrade your store
 
Quote:

Originally Posted by intel352
Padraic/Emerson, unless someone else takes care of it first, I'll look through the proposed fixes in the forum, make sure it applies to all area of X-Cart 4.0, make sure it's in a Patch form, and upload the patch for testers to have a go at it. If one of you guys would be interested in coordinating this, gathering some willing testers, etc, that'd be great.


I am spreading the word out.
If you want let me know and I can setup a server as a test bed.

balinor 04-10-2008 12:48 PM

Re: Upgrade your store
 
That would be great...just get some stock 4.0 carts in various versions set up (after .14 when it was considered "stable") or even some copies of customized ones with lots of mods.

johnrobholmes 04-10-2008 01:15 PM

Re: Upgrade your store
 
I just did some research on what it would take to migrate to another cart, and you are right balinor. It would be more expensive (in time too) to swap out. I don't quite trust carts that don't have something to profit from. Capitalism goes a long way in making sure there are no bugs before a release.


Waiting to hear what I will need to do to stay a viable store. Maybe upgrading to version 4.1 will give me added benefits too?

balinor 04-10-2008 01:17 PM

Re: Upgrade your store
 
To be fair John, there is no way X-Cart could have anticipated what would be required for PHP/MySQL 5 when they first released 4.0, so I wouldn't call it a 'bug'. I do, however, agree that they should have taken the time to release a patch once they realized this would be an issue.

Upgrading to 4.1 does have quite a number of benefits, but you need to weigh those against the cost of doing it. If there aren't specific features you need, it may not be worth the headache and expense.

intel352 04-10-2008 01:28 PM

Re: Upgrade your store
 
4.1 definitely has added benefits, in terms of security, new modules, speed, etc, plus shortening your future upgrade curve.

regarding carts that don't have something to profit, that's a valid business model nowadays actually, as people have found that it's often better to reel someone in with a free product, and make money off of services. in X-Cart's case, they reel people in with a fairly inexpensive product, and make money off of it not being a 100% comprehensive solution :-)



btw, Padraic is correct about headache/expense. 4.0 to 4.1 doesn't have a template/file upgrade, just a db upgrade, so essentially you have to start from scratch with a 4.1 install, and re-implement any customizations

johnrobholmes 04-10-2008 03:37 PM

Re: Upgrade your store
 
I really haven't customized my site at all beyond tweaking the template a bit. I have zero added features beyond what X-Cart supplied me with. Check out the site in my link, pretty basic.


I wan't calling the php upgrade a bug, I was referencing some other cart's that have known issues of security with the download.

Jerrad 04-11-2008 04:41 AM

Re: Upgrade your store
 
Quote:

Originally Posted by Emerson
This would be nice and I assume people would donate to the cause to help with everyone's time put into it.
I would definetely throw some $ in.


Count me in - I definetely would also throw some ─ in to prevent a forced upgrade to 4.1.x!!

just_me 04-11-2008 06:44 AM

Re: Upgrade your store
 
Well, this is it then, upgrade from 4.0.19 to 4.1.x has just become a necesity.
A nice weekend project, lol. Let's hope it goes without too many bugs.

balinor 04-11-2008 09:44 AM

Re: Upgrade your store
 
That's what we are trying to say here, it ISN'T a necessity, we are going to come up with a way to run X-Cart 4.0 on a MySQL 5 server. Upgrading a highly customized store is something not many people want to be forced to do.

pauldodman 04-11-2008 10:14 AM

Re: Upgrade your store
 
Also, I think it's important that xcart 4.0 users not on Emerson's servers should consider their situation. Emerson has given his customers plenty of prior warning that he is eventually going to have to upgrade his servers. But other hosts may not upgrade their servers, so the shops will still run - however, what is more likely is that hosts, particulary none x-cart approved hosts, will suddenly do this upgrade to php5/mysql 5 with little or no prior warning - giving little time to upgrade x-cart and suddenly people will have no shops.
It is worth people checking with their hosts what their plans are.

ranger82nd 04-11-2008 10:21 AM

Re: Upgrade your store
 
Although I am currently in the process of upgrading anyway, I would still be very interested in helping/contributing to this project.
Let me know...

Emerson 04-11-2008 10:28 AM

Re: Upgrade your store
 
Quote:

Originally Posted by pauldodman
Also, I think it's important that xcart 4.0 users not on Emerson's servers should consider their situation. Emerson has given his customers plenty of prior warning that he is eventually going to have to upgrade his servers. But other hosts may not upgrade their servers, so the shops will still run - however, what is more likely is that hosts, particulary none x-cart approved hosts, will suddenly do this upgrade to php5/mysql 5 with little or no prior warning - giving little time to upgrade x-cart and suddenly people will have no shops.
It is worth people checking with their hosts what their plans are.


Very good point Paul

This is not isolated to EWD. ALL hosts are going to have to upgrade this year.

exsecror 04-11-2008 10:56 AM

Re: Upgrade your store
 
We've always ran on PHP5 (with the exception of our development box that runs PHP6 but I won't go into that fun little mess). I stopped supporting PHP4 when PHP 5.1.0 was considered production stable.

Jerrad 04-11-2008 11:18 AM

Re: Upgrade your store
 
Quote:

Originally Posted by pauldodman
Also, I think it's important that xcart 4.0 users not on Emerson's servers should consider their situation. Emerson has given his customers plenty of prior warning that he is eventually going to have to upgrade his servers. But other hosts may not upgrade their servers, so the shops will still run - however, what is more likely is that hosts, particulary none x-cart approved hosts, will suddenly do this upgrade to php5/mysql 5 with little or no prior warning - giving little time to upgrade x-cart and suddenly people will have no shops.
It is worth people checking with their hosts what their plans are.


I informed this morning with our host and they going to upgrade in a few months to php5/mysql5.
But after the upgrade we can choose if we want to use php4 or php5.
Unfortunately that isn't the case with mysql - they are going to upgrade everybody to mysql 5... :?

exsecror 04-11-2008 12:01 PM

Re: Upgrade your store
 
Quote:

Originally Posted by Jerrad
I informed this morning with our host and they going to upgrade in a few months to php5/mysql5.
But after the upgrade we can choose if we want to use php4 or php5.
Unfortunately that isn't the case with mysql - they are going to upgrade everybody to mysql 5... :?


Makes sense, MySQL 4.1 is considered old production now by MySQL AB with 5.0 considered current production and 5.1 development and 6.0 at alpha

donmck 04-11-2008 02:03 PM

Re: Upgrade your store
 
I was going to direct these questions at Emerson (EWDhosting.com) via his normal support system, but felt it may be better if I added it to this thread, as it may save Emerson answering the same questions over and over, and possibly others will benefit, that are with other hosting services, and in the same position.

It is to do with servers.
The way I understand it:
V4.0.x = php4/mysql4
V4.1.x = php5/mysql5
Correct?

Can you run php4/mysql4 and php5/mysql5 on the same server?
If I upgraded from my 4.0.17 to 4.1.x, would I have to shift servers at this point of time?

Or let me put it another way, If the productive members of this thread are able to come up with suitable patches to enable V4.0.x = php5/mysql5, then would I have to move to a new server at the time the patches were done?

I must admit, when I got Emerson's message yesterday, I went into a cold sweat, and felt rather ill for a while. At 65, perhaps I am getting too old to handle this. I had hoped that the version I got less than 2 years ago, would give me a bit more mileage.

I too am prepared to contribute funds to assist this project. I am also very open to alternatives if I can find someone who can do a version upgrade to a modified site, in a reasonable time.

And thanks Padraic for making me aware of this thread, and possible resolution.

Cheers Don...


All times are GMT -8. The time now is 07:39 PM.

Powered by vBulletin Version 3.5.4
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.