X-Cart: shopping cart software

X-Cart forums (https://forum.x-cart.com/index.php)
-   General talk (https://forum.x-cart.com/forumdisplay.php?f=29)
-   -   Upgrade your store (https://forum.x-cart.com/showthread.php?t=38953)

candyman 04-11-2008 02:39 PM

Re: Upgrade your store
 
This news really has me worried, was not expecting to have to upgrade this program every few years.

If I install the newest Xcart and Affiliate Manager ect. I am going to lose all my affilates and data am I correct?

I really feel bad for the web hosts, I really think their older x-cart clients are going to bail once these changes come into effect.

balinor 04-11-2008 04:16 PM

Re: Upgrade your store
 
Again, we are working on a patch to PREVENT you from having to upgrade. Don't panic, just be patient :)

Sutekh 04-11-2008 08:48 PM

Re: Upgrade your store
 
Quote:

Originally Posted by ygao@glztech.com
So it means X-cart 4.0.18 can be supported in PHP 5 server ? Are you sure X-car 4.0.18 store will not work in PHP 5 server ?


Hi

I have been running everything on a dev unit under PHP 5.0 / 5.1 / 5.2 without any problems at all. However I don't remember if we changed any of the code significantly to work with this PHP profile.

I'm upgrading to MySQL 5.1 on the dev unit and will keep you posted on any problems. Other than JOIN structures I couldn't really see much to be worried about.

Also upgrading to MySQL 6 has enormous benefits as the team has improved the SQL optimizer and also introduced the FALCON engine which makes transactional stuff much faster than their previous effort.


Cheers
Scott

herbj 04-12-2008 04:14 AM

Re: Upgrade your store
 
Quote:

Originally Posted by balinor
Again, we are working on a patch to PREVENT you from having to upgrade. Don't panic, just be patient :)



I was also concerned when the upgrade email hit my box from EWD. I am more than willing to be patient and hope for a fix.

The reality of the upgrade is at some point we need to draw a line in the sand and say we are or are not going to make it with a patch so those of us running the 4.0 branch don't get caught without enough time to upgrade.

If you gurus can put it together and decide on who is going to develop the patch and get behind them, I am willing to contribute some $ and testing if I can to move it along.

Last thing I would want is a 200 + post thread that we all would have to decipher to install the patch.

Many thanks to the hard work and response from the core contributors who stay on top of this stuff....

balinor 04-12-2008 09:47 AM

Re: Upgrade your store
 
Ok, here's what I suggest:

1. Emerson - can you set up a test environment with a stock 4.0.19 store on a PHP/MySQL 5 server? We can get that working first, as it is the last release of that branch. We can then try some older stores as well, but nothing prior to 4.0.14 as that was the first 'officially stable' release. If someone is running a version prior to that, they can either try the patch or upgrade to the stable release, but it isn't worth trying to debug a release that is already riddled with bugs. I'd almost say anything prior to 4.0.18 was problematic.

2. Jon L - you had suggested you would be interested in tackling this - can you commit to having it done by April 30th? If not, I'll contract this out myself to another developer, as we can't procrastinate on this one. Emerson may be willing to wait until August, but I'm sure other hosts will not and I'd like to start on the 50 clients I'll need to patch this for.

If you guys can both reply so we can get the ball rolling that would be great.

intel352 04-12-2008 10:23 AM

Re: Upgrade your store
 
I'll have it done before April 30th.

BTW, the people that keep saying they were hoping to never have to upgrade (or haven't touched an upgrade in 2 years), I just want to suggest that it's never beneficial to let important software that manages your clients, orders, etc, to go out of date. It's always better to stay up to date, for features, security, performance, etc.

Emerson did some testing last night, found X-Cart 3.x operated fine on MySQL 5. The likely reason is 3.x probably doesn't use JOINS (or doesn't use them often).

Additionally, yes, the issue with MySQL is with the JOIN structure in queries. Again, it's not a big issue in terms of work required to fix it. As patches in the forum have demonstrated, it's a fairly easy fix from a programmer standpoint.

Someone asked about PHP/MySQL4 and PHP/MySQL5. You *can* mix and match the software, so that it's PHP5/MySQL4. But the point is that MySQL 4 support is ending as well (just a couple of months later). The focus here isn't so much on the PHP upgrade issue, more-so on the MySQL upgrade issue, and *only* for queries that have a non-SQL compliant JOIN structure.

Anywho, I'm communicating with Emerson on this, we'll have a tested solution before long.

Oh, and Padraic, I personally feel that only 4.0.18 & 4.0.19 should be specifically supported with the patch, as it should be discouraged for users to stay so far behind on the upgrade curve. Likely the patch will work fine on earlier versions, but the supported/recommended versions should be the recent release(s).

balinor 04-12-2008 10:45 AM

Re: Upgrade your store
 
Agree with you 100% on the 4.0.18 and .19 point. Trying to debug the versions prior to that will just be a major headache. I will say that I left many of my clients on .18 specifically because of the speed issue with .19, so covering those two should be more than enough.

Jerrad 04-12-2008 11:03 AM

Re: Upgrade your store
 
Are the older versions much different from 4.0.18 that they need a different approach for the php/mysql 5 upgrade?

And please let me know if I can help with a donation...

Emerson 04-12-2008 12:53 PM

Re: Upgrade your store
 
Yes I did some tests last night and see that earlier 3.x versions did not have an issue with php/mysql 5. As you get to 3.5.13 and .14 you get issues as the JOINS were introduced(I am assuming?)
This should not be a big issue to resolve. I have heard from a client that qualiteam will make her 3.5.14 shop compatible with mysql 5 for 40 support points so it can't be a big deal.

I have tested quickly the patches available in this forum and have a shop running 4.0.19 running ok under php/mysql5.

Tonight I will be testing version by version(from 4.0.14 UP) and we'll see how it works out.

Jon L and I will be working closely on this to get it resolved.


One thing that might come to play are the heavily moded shops. If the addons/modifications are not compatible then that will be an issue.
I can't see it being a big deal on stock/lightly moded shops however.

bespoke kid 04-14-2008 12:14 PM

Re: Upgrade your store
 
hi, we're on ewd servers with x-cart gold Version 4.0.11 are there any single upgrades to 4.1.1.9 gold or do we have to do all those incremental upgrades ?
thanks
Bespoke kid


All times are GMT -8. The time now is 07:48 PM.

Powered by vBulletin Version 3.5.4
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.