X-Cart: shopping cart software

X-Cart forums (https://forum.x-cart.com/index.php)
-   News and Announcements (https://forum.x-cart.com/forumdisplay.php?f=28)
-   -   4.1.9 changelog (https://forum.x-cart.com/showthread.php?t=34477)

Light Speed 10-10-2007 12:56 AM

Re: 4.1.9 changelog
 
Upgrade Pack?

josu 10-10-2007 07:40 AM

Re: 4.1.9 changelog
 
Not upgrade pack from 4.1.8?

aslater 10-10-2007 09:26 AM

Re: 4.1.9 changelog
 
So where are the upgrade packs for 4.1.9 it only has 4.1.8

timbrrr 10-10-2007 10:16 AM

Re: 4.1.9 changelog
 
Sometimes it takes awhile for them to get the upgrade packs into everyone's download area. Theres always the possibility that they aren't quite finished with it either, only the core. Either way, it'll show. :)

byronm 10-10-2007 01:06 PM

Re: 4.1.9 changelog
 
I'll wait for the upgrade packs.. with all those fixes & updates though i am a bit anxious to get them applied though ;)

murlyn28 10-11-2007 09:54 AM

Re: 4.1.9 changelog
 
I've found two apparent errors in the upgrade pack.

#1 the file include/admin_security.php was not copied into the /include/ directory
#2 the func_version_compare logic in /modules/magnifier/config.php was reversed it read:

(func_version_compare($config["version"], "4.1.9") < 0 ? "N" : "Y");

should be: (func_version_compare($config["version"], "4.1.9") < 0 ? "Y" : "N");

or at least that was the only way I could get the Magnifier module to work.

byronm 10-11-2007 09:59 AM

Re: 4.1.9 changelog
 
Quote:

Originally Posted by matrixa59
I have applied the update but am now getting this error.

INVALID SQL: 1146 : Table 'lingerieexpress2.xcart_session_history' doesn't exist
SQL QUERY FAILURE:SELECT xid FROM xcart_session_history WHERE ip = '81.156.180.168' AND host = 'www.lingerieexpress.co.uk'
INVALID SQL: 1146 : Table 'lingerieexpress2.xcart_session_history' doesn't exist
SQL QUERY FAILURE:SHOW FIELDS FROM xcart_session_history


Please help i get this everynow and can not log into the back end


Sounds like the patch.sql file didn't run.

byronm 10-11-2007 10:26 AM

Re: 4.1.9 changelog
 
I don't use the magnifier module so i can't speak on that. However my admin site says 4.1.8 still as well and i had to manually apply the patch.sql because it gave the DB error before finishing step 2.

byronm 10-11-2007 10:39 AM

Re: 4.1.9 changelog
 
Quote:

Originally Posted by matrixa59
Was it the same sql erorrs i got in my first post?


yeah, i got the same sql errors substitute my site name and database name. Infact i can't get to step two because the validation takes so long on my server that i get this error. Basically it sayd patch applied on everything, click apply (shows step one) but it kicks me out because the process to verify the patch took to long.

"The form could not be identified as a form generated by X-Cart. The reason may be that a substantial period of time has elapsed, or more than 100 pages have been opened since you opened the page with this form. If you did not open the page with this form, you might be under a CSRF attack."

jillsybte 10-11-2007 09:17 PM

Re: 4.1.9 changelog
 
Quote:

Originally Posted by matrixa59
also a major security issue - I went to place a dummy order on the store and noticed the site did not redirect to HTTPS when checking out with PayPal Pro. this is set to HTTPS in admin.


Other than the HTTPS problem, did you have any other problems checking out with PayPal Pro? I was using/testing 4.1.8 for the past few weeks and had several successful orders using PayPal Pro in Test Mode (both with Express and with Credit Card).

I did a fresh install of 4.1.9 and applied all the changes I had applied to 4.1.8. These were mainly appearance-related plus some BCS Eng. mods (shipping estimator, customer review management, catalog order form, and shipping per product). Now I can't get any orders to go through PayPal Pro. I've tried Express and Credit Card and I keep getting an order declined error due to a duplicate invoice number.

I definitely didn't mess with any of the payment-related scripts/templates. I just worked my butt off for the past 2 days getting 4.1.9 to the same point I had had 4.1.8. I'm logged into PayPal Sandbox like I'm supposed to be. I don't know what the problem could be, but I can't imagine it's related to the changes I've made.

Is anyone else using 4.1.9 with PayPal Pro? I'm desperate for assistance here as I would like to get my store launched. I need to sleep now, but if no one has any ideas, I guess I'll have to try doing a default install with just the PayPal Pro setup done and try test orders with that. If that doesn't work, I'll have to go back to 4.1.8.

Thanks,
Jill


All times are GMT -8. The time now is 08:30 PM.

Powered by vBulletin Version 3.5.4
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.