X-Cart: shopping cart software

X-Cart forums (https://forum.x-cart.com/index.php)
-   General talk (https://forum.x-cart.com/forumdisplay.php?f=29)
-   -   Upgrade your store (https://forum.x-cart.com/showthread.php?t=38953)

balinor 04-10-2008 12:31 PM

Re: Upgrade your store
 
MySQL is the issue, and correct me if I am wrong Emerson, but don't you need MySQL 5 if you are running PHP 5?

intel352 04-10-2008 12:33 PM

Re: Upgrade your store
 
Hi David, they're saying that along with the PHP 5 upgrade, MySQL 5 is going to be upgraded as well. X-Cart 4.0.x has issues with MySQL 5. it's more of a MySQL issue than a PHP issue


Padraic/Emerson, unless someone else takes care of it first, I'll look through the proposed fixes in the forum, make sure it applies to all area of X-Cart 4.0, make sure it's in a Patch form, and upload the patch for testers to have a go at it. If one of you guys would be interested in coordinating this, gathering some willing testers, etc, that'd be great.

Emerson 04-10-2008 12:34 PM

Re: Upgrade your store
 
Yes, both php and mysql would be upgraded to 5

So the issue is on both ends.

Emerson 04-10-2008 12:39 PM

Re: Upgrade your store
 
And to be clear. Both PHP4 and MySQL 4 are EOL

PHP4 EOL is 08/08/08
MySQL 4 EOL is 12/31/08

Emerson 04-10-2008 12:42 PM

Re: Upgrade your store
 
Quote:

Originally Posted by intel352
Padraic/Emerson, unless someone else takes care of it first, I'll look through the proposed fixes in the forum, make sure it applies to all area of X-Cart 4.0, make sure it's in a Patch form, and upload the patch for testers to have a go at it. If one of you guys would be interested in coordinating this, gathering some willing testers, etc, that'd be great.


I am spreading the word out.
If you want let me know and I can setup a server as a test bed.

balinor 04-10-2008 12:48 PM

Re: Upgrade your store
 
That would be great...just get some stock 4.0 carts in various versions set up (after .14 when it was considered "stable") or even some copies of customized ones with lots of mods.

johnrobholmes 04-10-2008 01:15 PM

Re: Upgrade your store
 
I just did some research on what it would take to migrate to another cart, and you are right balinor. It would be more expensive (in time too) to swap out. I don't quite trust carts that don't have something to profit from. Capitalism goes a long way in making sure there are no bugs before a release.


Waiting to hear what I will need to do to stay a viable store. Maybe upgrading to version 4.1 will give me added benefits too?

balinor 04-10-2008 01:17 PM

Re: Upgrade your store
 
To be fair John, there is no way X-Cart could have anticipated what would be required for PHP/MySQL 5 when they first released 4.0, so I wouldn't call it a 'bug'. I do, however, agree that they should have taken the time to release a patch once they realized this would be an issue.

Upgrading to 4.1 does have quite a number of benefits, but you need to weigh those against the cost of doing it. If there aren't specific features you need, it may not be worth the headache and expense.

intel352 04-10-2008 01:28 PM

Re: Upgrade your store
 
4.1 definitely has added benefits, in terms of security, new modules, speed, etc, plus shortening your future upgrade curve.

regarding carts that don't have something to profit, that's a valid business model nowadays actually, as people have found that it's often better to reel someone in with a free product, and make money off of services. in X-Cart's case, they reel people in with a fairly inexpensive product, and make money off of it not being a 100% comprehensive solution :-)



btw, Padraic is correct about headache/expense. 4.0 to 4.1 doesn't have a template/file upgrade, just a db upgrade, so essentially you have to start from scratch with a 4.1 install, and re-implement any customizations

johnrobholmes 04-10-2008 03:37 PM

Re: Upgrade your store
 
I really haven't customized my site at all beyond tweaking the template a bit. I have zero added features beyond what X-Cart supplied me with. Check out the site in my link, pretty basic.


I wan't calling the php upgrade a bug, I was referencing some other cart's that have known issues of security with the download.


All times are GMT -8. The time now is 11:21 AM.

Powered by vBulletin Version 3.5.4
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.