X-Cart: shopping cart software

X-Cart forums (https://forum.x-cart.com/index.php)
-   News and Announcements (https://forum.x-cart.com/forumdisplay.php?f=28)
-   -   X-Cart 5.4.0 Stable Release (https://forum.x-cart.com/showthread.php?t=77025)

mvs 06-29-2019 10:57 AM

X-Cart 5.4.0 Stable Release
 
Hey fellow X-Carters,

Great news! We’ve just released X-Cart 5.4.0 Stable. Upgrade is available in developer mode for now, X-Cart merchants will be able to upgrade within a couple of months.

Check the blog for what’s new there: https://www.x-cart.com/blog/5-4-0-4-stable-released.html

cflsystems 07-01-2019 07:03 AM

Re: X-Cart 5.4.0 Stable Release
 
Max is 5.4.0.4 going to be upgradable? In other words is it ok to start on new integration with it now and not have to start from scratch when it is officially released merchant wave?

mvs 07-01-2019 11:38 AM

Re: X-Cart 5.4.0 Stable Release
 
Quote:

Originally Posted by cflsystems
Max is 5.4.0.4 going to be upgradable? In other words is it ok to start on new integration with it now and not have to start from scratch when it is officially released merchant wave?


Hi,

Yes, it will be upgradable. So you can start new integrations/projects on 5.4.0.4.
We didn't release X-Cart 5.4.0.4 in merchant wave because:
- new upgrade system is in the process of debugging store migration from 5.3.6.x at 5.4.0.x as it's the new complex tool that works separately from the store
- not all third-party addons / themes are adapted for 5.4.0.x

Thanks!

Dougrun 07-19-2019 02:21 PM

Re: X-Cart 5.4.0 Stable Release
 
Upgrade not allowed
X-Cart v5.4 requires MySQL version 5.7.7 or better. Please update the MySQL version installed on your server before you proceed.





I'm on Mariadb 10.3.16.

mvs 07-24-2019 03:24 AM

Re: X-Cart 5.4.0 Stable Release
 
Quote:

Originally Posted by Dougrun
Upgrade not allowed
X-Cart v5.4 requires MySQL version 5.7.7 or better. Please update the MySQL version installed on your server before you proceed.
I'm on Mariadb 10.3.16.

In 5.3.6.3 we will have a fix which allows upgrading the store with MariaDB which provide a version.
5.3.6.3 will be released in merchant wave in September. Please contact our support team and they will be able to apply the hotfix to your store. Keep in mind that 5.4.0.x is still not available in merchant wave to upgrade from 5.3.6.x.

Thanks!


All times are GMT -8. The time now is 03:46 AM.

Powered by vBulletin Version 3.5.4
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.